Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Возвраты в УТ 10

Возвраты в УТ 10
Я
   johnnik
 
04.03.21 - 12:33
Всем привет. У конторы две системы налогообложения: патент для товаров и УСН для масла (подакцизный товар). Соответственно, масла они продают через Реализация + ПКО (или по карте), а все остальное - через чек ККМ. Только вот чеки ККМ при закрытии смены удаляются и сделать возврат по ним невозможно. Если делать возврат через документ "Возврат от покупателя" - то пробивается чек возврата по УСН, а надо по патенту. Если сделать чек ККМ и выбрать вид операции "Возврат", то 1С-ка требует выбрать документ "Чек ККМ" типа как основание для возврата, но чеков то уже нету, удалились при закрытии смены.

Как из ситуации выйти и пробить возвраты по патенту?
   SeriyP
 
1 - 04.03.21 - 12:44
"Только вот чеки ККМ при закрытии смены удаляются" 
Их можно и не удалять

"чек ККМ и выбрать вид операции "Возврат", то 1С-ка требует выбрать документ "Чек ККМ"" 
Так делается в "текущем" числе, вчерашний возврат так оформлять не следует

"Как из ситуации выйти и пробить возвраты по патенту?"
Общие модули / МенеджерОборудованияВызовСервера / ПодготовитьДанныеДляФискализацииЧека - 
ОбщиеПараметры.СистемаНалогообложения = МенеджерОборудованияКлиентСервер.СистемаНалогообложения
        (ОрганизацияЧека, Ссылка.Дата)
здесь доработать до того, что вам нужно.
   SeriyP
 
2 - 04.03.21 - 12:49
Для ОСНО и ЕНВД (было):
Если ОрганизацияЧека.Код <> "000000001" Тогда
    Если  Ссылка.РасшифровкаПлатежа[0].СтавкаНДС = Перечисления.СтавкиНДС.БезНДС Тогда
            СНО = ПредопределенноеЗначение("Перечисление.ТипыСистемНалогообложенияККТ.ЕНВД");
        Иначе
            СНО = МенеджерОборудованияКлиентСервер.СистемаНалогообложения(ОрганизацияЧека, Ссылка.Дата);
        КонецЕсли;
    Иначе
        Если  Ссылка.РасшифровкаПлатежа[0].СтавкаНДС = Перечисления.СтавкиНДС.НДС18 
            ИЛИ Ссылка.РасшифровкаПлатежа[0].СтавкаНДС = Перечисления.СтавкиНДС.НДС20 Тогда//НДС20!

            СНО = ПредопределенноеЗначение("Перечисление.ТипыСистемНалогообложенияККТ.ОСН");
        ИначеЕсли  Ссылка.РасшифровкаПлатежа[0].СтавкаНДС = Перечисления.СтавкиНДС.БезНДС Тогда
            СНО = ПредопределенноеЗначение("Перечисление.ТипыСистемНалогообложенияККТ.ЕНВД");
        Иначе 
            СНО = МенеджерОборудованияКлиентСервер.СистемаНалогообложения(ОрганизацияЧека, Ссылка.Дата);
        КонецЕсли;
    КонецЕсли;
    ОбщиеПараметры.СистемаНалогообложения = СНО;
   johnnik
 
3 - 05.03.21 - 08:39
(1) Спасибо за идею, но у клиента базовая УТ, ее не модицицируешь
   Гипервизор
 
4 - 05.03.21 - 08:54
Настолько древняя УТ у клиента? Архивация чеков появилась в релизе 10.3.43.2 от 28.07.17.
   Йохохо
 
5 - 05.03.21 - 08:58
для чека возврата ут 10 достаточно непроведенной пустышки чека как основания, хранить ее потом или нет сами решайте

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.