Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Забыли пароль от ИТС

Забыли пароль от ИТС
Я
   drhimik
 
01.03.21 - 14:15
Добрый день!

Ситуация стандартная, база 1с ЗиК создана неизвестно когда, сотрудником который уже сто лет не работает в конторе. Соответственно пароля от ИТС никто не знает.

Вроде решение есть, надо добавить обработку:

На управляемой форме создаете два реквизита и кнопку. Код ниже:

&НаСервере
Процедура Команда1НаСервере()
    
    ДанныеАвторизации = ИнтернетПоддержкаПользователей.ДанныеАутентификацииПользователяИнтернетПоддержки();
    
    Попытка
        Для Каждого Элемент Из ДанныеАвторизации Цикл
            Сообщить(Элемент.Ключ + ":  " + Элемент.Значение);
            Если Элемент.Ключ = "Логин" Тогда
                Реквизит1 = Элемент.Значение;
            ИначеЕсли Элемент.Ключ = "Пароль" Тогда
                Реквизит2 = Элемент.Значение;            
            КонецЕсли;
            
        КонецЦикла;
    Исключение
        Сообщить("Нет данных регистрации ИТС.");    
    КонецПопытки

    
КонецПроцедуры

Но так как я криворук и весьма далек от программирования то не могу воспользоваться советом. Есть ли у кого уже готовый файл .epf
   Beduin
 
1 - 01.03.21 - 14:18
Напиши в поддержку, пришлют в течение дня.
   Winnie Buh
 
2 - 01.03.21 - 14:26
вариант 1. если пароль есть в базе, то зайдите в личный кабинет на портале прямо из программы и поменяте пароль
вариант 2. создайте новую учетную запись и перерегистрируйте продукты

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.