Вход | Регистрация
 

Куда сохраняется КУДиР по кнопке Сохранить?

Куда сохраняется КУДиР по кнопке Сохранить?
Я
   Гений 1С
 
01.03.21 - 10:47
Во-первых она сохраняется только если 1С запущена под админом, значит сохраняется в какой-то системный каталог.
Как понять, где ее искать?
   Гений 1С
 
1 - 01.03.21 - 10:49
Речь про БП3, да.
   ДенисЧ
 
2 - 01.03.21 - 10:52
А если не под админом - что говорит?
   Гений 1С
 
3 - 01.03.21 - 11:12
(2) ну там ошибка прав доступа, не заскринил
   Гений 1С
 
4 - 01.03.21 - 11:12
именно ошибка прав доступа к файлу
   Вафель
 
5 - 01.03.21 - 11:13
отладчик вообще влом запускать?
   ДенисЧ
 
6 - 01.03.21 - 11:15
(5) Это не по-гениальносвкому будет
   Гений 1С
 
7 - 01.03.21 - 21:02
Во-первых папка сохранения доступна только если:
    Элементы.ПапкаДляСохраненияФайлов.Видимость = Параметры.РасширениеДляРаботыСФайламиПодключено;

Пишет тут:
    Для Каждого ФайлДляЗаписи Из ПолучаемыеФайлы Цикл
        ДвоичныеДанные = ПолучитьИзВременногоХранилища(ФайлДляЗаписи.Хранение);
        ДвоичныеДанные.Записать(УникальноеИмяФайла(Папка + ФайлДляЗаписи.Имя));
    КонецЦикла;

На вызове УникальноеИмяФайла я и подловил путь:
K:\temp\SYSTEM\v8_23A4_25.tmp\КУДиР 01.01.2020 0 00 00 - 31.12.2020 0 00 00 Титульный лист.pdf

Сюда он записать не может:

Ошибка доступа к файлу 'КУДиР 01.01.2020 0 00 00 - 31.12.2020 0 00 00 Титульный лист.pdf'. 5(0x00000005): Отказано в доступе.
{Отчет.КнигаУчетаДоходовИРасходов.Форма.ФормаОтчета.Форма(1099)}:        ДвоичныеДанные.Записать(УникальноеИмяФайла(Папка + ФайлДляЗаписи.Имя));
{ОбщийМодуль.ФайловаяСистемаСлужебныйКлиент.Модуль(1109)}:    ВыполнитьОбработкуОповещения(ОповещениеОЗакрытии, РасширениеПодключено);
{ОбщийМодуль.ФайловаяСистемаКлиент.Модуль(756)}:    ВыполнитьОбработкуОповещения(ОписаниеОповещенияЗавершение, "ПодключениеНеТребуется");
{ОбщийМодуль.ОбщегоНазначенияКлиент.Модуль(1238)}:    ФайловаяСистемаКлиент.ПодключитьРасширениеДляРаботыСФайлами(
{Отчет.КнигаУчетаДоходовИРасходов.Форма.ФормаОтчета.Форма(1073)}:    ОбщегоНазначенияКлиент.ПоказатьВопросОбУстановкеРасширенияРаботыСФайлами(ОписаниеОповещения);
{Отчет.КнигаУчетаДоходовИРасходов.Форма.ФормаОтчета.Форма(1052)}:            СохранитьПечатныеФормы(ФайлыВоВременномХранилище, ВыбранноеЗначение.ПапкаДляСохранения);
{ОбщаяФорма.СохранениеПечатнойФормы.Форма(149)}:    ОповеститьОВыборе(РезультатВыбора);

по причине:
Ошибка доступа к файлу 'КУДиР 01.01.2020 0 00 00 - 31.12.2020 0 00 00 Титульный лист.pdf'. 5(0x00000005): Отказано в доступе.
   Гений 1С
 
8 - 01.03.21 - 21:12
Проблема в том, что КУДиР сохраняется так:

&НаКлиенте
Процедура Сохранить(Команда)
    
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ОбъектыПечати", Новый СписокЗначений);
    ОткрытьФорму("ОбщаяФорма.СохранениеПечатнойФормы", ПараметрыФормы, ЭтотОбъект);
    
КонецПроцедуры

т.е. в параметрах не передается РасширениеДляРаботыСФайламиПодключено, но оно почему-то установлено в ложь.
Но все же это свойство где-то назначается в параметрах, иначе бы при проверке Параметры.РасширениеДляРаботыСФайламиПодключено оно бы вылетало.
Это как? что за свойство такое? поясните мне механику...
А, хотя это параметр формы (новый механизм), в закладках. Ок.


Вот тут есть ссылочка, как включить расширение:
Администрирование - Настройки - Персональные настройки - Установить расширение работы с файлами
v8: Как подключить расширения работы с файлами



Вот в модуле ПечатьДокументов вызов делается правильно:

&НаКлиенте
Процедура ПриПодключенииРасширения(РасширениеПодключено, ДополнительныеПараметры) Экспорт
    
    РасширениеДляРаботыСФайламиПодключено = РасширениеПодключено;
    
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ОбъектыПечати", ОбъектыПечати);
    ПараметрыФормы.Вставить("РасширениеДляРаботыСФайламиПодключено", РасширениеПодключено);
    ОткрытьФорму("ОбщаяФорма.СохранениеПечатнойФормы", ПараметрыФормы, ЭтотОбъект);

КонецПроцедуры


В общем, короче, косяк 1С. Сообщите кто-нибудь на Селезневскую
   ПрестарелыйЗаяц
 
9 - 01.03.21 - 21:21
(9) У нищих слуг нет, так что как-то сам.
   Гений 1С
 
10 - 01.03.21 - 21:36
(9) ну я лично для себя вопрос решил печатью в PDF, а там глядишь сорока донесет в отдель борьбы с ошибками 1С про этот баг и они поправят КУДиР. ;-)
   hhhh
 
11 - 02.03.21 - 00:23
(8) РасширениеДляРаботыСФайламиПодключено это для Веб-клиента, а у вас обычный тонкий. Там это расширение не нужно.
   Гений 1С
 
12 - 02.03.21 - 07:13
(11) Спасибо, КЭП, но в 1С об этом не знают. Если не осилил текст сообщения, то там криво вызывается форма сохранения из отчета КУДиР, типичный баг 1с.
   dangerouscoder
 
13 - 02.03.21 - 11:15
(7) доступ дай )))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.