Вход | Регистрация
 

Обновил БСП с 2 на 3 - слетели настройки универсального отчета

Обновил БСП с 2 на 3 - слетели настройки универсального отчета
Я
   RomaH
 
01.03.21 - 08:53
Как восстановить?

выгрузка настроек и загрузка в новую версию не помогает
должна же быть технология перехода - подскажете?
   AceVi
 
1 - 01.03.21 - 09:30
А раскроешь секрет - как это обновил БСП?
БСП - же вроде встраивается в конфигурацию и имеет привязку к номеру платформы(и режиму совместимости соответственно)
как можно обновить БСП в отдельности от самой конфигурации? или БСП полностью самостоятельна??
   RomaH
 
2 - 01.03.21 - 09:38
БСП - это подсистема состоящая из подсистем
как-то вот у меня получается обновлять, например, работу с контактной информацией из новой версии БСП, ну почти

аналогично вот добавил "Контроль учета" из 3.1, хотя большинство подсистем БСП из 2
затронул "Универсальный отчет" и началось...

варианты вроде обновил - теперь формирует, но не показывает объект метаданных на котором основывается

https://ibb.co/tzkTjk8
   RomaH
 
3 - 01.03.21 - 09:38
варианты так обновил:


&НаКлиенте
Процедура Команда1(Команда)
    Команда1НаСервере();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура Команда1НаСервере()
    Параметры = ОбновлениеИнформационнойБазы.ОсновныеПараметрыОтметкиКОбработке();
    Параметры.Очередь = 1;
    Справочники.ВариантыОтчетов.ЗарегистрироватьДанныеКОбработкеДляПереходаНаНовуюВерсию(Параметры);
КонецПроцедуры

&НаКлиенте
Процедура Команда2(Команда)
    Команда2НаСервере();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура Команда2НаСервере()
    Параметры = ОбновлениеИнформационнойБазы.ОсновныеПараметрыОтметкиКОбработке();
    Параметры.Очередь = 1;
    Параметры.Вставить("ОбработкаЗавершена", Ложь);
    Справочники.ВариантыОтчетов.ОбработатьДанныеДляПереходаНаНовуюВерсию(Параметры);
КонецПроцедуры
   Фрэнки
 
4 - 01.03.21 - 09:41
Если обсуждаемая версия БСП соответствует актуальным типовым, то загрузка сохраненных настроек универсального отчета в таких БСП становится доступна после того, как в открытом отчете сделан возврат к стандартным. Т.е. до возврата к стандартным этого в пункта в командной панели на форме для универсального отчета просто не видно.
Думаю, что это баг, который не досмотрели при тестировании.
   Фрэнки
 
5 - 01.03.21 - 09:42
* к стандартным _настройкам_ _отчета_
   Фрэнки
 
6 - 01.03.21 - 09:44
Еще предположение, что в режиме предприятия в обработке загружаемых настроек отчета есть какие-то ошибки и отказы, но их не отображают почему-то в виде сообщений. Посмотреть журнал, возможно, что там инфа какая-то об этом событии регистрируется.
   RomaH
 
7 - 01.03.21 - 10:16
вот такой костыль вставил:

Процедура ПередЗагрузкойНастроекВКомпоновщик(Контекст, КлючСхемы, КлючВарианта, Настройки, ПользовательскиеНастройки) Экспорт
    ТекущийКлючСхемы = Неопределено;
    
    Если Настройки = Неопределено Тогда 
        Настройки = КомпоновщикНастроек.Настройки;
    КонецЕсли;
    
    ЭтоЗагруженнаяСхема = Ложь;
    ДвоичныеДанныеСхемы = ОбщегоНазначенияКлиентСервер.СвойствоСтруктуры(
        Настройки.ДополнительныеСвойства, "СхемаКомпоновкиДанных");
    
    Если ТипЗнч(ДвоичныеДанныеСхемы) = Тип("ДвоичныеДанные") Тогда
        ТекущийКлючСхемы = ХешДвоичныхДанных(ДвоичныеДанныеСхемы);
        Если ТекущийКлючСхемы <> КлючСхемы Тогда
            Схема = Отчеты.УниверсальныйОтчет.ИзвлечьСхемуИзДвоичныхДанных(ДвоичныеДанныеСхемы);
            ЭтоЗагруженнаяСхема = Истина;
        КонецЕсли;
    КонецЕсли;
    
    ДоступныеЗначения = Неопределено;
    
    //Костыль

    
    ПараметрыДанныхИмяОбъектаМетаданных = Настройки.ПараметрыДанных.Элементы.Найти("ИмяОбъектаМетаданных"); 
    Если ПараметрыДанныхИмяОбъектаМетаданных <> Неопределено И ПараметрыДанныхИмяОбъектаМетаданных.ИдентификаторПользовательскойНастройки = "" Тогда
        ПараметрыДанныхИмяОбъектаМетаданных.ИдентификаторПользовательскойНастройки = "" + Новый УникальныйИдентификатор;    
    КонецЕсли;
    
    //Костыль

    
    ФиксированныеПараметры = Отчеты.УниверсальныйОтчет.ФиксированныеПараметры(


где-то ИдентификаторПользовательскойНастройки  потерялся при обновлении

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.