Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка в выражении

Ошибка в выражении
Я
   KoalaJustKoala
 
01.03.21 - 06:32
Доброго времени суток, я тут начал с флажками разбираться и тут ни с того, ни с сего выдает мне ошибку в этой процедуре:
Процедура ТабПриИзмененииФлажка(Элемент, Колонка)
    Если Колонка.Имя = “ПроверкаПриход” Тогда
        НайденныйЭлемент =  ОтмеченныеСтроки.НайтиПоЗначению(Элемент.ТекущаяСтрока);
        Если НайденныйЭлемент = Неопределено Тогда
            ОтмеченныеПользователи.Добавить(Элемент.ТекущаяСтрока);
        Иначе
            ОтмеченныеПользователи.Удалить(НайденныйЭлемент);
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

В 1м если, именно где Колонка.Имя = “ПроверкаПриход”
Подскажите пожалуйста :3
   ДенисЧ
 
1 - 01.03.21 - 06:35
Картинки показывай, а не TheBeatles в перепевке Рабиновича по межпланетному телефону.
   KoalaJustKoala
 
2 - 01.03.21 - 06:40
Вот картинка модуля со свойствами
http://pics.rsh.ru/img/_oxlkwn62.png
   KoalaJustKoala
 
3 - 01.03.21 - 06:41
Со свойствами конкретной колонки*
   ДенисЧ
 
4 - 01.03.21 - 06:42
(2) А код ты преднамеренно скрыл?
   KoalaJustKoala
 
5 - 01.03.21 - 06:43
Брал информацию отсюда, без групповой отметки
https://zapiskiprogrammistki.uz/2020/04/21/1s-flazhki-v-tablichnom-pole.html

Вот сам код:
http://pics.rsh.ru/img/_cnjbz3q8.png
   KoalaJustKoala
 
6 - 01.03.21 - 06:43
(4) Нее, просто скинуть не успел как раз скрин делал
   KoalaJustKoala
 
7 - 01.03.21 - 06:44
Кстати, щас еще события зафотаю с таб. поля
   KoalaJustKoala
 
8 - 01.03.21 - 06:44
   ДенисЧ
 
9 - 01.03.21 - 06:44
Мммм.. А что там это за кавычки у тебя кривые какие-то? Косоглазые?
Сотри кавычки и напиши руками.
   KoalaJustKoala
 
10 - 01.03.21 - 06:49
(9) О, так, что-то заработало и выдало еще тонну ошибок, но это уже что-то спасибо!
   DrZombi
 
11 - 01.03.21 - 09:33
(0) Отладку запусти.

Как работать с отладкеой.
https://programmist1s.ru/otladka-1s/

Галочку поставь "Останавливаться по ошибке"
https://programmist1s.ru/wp-content/uploads/2013/06/ostanovka-po-oshibke.png
   KoalaJustKoala
 
12 - 01.03.21 - 11:44
(11) Я пока не научился колдовать с отладкой :(
   ДенисЧ
 
13 - 01.03.21 - 11:46
(11) Причём тут отладка, если у него синтаксическая ошибка?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.