Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Работа с файлами на мобильном клиенте

Работа с файлами на мобильном клиенте
Я
   irlandets1980
 
24.02.21 - 22:07
Всем доброго времени суток. Столкнулся с проблемой - написал мобильный клиент к самописной конфигурации. Не могу выбрать файл на устройстве(андроид).

#Если МобильныйКлиент Тогда
        Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
        Если Диалог.Выбрать() Тогда
            БинДанные = Новый ДвоичныеДанные(Диалог.ПолноеИмяФайла);
            АдресВременногоХранилища = ПоместитьВоВременноеХранилище(БинДанные, ЭтаФорма.УникальныйИдентификатор);
        КонецЕсли;
  #КонецЕсли

Получаю на телефоне ошибку после выбора файла :
Ошибка доступа к файлу '/storage/emulated/0/DCIM/Camera/202/10212_14101.jpg'
Ошибка при создании двоичных данных.
Подскажите куда копать)
   ejikbeznojek
 
1 - 24.02.21 - 22:57
Может разрешения попробовать дать приложению на телефоне?
   polosov
 
2 - 24.02.21 - 23:04
8.3.18.1208
Нет такой проблемы.

&НаКлиенте
Асинх Процедура ОткрытьФайлТест(Команда)
    
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Диалог.Заголовок = "Выбери файл:";
    
    Результат = Ждать Диалог.ВыбратьАсинх(); 
    Если Результат <> Неопределено И Результат.Количество() > 0 Тогда
        
        БинДанные = Новый ДвоичныеДанные(Результат[0]);
        АдресВременногоХранилища = ПоместитьВоВременноеХранилище(
                                БинДанные, ЭтаФорма.УникальныйИдентификатор);        
    Иначе
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "Не выбран каталог";
        Сообщение.Сообщить();
    КонецЕсли;

КонецПроцедуры

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.