Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

1с8 обычное приложение, внешние печатные формы

1с8 обычное приложение, внешние печатные формы
Я
   buketovav
 
24.02.21 - 21:57
Доброго дня, Дорогие Форумчане!

Ранее не работал с обычным приложением.
Столкнулся с такой проблемой, сделал внешнюю ПФ, добавил ее в систему, команда выводится в документе, но команда недоступна для использования, не активная.

Подскажите, пожалуйста, что может быть не правильно и куда вообще копать?

https://prnt.sc/105uyg2
   ДНН
 
1 - 24.02.21 - 22:03
(0) наверно в модуле формы документа блокируется.
А так качай готовые шаблоны за стартмани http://catalog.mista.ru/public/1236630/
   buketovav
 
2 - 24.02.21 - 22:58
(1) нет стартмани ))) да шаблоны то я и сам умею делать, не могу найти где блокируется, остальное то все работает. Если обработку открываю через Файл - Открыть. то все работает и формируется как надо.
   hhhh
 
3 - 24.02.21 - 23:05
(2) навскидку, отсутствует Печать() в модуле объекта, ну или она неэкспортная.
   buketovav
 
4 - 24.02.21 - 23:08
(3) https://prnt.sc/105w6na
да вроде бы есть
   buketovav
 
5 - 24.02.21 - 23:11
(4) это в модуле внешней обработки
   RomanYS
 
6 - 24.02.21 - 23:20
(0) Что за конфигурация? Вроде в типовых не было такой фишки: показывать недоступные формы.
Документ типовой?
В справочнике обработок файл к шапке привязан или в ТЧ добавлен?
   buketovav
 
7 - 24.02.21 - 23:23
(6) 1С-Рарус: Бэк-офис, редакция 5 (05.03.02.16)
Док нетиповой
https://prnt.sc/105wfy8
   RomanYS
 
8 - 24.02.21 - 23:27
(7) Может в подключении подсистемы печати в документе что-то не прописал.
Ну и возможно рарус какую-нибудь подсистему прав прикрутил к ВПФ
   buketovav
 
9 - 24.02.21 - 23:29
(8) ну мож и так... буду искать... если у кого-нибудь будут еще мысли, то с удовольствием приму к сведению
   RomanYS
 
10 - 24.02.21 - 23:29
(8) Чтобы проверить и то и другое достаточно привязать (можно даже пустую) ВПФ к типовому документу.
   RomanYS
 
11 - 24.02.21 - 23:30
(9) Ну и по замеру производительности можно поискать "Доступность", "ТолькоПросмотр"...
   buketovav
 
12 - 24.02.21 - 23:33
(11) спасибо большое, сейчас буду пробовать
   buketovav
 
13 - 24.02.21 - 23:50
ни чего подходящего и похожего не нашел... везде используется один и тот же код, код из типового документа

Процедура УстановитьКнопкиПечати()
    
    мДеревоМакетов = ПолучитьДеревоМакетовПечати(Ссылка, ПолучитьСтруктуруПечатныхФорм(), Новый Действие("ОсновныеДействияФормыПечать"), Новый Действие("ОсновныеДействияФормыУстановитьПечатьПоУмолчанию"));
    
    УстановитьПодменюПечати    (мПодменюПечати, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов.Строки.Количество() > 0);
    УстановитьПечатьПоУмолчанию(мПечатьПоУмолчанию, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов, Метаданные().Имя,Новый Действие("ОсновныеДействияФормыПечатьПоУмолчанию"));
    
    Если Не мПодменюПечати = Неопределено Тогда
        СформироватьПодменю(мДеревоМакетов, мПодменюПечати,Истина,Истина);
    КонецЕсли;     
    
    
КонецПроцедуры
   RomanYS
 
14 - 24.02.21 - 23:55
(13) по идее в форме какая-то процедура-обработчик должна быть. Очень похоже что у тебя ее нет
   buketovav
 
15 - 24.02.21 - 23:57
видимо так и есть, продолжаю поиски
   RomanYS
 
16 - 25.02.21 - 00:32
// Процедура - обработчик нажатия на кнопку "Печать".

// Открывает форму выбора печатных форм объекта.
//

Процедура ОсновныеДействияФормыПечать(Кнопка)
    
    УниверсальныеМеханизмы.ОткрытьФормуВыбораПечатныхФормОбъекта(ЭтотОбъект, ЭтаФорма);
    
КонецПроцедуры// ОсновныеДействияФормыПечать()


// Процедура - обработчик нажатия на кнопку "Печать по умолчанию"

//
Процедура ОсновныеДействияФормыПечатьПоУмолчанию(Кнопка)
    
    УниверсальныеМеханизмы.НапечататьДокументПоУмолчанию(ЭтотОбъект);
    
КонецПроцедуры
   Cthulhu
 
17 - 25.02.21 - 00:44
она там повторного использования вроде. проца которая составляет для определенного вида документа список печ.форм. при первом открытии дока можно только в нее попасть.
   Cthulhu
 
18 - 25.02.21 - 00:45
(17): это к (11)+(12)+(13)
   buketovav
 
19 - 25.02.21 - 00:56
(16) после добавления этих процедур команды стали активны, но это моя система не умеет делать - УниверсальныеМеханизмы.ОткрытьФормуВыбораПечатныхФормОбъекта(ЭтотОбъект, ЭтаФорма);
теперь разбираюсь дальше как заставить ее формировать пф
   vfire1000
 
20 - 25.02.21 - 09:20
Офф

(0) >>Ранее не работал с обычным приложением.

Ранее, на меня говорили: "Вот и подросло то поколение, которое не работало в 77"

Сейчас, я могу сказать: "Вот и подросло то поколение, которое не работало с обычными формами"

Можно считать, что я старый? )
   buketovav
 
21 - 25.02.21 - 09:28
(20) Вы ведь не знаете сколько лет мне и в каком возрасте я пришел в 1с )
просто сложилось так, что, везде, где я работал, использовалась 1с83, поэтому опыта работы с обычными формами получить попросту было негде
   buketovav
 
22 - 25.02.21 - 09:28
но вопрос я так и не решил (
   ДенисЧ
 
23 - 25.02.21 - 09:30
(21) Видишь и в чём дело... Если "везде, где я работал, использовалась 1с83" - то это явно говорит о сроке и годах вхождения ))))
Так что не обижайся, когда тебя молодёжью назыают )))
   buketovav
 
24 - 25.02.21 - 09:38
(23) яне обижаюсь, в моем возрасте это комплимент )
   ptiz
 
25 - 25.02.21 - 10:06
(22) Открой БП 2.0 или УТ 10.3 - там всё есть.
   buketovav
 
26 - 25.02.21 - 23:29
вот этого не хватало в самописном документе, чтобы заработали печатные формы
// Процедура - обработчик нажатия на кнопку "Печать".

Процедура ОсновныеДействияФормыПечать(Кнопка)
    
    ПечатьПоДополнительнойКнопке(мДеревоМакетов, ЭтотОбъект, ЭтаФорма, Кнопка.Текст);
    
КонецПроцедуры


// Процедура - обработчик нажатия на кнопку "Печать по умолчанию"

Процедура ОсновныеДействияФормыПечатьПоУмолчанию(Кнопка)
    
       Если НазначитьКнопкуПечатиПоУмолчанию(мДеревоМакетов, Метаданные().Имя) Тогда
        
        УстановитьКнопкиПечати();
        
    КонецЕсли; 
    
КонецПроцедуры


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.