Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ландшафт и Портрет в одном табличном документе

Ландшафт и Портрет в одном табличном документе
Я
   Snail
 
24.02.21 - 15:20
В табдоке есть 2 области (печатаются по условию)
Если А=1 Тогда
   ТабДок.Вывести(Шапка1);
   ......
КонецЕсли

Если А=2 Тогда
   ТабДок.Вывести(Шапка2);
   ......
КонецЕсли

Все это формируется для печати, но как сделать так, чтобы если а=1 тогда ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
   Малыш Джон
 
1 - 24.02.21 - 15:23
Если А=1 Тогда
    ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
Иначе
    ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
КонецЕсли;
   Малыш Джон
 
2 - 24.02.21 - 15:23
Не?
   Snail
 
3 - 24.02.21 - 15:24
Все в портрет переводит(
По последнему ОриентацияСтраницы.Портрет;
   polosov
 
4 - 24.02.21 - 15:32
(3) Пробуй через ПакетОтображаемыхДокументов
   Малыш Джон
 
5 - 24.02.21 - 15:32
(3) Возможно твой принтер - художник в душе. Художик-портретист.

Вообще любой документ переводит в портрет? Если отдельно где-нибудь сформировать табдок с ландшафтной ориентацией и пустить на принтер - тоже  портрет получится?
   Snail
 
6 - 24.02.21 - 15:34
Нет, не переводит. Если ворд - ладншафт тогда ландшафт и наоборот
   Йохохо
 
7 - 24.02.21 - 15:38
инициализировать ключ параметров печати до всех еслей
   Snail
 
8 - 24.02.21 - 15:43
Йохохо, приведи пример такого шаманства, я еще такого не делал :)
   Йохохо
 
9 - 24.02.21 - 15:44

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.