Вход | Регистрация
 

Помогите решить проблему начинающему, пожалуйста

Помогите решить проблему начинающему, пожалуйста
Я
   Varlant1n
 
22.02.21 - 18:24
Здравствуйте. Есть процедура:

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
   Если ИмяСобытия = "Выбор" И ТипЗнч(Параметр) = Тип("ДокументСсылка.ЗаказПоставщику") Тогда
      Объект.ЗаказКлиента = Параметр;
      ЗаполнитьДанныеПоЗаказуНаСервере(Истина);
   КонецЕсли;
КонецПроцедуры

И есть процедура:
&НаКлиенте
Процедура Обработать(Данные)
   Если ТипЗнч(Параметр) <> Тип("ДокументСсылка.ЗаказКлиента") Тогда
    ///////////    
   КонецЕсли;
КонецПроцедуры

Мне нужно использовать это условие, но я не знаю как сюда передать "Параметр".... Не смейтесь и не ругайтесь, я знаю, вы умеете.
Переменная не определена (Параметр)
   acht
 
1 - 22.02.21 - 18:43
Как это вообще все взаимосвязано?
   Гений 1С
 
2 - 22.02.21 - 18:45
(1) +1. Откуда вызывается Обработать?
   Fedor-1971
 
3 - 23.02.21 - 10:18
(0) Вызываешь на клиенте Оповестить(<ИмяСобытия>, <Параметр>, <Источник>), например, так
Оповестить("Выбор", Объект.Ссылка); 
в ОбработкуОповещения прилетит твой параметр. 

Только есть особенность: Оповестить работает в одном сеансе, т.е. если ты откроешь 2 экземпляра 1С, то Опопвестить будет работать только в том, где вызвана, второй про неё ничего не узнает

По коду:
Обработать(Данные) - тут Данные
   Если ТипЗнч(Параметр) - но проверяем Параметр

Ничего не перепутал?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.