Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Передать параметр с двумя значениями в отбор при открытии формы.

Передать параметр с двумя значениями в отбор при открытии формы.
Я
   AlekseiYunniPodavvan
 
19.02.21 - 18:56
Добрый вечер! Словил затуп. Подскажите пожалуйста как передать нескоько значений в параметр подбора, с мое случае нужно 2 типа налогооблажения.
Сейчас выглядит так:
ПараметрыПодбора.Вставить("НалогообложениеНДС", Объект.НалогообложениеНДС);
Заранее признателен!
   lubitelxml
 
1 - 19.02.21 - 19:03
Ну так и передавай массив, единственный момент - посмотри как дальше это поля разбирается, возможно в параметры запроса, тогда в запросе "=" на "В" придется заменить
   AlekseiYunniPodavvan
 
2 - 19.02.21 - 19:12
поправьте если неправильно понимаю, параметр подбора в запрос не передается, работает непосредственно с отбором при заполнении
   lubitelxml
 
3 - 19.02.21 - 19:17
"работает непосредственно с отбором при заполнении" - код покажи
   Cyberhawk
 
4 - 19.02.21 - 19:19
Передача отбора (через параметры открываемой формы) работает только как "Равно".
Для остальных способов придется внедряться в код открываемой формы.
   AlekseiYunniPodavvan
 
5 - 19.02.21 - 19:19
&НаКлиенте
Процедура ПодборТоваровПоРеализациям()
    
    Отказ = Ложь;
    ОчиститьСообщения();
    
    ВозвратОтРозничногоПокупателя = Ложь;
    
    Если Объект.ХозяйственнаяОперация = ПредопределенноеЗначение("Перечисление.ХозяйственныеОперации.ВозвратОтРозничногоПокупателя") Тогда
        ВозвратОтРозничногоПокупателя = Истина;
    КонецЕсли;
    
    Если Не ЗначениеЗаполнено(Объект.Валюта) Тогда
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(
            НСтр("ru = 'Поле ""Валюта"" не заполнено';
                |en = '""Currency"" is required'"),
            Объект.Ссылка, "Объект.Валюта",
            ,
            Отказ);
    КонецЕсли;
    
    Если Не ЗначениеЗаполнено(Объект.НалогообложениеНДС) Тогда
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(
            НСтр("ru = 'Поле ""НалогообложениеНДС"" не заполнено';
                |en = '""VAT taxation"" is required'"),
            Объект.Ссылка, "Объект.НалогообложениеНДС",
            ,
            Отказ);
    КонецЕсли;
    
    Если НЕ ЗначениеЗаполнено(Объект.Организация) Тогда
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(
            НСтр("ru = 'Поле ""Организация"" не заполнено';
                |en = '""Company"" is required'"),
            Объект.Ссылка, "Объект.Организация",
            ,
            Отказ);
    КонецЕсли;
    
    Если НЕ ЗначениеЗаполнено(Объект.Партнер) Тогда
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(
            НСтр("ru = 'Поле ""Клиент"" не заполнено';
                |en = '""Customer"" is required'"),
            Объект.Ссылка, "Объект.Партнер",
            ,
            Отказ);
    КонецЕсли;
    
    Если Не ИспользоватьПартнеровКакКонтрагентов Тогда
        Если НЕ ЗначениеЗаполнено(Объект.Контрагент) Тогда
            ОбщегоНазначенияКлиентСервер.СообщитьПользователю(
            НСтр("ru = 'Поле ""Контрагент"" не заполнено';
                |en = '""Counterparty"" is not filled in'"),
            Объект.Ссылка, "Объект.Контрагент",
            ,
            Отказ);
        КонецЕсли;
    КонецЕсли;
    
        
    Если Не Отказ Тогда
        
        ПараметрыПодбора = Новый Структура;
        ПараметрыПодбора.Вставить("ДокументВозврата", Объект.Ссылка);
        ПараметрыПодбора.Вставить("Валюта", Объект.Валюта);
        ПараметрыПодбора.Вставить("Дата", ?(ЗначениеЗаполнено(Объект.Дата), Объект.Дата, ОбщегоНазначенияКлиент.ДатаСеанса()));
        ПараметрыПодбора.Вставить("ЦенаВключаетНДС", Объект.ЦенаВключаетНДС);
        ПараметрыПодбора.Вставить("Склад", Объект.Склад);
        ПараметрыПодбора.Вставить("ОтборПоСкладу", Истина);

        
        ПараметрыПодбора.Вставить("НалогообложениеНДС", Объект.НалогообложениеНДС);


        ПараметрыПодбора.Вставить("Партнер", Объект.Партнер);
        ПараметрыПодбора.Вставить("Контрагент", Объект.Контрагент);
        ПараметрыПодбора.Вставить("Соглашение", Объект.Соглашение);
        ПараметрыПодбора.Вставить("Договор", Объект.Договор);
        ПараметрыПодбора.Вставить("Организация", Объект.Организация);
        ПараметрыПодбора.Вставить("ВозвратОтРозничногоПокупателя", ВозвратОтРозничногоПокупателя);
        ПараметрыПодбора.Вставить("ЧекККМ", Объект.ЧекККМ);
        ПараметрыПодбора.Вставить("ПоказыватьТовары", Истина);
        ПараметрыПодбора.Вставить("ПоказыватьТару", Не ВозвратОтРозничногоПокупателя И Объект.ВозвратПереданнойМногооборотнойТары);
        ПараметрыПодбора.Вставить("НаправлениеДеятельности", Объект.НаправлениеДеятельности);
        
        ОткрытьФорму(
            "ОбщаяФорма.ПодборТоваровПоРеализациямИПередачам",
            ПараметрыПодбора,
            ЭтаФорма);
        
    КонецЕсли;
    
КонецПроцедуры
   AlekseiYunniPodavvan
 
6 - 19.02.21 - 19:20
(4) придется в форму лезть. Спасибо
   Вафель
 
7 - 19.02.21 - 19:32
проще форму открыть и установить отбор списка
   AlekseiYunniPodavvan
 
8 - 19.02.21 - 19:36
(7) пошел этим путем

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.