Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Реквизиты управляемой формы.

Реквизиты управляемой формы.
Я
   MadChild
 
18.02.21 - 13:54
Доброго дня всем!

Помогите, пожалуйста. На форме есть реквизиты из них мне нужны: КолВо_1, КолВо_2 и КолВо_3.
Программно получаю:

&НаСервере
Процедура ААААА()
МассивРекДляУдаления = Новый Массив;
    ВсеРеквизиты = ЭтаФорма.ПолучитьРеквизиты();
    Для Каждого Элемент из ВсеРеквизиты цикл
        Если Лев(Элемент.Имя,6)="КолВо_" тогда
            // Получаем значение нужного реквизита
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры    

Вопрос собственно - как получить значение реквизита?
   Classic
 
1 - 18.02.21 - 14:02
ЭтаФорма[Элемент.Имя]
   fisher
 
2 - 18.02.21 - 14:17
(1) Это если имя элемента и реквизита-источника данных совпадает.
   fisher
 
3 - 18.02.21 - 14:18
А, тьфу, туплю. Это же и есть реквизиты, а не элементы формы.
   Kassern
 
4 - 18.02.21 - 14:23
(0) Для к=1 по 3 Цикл
ЗначениеРеквизита=ЭтаФорма["КолВо_"+к]
КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.