Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не записывается измерение в регистр

Не записывается измерение в регистр
Я
   axeJl_
 
16.02.21 - 04:53
Здравствуйте, подскажите пожалуйста почему не записываются измерения в регистр. Считываю данные из регистра записываю их в табличную часть документа, потом редактирую данные после чего записываю в тот же регистр из которого считал. Все данные записываются кроме измерений.

[CODE]
Процедура ОбработкаПроведения(Отказ, Режим)
    Движения.ДрагМеталлы.Записывать = Истина;
    Для Каждого ТекСтрокаТабличнаяЧасть1 Из ТабличнаяЧасть1 Цикл
        Движение = Движения.ДрагМеталлы.Добавить();
        Если ТекСтрокаТабличнаяЧасть1.ВидДвижения = "Приход" Тогда
            Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
        Иначе
            Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
        КонецЕсли;
        Движение.Период = Дата;
        Движение.Материал = ТекСтрокаТабличнаяЧасть1.Материал;        
        Движение.ДрагМеталл = ТекСтрокаТабличнаяЧасть1.ДрагМеталл;
        Движение.Количество = ТекСтрокаТабличнаяЧасть1.Количество;
        Движение.Содержание = ТекСтрокаТабличнаяЧасть1.Содержание;
        Движение.КоличествоДр = ТекСтрокаТабличнаяЧасть1.КоличествоДр;
    КонецЦикла;
КонецПроцедуры
[/CODE]


Поля "Материал" и "ДрагМеталл"  это измерения и они не записываются просто пустое поле (хотя когда делаю вывод через "Сообщить" это измерение выводится), другие поля нормально записываются.
 
 Партнерская программа EFSOL Oblako
   hhhh
 
1 - 16.02.21 - 05:02
(0) типы проверьте. какой тип у поля ТекСтрокаТабличнаяЧасть1.Материал  ?
   axeJl_
 
2 - 16.02.21 - 05:08
(1) Строка
   hhhh
 
3 - 16.02.21 - 05:11
(2) сомневаюсь, что в Движение.Материал должна быть строка. Там должен быть справочник, если не ошибаюсь.
   axeJl_
 
4 - 16.02.21 - 05:20
Я этот документ сам создал и в нем соответственно табличную часть, там у всех полей тип строка по умолчания вроде как я ничего не изменял. Но другие же поля записываются, все кроме измерений.
   axeJl_
 
5 - 16.02.21 - 05:21
И в этот же регистр я записываю данные только уже из другого документа, который уже был создан и там все нормально записывается и даже измерения.
   hhhh
 
6 - 16.02.21 - 05:31
(4) у вас разные типы. Поэтому не записывается. Причем тут, измерение или не измерение. Другие поля - это тип число или строка, поэтому записываются. Если сделаете в регистре тип строка, тогда запишется.
   ДенисЧ
 
7 - 16.02.21 - 05:36
@у всех полей тип строка по умолчания вроде как я ничего не изменял@

Скажите, а в моргах сегодня свободные места есть? Тут пациент образовался...
   axeJl_
 
8 - 16.02.21 - 05:38
(7) Клоун попроще общайся, я только начал изучать 1С
   Йохохо
 
9 - 16.02.21 - 05:48
(8) а ты кучино с купчино не попутаешь, спишись с Решил отдать книги по программированию даром. Самовывоз.
   axeJl_
 
10 - 16.02.21 - 05:51
(9) Зачем мне этот мусор?

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.