Вход | Регистрация
 

Передача результата на клиента

Передача результата на клиента
Я
   fedotov_andrey
 
15.02.21 - 21:00
Подскажите, только учусь :)
Две процедуры, одна на клиенте, другая на сервере

&НаКлиенте
Процедура ПолучитьМассив(Команда)
    ПолучитьМассивНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПолучитьМассивНаСервере()
    
    ЗАПРОС_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
КонецПроцедуры

На сервере все разложил по переменным, как теперь на клиенте получить эти значения? а вообще нужен мнагомерный массив из значений.
 
 Партнерская программа EFSOL Oblako
   fedotov_andrey
 
1 - 15.02.21 - 21:07
*многомерный))
   acht
 
2 - 15.02.21 - 21:13
&НаСервере
Функция ПолучитьМассивНаСервере()
    
    ЗАПРОС_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

    Возврат СФОРМИРОВАННЫЕ_ДАННЫЕ;

КонецФункции

Но необходимость этих данных на клиненте сомнительна. У тебя на сервере будет доступен контекст формы, поэтому, наверно, лучше:

&НаСервере 
Процедура ПолучитьМассивНаСервере()
    
    ЗАПРОС_ДАННЫХ
    ОБРАБОТКА_ДАННЫХ_В_КОНТЕКСТЕ_ФОРМЫ

КонецПроцедуры
   fedotov_andrey
 
3 - 15.02.21 - 21:18
(2) у меня в клиентской процедуре сейчас массив. Я  данные массива поместил в справочник.
Может сам подход не верный?
   acht
 
4 - 15.02.21 - 21:31
(3) > Я  данные массива поместил в справочник
Это как? Какая вообще задача решается?
   fedotov_andrey
 
5 - 15.02.21 - 21:47
(4)  Сейчас обычный массив, в котором есть числовые значения. В процедуре на клиенте используется каждое значение для вычислений.
Я хотел перенести все эти значения в справочник, чтобы не жестко их прописывать в коде, а дать пользователю возможность добавить значения.
   acht
 
6 - 15.02.21 - 21:51
(5)
&НаКлиенте
Процедура ПолучитьМассив(Команда)

    Данные = ПолучитьМассивНаСервере();

КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьМассивНаСервере()
    
    ЗАПРОС_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    Данные = РЕЗУЛЬТАТЫ_ОБРАБОТКИ

    Возврат Данные;

КонецФункции
   fedotov_andrey
 
7 - 15.02.21 - 21:56
Спасибо!!!
   fedotov_andrey
 
8 - 15.02.21 - 22:52
(6) не совсем получается)) Данные, это должна быть таблица значений?
   fedotov_andrey
 
9 - 15.02.21 - 22:55
Запросом я получаю например значения трех колонок и 5 строк
в колонке номер 2 у меня как раз те числовые значение, которые должны быть в массиве
   Chameleon1980
 
10 - 15.02.21 - 23:42
нет на клиенте тз
   hhhh
 
11 - 16.02.21 - 00:51
(9) делай все вычисления на сервере. Это гораздо быстрее. Не надо ничего на клиенте делать, он не для этого.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.