Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вставить строку в Word

Вставить строку в Word
Я
   Cоляпсус
 
15.02.21 - 13:47
Добрый день. Подскажите пожалуйста, как можно вставить строку в таблицу Ворд?
Есть макет целая единственная таблица, есть часть куда заполняется номенклатура, путём указания строки и столбца
Документ.Tables(1).Cell(СтрокаНомер,КолонкаНомер).Range.Text = Строка.Номенклатура
и пока есть строки макета, то соответственно заполняется всё хорошо. Но когда строки превышают количество строк в макете возникает трудность.
Документ.Tables(1).Rows.Add(); это добавляет строки в конце таблицы. А необходимо, чтобы вставлял строки пока перечисляется номенклатура.
Заранее благодарен.
 
 Партнерская программа EFSOL Oblako
   Cоляпсус
 
1 - 15.02.21 - 13:52
По идее, чтобы вставить строку, нужно применить 
Ворд.Application.Selection.InsertRowsBelow(1);
но что-то не выходит каменный цветок
   Cоляпсус
 
2 - 15.02.21 - 14:01
InsertRowsBelow(1); вроде как и есть вставляет в последующую строку
   uno-group
 
3 - 15.02.21 - 14:06
(2) Вроде да. Попробуй Документ.Tables(1).Selection.InsertRowsBelow 1
В документе может быть несколько таблиц он как то должен понять в какой таблице ты хочешь строку вставить.
   Cоляпсус
 
4 - 15.02.21 - 14:11
(3) Разбить документ на несколько таблиц?
   Cоляпсус
 
5 - 15.02.21 - 14:13
(3) Нет ли метода где заканчивается строка макета (указанная или по счётчику) и сразу за ней вставить ещё строку?
   Cоляпсус
 
6 - 15.02.21 - 14:15
Для Каждого Строка Из ЗаказПокупателя.Товары Цикл
        Если СтрокаНомер < 29 Тогда
            Если Строка.Номенклатура.ОпасныйГруз = Истина Тогда
                Документ.Tables(1).Cell(СтрокаНомер,КолонкаНомер).Range.Text = Строка.Номенклатура
            Иначе
                Документ.Tables(1).Cell(СтрокаНомер,КолонкаНомер).Range.Text = Строка.Номенклатура.НаименованиеПолное;
            КонецЕсли;    
            
            Документ.Tables(1).Cell(СтрокаНомер,2).Range.Text = Строка.Номенклатура.КодТНВЭД.Наименование;
        Документ.Tables(1).Select();
        Ворд.Application.Selection.InsertRowsBelow(1);
            СтрокаНомер = СтрокаНомер + 1    
        КонецЕсли; 
    КонецЦикла;
при так заполняется хорошо и как надо, но почему-то не добавляется.
   Cоляпсус
 
7 - 15.02.21 - 14:19
А нет, добавляет строки, но всё же опять же в конец таблицы, а надо в середину
   uno-group
 
8 - 15.02.21 - 15:07
А зачем ты это вообще в Ворде делаешь почему не в Ексель?
   uno-group
 
9 - 15.02.21 - 15:10
   uno-group
 
10 - 15.02.21 - 15:20
   Бычье сердце
 
11 - 15.02.21 - 15:30
   Бычье сердце
 
12 - 15.02.21 - 15:31
Можно через БСП вывести, но придется код поправить
{v8 Область.<Имя области>}
...
{/v8 Область.<Имя области>}

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.