Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Обработка табличной части формы (Помогите начинающему)

Обработка табличной части формы (Помогите начинающему)
Я
   YAndrey
 
15.02.21 - 08:01
В конфигурации есть обработка с формой и табличными частями. Есть табличная часть "Товары", в ТЧ "Товары" есть реквизит "Номенклатура" - Справочник.Номенклатура. Добавляю форму обработки в расширение конфигурации. Для одной из функций пишу функцию, вызываемую впереди (Директива &Перед) В этой функции перебираю табличную часть товары:

    Для Каждого Товар Из ЭтотОбъект.Объект.Товары Цикл
        Сообщить("номенклатура "+Товар.Номенклатура.Наименование);
    КонецЦикла;

Прога пишет ошибку - Не обнаружено Наименование.
Если пишу:

    Для Каждого Товар Из ЭтотОбъект.Объект.Товары Цикл
        Сообщить("номенклатура "+Строка(Товар.Номенклатура));
    КонецЦикла;

Выводит именно наименование номенклатуры.

Если пишу:
    Для Каждого Товар Из ЭтотОбъект.Объект.Товары Цикл
        Сообщить("номенклатура "+Строка(ТипЗнч(Товар.Номенклатура)));
    КонецЦикла;

Выводит :
номенклатура Позиция номенклатуры

Вопрос. Как добраться до реквизита Номенклатура, чтоб это была именно ссылка на номенклатуру, и что за тип значения "Позиция номенклатуры"?
   ДенисЧ
 
1 - 15.02.21 - 08:06
На сервере делай...
А "Позиция номенклатуры" это название справочника
   YAndrey
 
2 - 15.02.21 - 08:13
Забыл добавить, что это делается на клиенте
   YAndrey
 
3 - 15.02.21 - 08:13
Опс, не заметил. Ок
   YAndrey
 
4 - 15.02.21 - 08:18
Получилось, спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.