Вход | Регистрация
 

УТ 10 + Атол

УТ 10 + Атол
Я
   first_may
 
12.02.21 - 15:00
Добрый день.

Управление торговлей, редакция 10.3
Атол 22Ф
Драйвер 10.0.8
Касса подключена через IP

Открываем смену, пробиваем чеки. Затем наступает пауза в покупках.
А как только надо пробить чек, то выдается сообщение "порт занят или нет связи".

Подскажите пож, почему такое может быть? Как исправить?
   first_may
 
1 - 12.02.21 - 20:28
Ни у кого нет такой ситуации?
   CepeLLlka
 
2 - 12.02.21 - 20:46
У меня по COM, всё работает..
   first_may
 
3 - 13.02.21 - 16:06
(2) COM это когда касса подключена к компу же, а тут она в сети.
пользователь запускает rdp, а там саму 1с.
   CepeLLlka
 
4 - 13.02.21 - 16:45
(3)Можно пробросить порт..

Но скорость вроде не очень в такой схеме..
   first_may
 
5 - 13.02.21 - 16:55
(4) это одна из причин, почему перешли на IP, но были и другие.
вообщем есть то, что есть и надо как то это настроить.

а как не могу сообразить.
   Исновая
 
6 - 13.02.21 - 17:41
Тех обнуление пераым делом, вторым..айпи в ккт стат или дин?
   first_may
 
7 - 13.02.21 - 18:44
(6) Тех обнуление - а подробно можно?
айпи в ккт -
стат
   shpioleg
 
8 - 14.02.21 - 17:06
(3) Касса подключается еще у другого пользователя, который работает по рдп на том же сервере. Нужно немного поправить код, чтобы имя компьютера для подключенной кассы было не именем сервера, а именем локального компа.
   first_may
 
9 - 14.02.21 - 17:54
(8) код в торговле?
   neomarat
 
10 - 14.02.21 - 22:24
А лучше не имя компа, а имя пользователя 1С присобачить - так проще реализовать
   shpioleg
 
11 - 15.02.21 - 10:24
(9) Да. В функции ПолучитьИмяКомпьютераТО() в обработке ТОСервер
Это все равно ненадежное решение. При работе по рдп однозначно лучше Веб сервер АТОЛа (обсуждалось тут уже не раз).
(10) Никто не запрещает под одним пользователем сидеть в базе нескольким пользователям.
   first_may
 
12 - 17.02.21 - 22:45
А если все таки ничего кодить не надо?
Только использовать то, что есть.

Как настроить?
   neomarat
 
13 - 17.02.21 - 23:01
(12) Че там кодить? Одну строчку поправить - даже процедуру указали где. Ты больше времени на переписку потерял уже.
   first_may
 
14 - 18.02.21 - 11:41
"Нужно немного поправить код, чтобы имя компьютера для подключенной кассы было не именем сервера, а именем локального компа."

зачем это делать, если я открыл в УТ настройки торгового оборудования,
касса Атол и в ней прописан IP 192.168.1.98.
   vovastar
 
15 - 18.02.21 - 11:43
(14) он у тебя просто отключается от аппарата. Если перезайдешь в 1С он вновь подключится и пробьет. Ищи галочку, не отключаться от ккм.
   first_may
 
16 - 18.02.21 - 12:05
(15) да, точно так..
то есть где то есть в настройках "ухода" оборудования в спящий режим?
   shpioleg
 
17 - 18.02.21 - 12:29
(14) У тебя все пользователи работают через рдп на одном компе сервере. Когда подключаешь оборудование, то все пользователи начинают его видеть и конкурировать за него.
Для этого и нужно сделать так, чтобы оборудование подключалось только у кассира.
Такая же история происходит и со сканером. При открытии форм начинает ругаться, что ком порт занят другим пользователем.
   first_may
 
18 - 18.02.21 - 12:45
(17) нашел


Поиск строки "ПолучитьИмяКомпьютераТО"...
Основная конфигурация Конфигурация.УправлениеТорговлей.Модуль обычного приложения(515, 93) : Предупреждение("У кассы: """ + КассаККМ + """, для компьютера: """ + ПолучитьСерверТО().ПолучитьИмяКомпьютераТО() + """, фискальное устройство не установлено!");

Основная конфигурация Документ.КассоваяСмена.Форма.ФормаСписка.Форма.Модуль(8, 38) : КомпьютерШапка = ПолучитьСерверТО().ПолучитьИмяКомпьютераТО();

Основная конфигурация Обработка.ТОНастройка.Форма.Форма.Форма.Модуль(24, 82) : ЭлементыФормы.ДляКомпьютера.Значение = "для компьютера """ + ПолучитьСерверТО().ПолучитьИмяКомпьютераТО() + """";

Основная конфигурация Обработка.ТОНастройка.Форма.Форма.Форма.Модуль(795, 60) : Запрос.УстановитьПараметр("Компьютер", ПолучитьСерверТО().ПолучитьИмяКомпьютераТО());

Основная конфигурация Обработка.ТОНастройка.Форма.Форма.Форма.Модуль(850, 78) : ЭлементыФормы[ИмяТП].Значение.Отбор.Компьютер.Установить(ПолучитьСерверТО().ПолучитьИмяКомпьютераТО());

Основная конфигурация Обработка.ТОНастройка.Форма.Форма.Форма.Модуль(918, 52) : ТекущиеДанные.Компьютер     = ПолучитьСерверТО().ПолучитьИмяКомпьютераТО();

Основная конфигурация Обработка.ТОНастройка.Форма.Форма.Форма.Модуль(1184, 60) : Запрос.УстановитьПараметр("Компьютер", ПолучитьСерверТО().ПолучитьИмяКомпьютераТО());

Основная конфигурация Обработка.ТОНастройка.Форма.ФормаПомощникаНастроек.Форма.Модуль(842, 66) : Запрос.УстановитьПараметр("ИмяКомпьютераТО", ПолучитьСерверТО().ПолучитьИмяКомпьютераТО());

Основная конфигурация Обработка.ТОНастройка.Форма.ФормаПомощникаНастроек.Форма.Модуль(906, 54) : мМенеджерЗаписи.Компьютер     = ПолучитьСерверТО().ПолучитьИмяКомпьютераТО();

Основная конфигурация Обработка.ТОСервер.Модуль объекта(418, 42) : Запрос.УстановитьПараметр("Компьютер" , ПолучитьИмяКомпьютераТО());

Основная конфигурация Обработка.ТОСервер.Модуль объекта(3046, 42) : Запрос.УстановитьПараметр("Компьютер", ПолучитьИмяКомпьютераТО());

Основная конфигурация Обработка.ТОСервер.Модуль объекта(4161, 9) : Функция ПолучитьИмяКомпьютераТО() Экспорт

Основная конфигурация Обработка.ТОСервер.Модуль объекта(4169, 17) : КонецФункции// ПолучитьИмяКомпьютераТО()


Найдено вхождений: 13
   first_may
 
19 - 18.02.21 - 12:46
получается можно поправить одну

// Функция возвращает строку c именем компьютера для нужд торгового оборудования.

//
// Возвращаемое значение:

//  Строка - имя компьютера для торгового оборудования.
//

Функция ПолучитьИмяКомпьютераТО() Экспорт

    Если мИмяКомпьютера = Неопределено Тогда
        мИмяКомпьютера = ВРег(ИмяКомпьютера());
    КонецЕсли;

    Возврат мИмяКомпьютера;

КонецФункции// ПолучитьИмяКомпьютераТО()




и тут написать например 

Возврат "КомпСКассой";
   first_may
 
20 - 18.02.21 - 12:47
но ведь касса не подключена к компу, а она подключена в сеть (к роутеру).
   shpioleg
 
21 - 18.02.21 - 12:53
Как то так. Код не мой

Функция ПолучитьИмяКомпьютераТО() Экспорт

//((заменим на имя физического компа 

    //типовой код комментируем. 

    //Если мИмяКомпьютера = Неопределено Тогда

    //    мИмяКомпьютера = ВРег(ИмяКомпьютера());

    //КонецЕсли;

    Если мИмяКомпьютера = Неопределено Тогда
        WSS = Новый COMОбъект("WScript.Shell");
        WSSE = WSS.Environment("Process");
        мИмяКомпьютера = ВРег(WSSE.Item("ClientName"));
        Если ПустаяСтрока(мИмяКомпьютера) Тогда
            мИмяКомпьютера = ВРег(ИмяКомпьютера());
        КонецЕсли;
    КонецЕсли;
    //если зайти в терминальной сессии консольно, то получим "CONSOLE",

    // в этом случае применяем типовую функцию

    Если мИмяКомпьютера = "CONSOLE" Тогда  
        мИмяКомпьютера = ВРег(ИмяКомпьютера());
    КонецЕсли;
    //))

    Возврат мИмяКомпьютера;

КонецФункции
   shpioleg
 
22 - 18.02.21 - 12:57
(20) Она прям физически воткнута в роутер ?
Или все-таки проброс через IP в ком порт компьютера
   first_may
 
23 - 18.02.21 - 13:02
(22)
Фактически в роутер.
В кассе только rj-45 подключён.
   shpioleg
 
24 - 18.02.21 - 13:11
(23) Тут я не подскажу. Но скорее всего проблемы те же, что и с подключением по ком порту. Помимо IP там же наверняка указан и порт.
Сделайте как в (21) и заново подключите кассу уже только кассиру. Смену только нужно не забыть закрыть перед этим


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.