Вход | Регистрация
 

Дата запрета изменения данных и обмен (синхронизация) данных как дружат?

Дата запрета изменения данных и обмен (синхронизация) данных как дружат?
Я
   Бешеный заяц
 
10.02.21 - 09:59
есть пользователь под которым работает обмен на стороне ЕРП у него стоит дата запрета, загрузится ли документ из другой базы в базу ERP если он по дате попадает под запрет? или при обмене дата запрета не работает? при настройке синхронизации не нашел возможность указать "Загружать в режиме обмен данными истина".
   dka80
 
1 - 10.02.21 - 10:04
не загрузится
   Бешеный заяц
 
2 - 10.02.21 - 10:10
ок спасибо
   DrShad
 
3 - 10.02.21 - 10:11
(0) и в каком режиме по-твоему оно загружается?
   Бешеный заяц
 
4 - 10.02.21 - 10:13
(3) не знаю, когда обработкой загружаешь он записывает и проводит в обычном режиме если соответствующую галочку не поставишь
   DrShad
 
5 - 10.02.21 - 10:14
(4) ну ты сравнил теплое и мягкое )))
   DrShad
 
6 - 10.02.21 - 10:16
и таки документ загрузится, но не проведется
   Бешеный заяц
 
7 - 10.02.21 - 10:18
(6) те документ загрузит дата запрета не помешает, только не даст провести?
   Бешеный заяц
 
8 - 10.02.21 - 10:21
Дабы не плодить темы.
Как настроить в ERP дату запрета в разрезе организаций сразу для всех разделов?
   Serg_1960
 
9 - 10.02.21 - 10:57
(0) Во-первых, вопрос: между базами ЕРП обмен РИБ или не РИБ? Во-вторых, ты программист или где? Не знаю как в ЕРП, а в моих конфигурация перед проверкой даты запрета везде стоит Если Источник.ОбменДанными.Загрузка Тогда Возврат; КонецЕсли;
   Обработка
 
10 - 10.02.21 - 11:08
Дата запрета в константах ни как не влияет на обмен Ибо обмен просто грузит данные но не меняет ничего (престо передает что есть). А дата запрета это когда кто-то что то меняет интерактивно или программно. А обмен всегда это обходит. Другое дело есть дата загрузки данных в РИБе.
   Бешеный заяц
 
11 - 10.02.21 - 11:17
(9) нет не риб.Программист.
(10) обмен на уровне встроенного языка работает, а не абстрактно грузит данные.
Например есть подписка на событие, в данном случае источник это регистр, при обмене он унаследует Источник.ОбменДанными.Загрузка из документа? при условии что документ выгружается без движений соответственно проводится при загрузке? или в данном случае Источник.ОбменДанными.Загрузка будет ложь и как мне подсказали в (6) документ загрузится так как когда он будет грузится как объект сработает загрузка истина, а вот когда проводится загрузки истина при записи движений у регистра уже не будет?

Процедура ПроверитьДатуЗапретаИзмененияПередЗаписьюНабораЗаписей(Источник, Отказ, Замещение) Экспорт
    
    Если Источник.ОбменДанными.Загрузка Тогда
        Возврат;
    КонецЕсли;
    
    ПроверитьДатыЗапретаИзмененияДанных(Источник, Отказ, Истина, Замещение);
    
КонецПроцедуры
   Бешеный заяц
 
12 - 10.02.21 - 11:18
(11) для документа процедура проверки даты выглядит также
   DrShad
 
13 - 10.02.21 - 11:19
при загрузке ничего не проводится, проводится после
   Бешеный заяц
 
14 - 10.02.21 - 11:21
(13) следовательно если я правильно понял, объект залетит в запрещённом периоде так как он Загрузка = Истина, а провестись не сможет так как Загрузки истина для регистра нет?
   DrShad
 
15 - 10.02.21 - 11:23
ну наконец-то
   Бешеный заяц
 
16 - 10.02.21 - 11:32
ок спасибо понял
   Serg_1960
 
17 - 10.02.21 - 11:39
(11) Я не зря спросил про РИБ - только в РИБ документы и их движения в сообщениях обмена мигрируют автономно и независимо друг от друга.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.