Вход | Регистрация
 

Не работает отладка в серверных процедурах

Не работает отладка в серверных процедурах
Я
   Айрат_116
 
09.02.21 - 15:30
Здравствуйте, подскажите пожалуйста, в чём может быть проблема
Отладка включена через tcp в разделе "Подключения" пишет что сервер и тонький клиент
Но почему то в функции серверные остановка не срабатывает https://prnt.sc/yu9ulz
   ZDenis
 
1 - 09.02.21 - 15:31
(0) Должна быть включена отладка в службе сервера 1С - debug
   Айрат_116
 
2 - 09.02.21 - 15:34
(1) Она включена
Если мы дебак прописываем, тогда http должно быть?
   mikecool
 
3 - 09.02.21 - 15:36
(2) нет, для -debug - отладка tcp
для /debug -http - отладка http
читайте официальную доку
   ZDenis
 
4 - 09.02.21 - 15:36
(2) Если прописать еще "-debug -http" тогда и в 0 http ставь,по мне так он лучше работает и больше настроек.
   mikecool
 
5 - 09.02.21 - 15:38
(4) у меня "-debug -http" не взлетело на 8.3.17 какой то
ИТС говорит - надо " /debug -http" и тогда заработало
   fisher
 
6 - 09.02.21 - 15:40
А что, такое бывает, что в предметах отладки сервер подключился, но отладка не работает?
Я с таким не сталкивался. Но и по http не отлаживал.
   mikecool
 
7 - 09.02.21 - 15:42
(6) тссс... там клиент явно не тот, что подключен )
   Айрат_116
 
8 - 09.02.21 - 15:45
Прописано https://prnt.sc/yubtw7
   ZDenis
 
9 - 09.02.21 - 15:47
(5) Посмотрел у себя, не у меня через дефис на 17.1851 работате
D:\1cv8\8.3.17.1851\bin\ragent.exe -srvc -agent -regport 1541 -port 1540 -range 1560:1591 -d "D:\1cv8\srvinfo" -debug -http
   fisher
 
10 - 09.02.21 - 15:51
(7) Почему не тот?
   Айрат_116
 
11 - 09.02.21 - 16:21
Нужно ли сервер перезагружать чтоб изменения подействовали?
   ДенисЧ
 
12 - 09.02.21 - 16:23
(11) Службу сервера 1с - обязательно
   Айрат_116
 
13 - 09.02.21 - 17:55
У кого была такая ошибка, ставлю http далее перезапускаю базу
И при входе выходит такая ошибка https://prnt.sc/yus6rl
   CepeLLlka
 
14 - 09.02.21 - 21:01
Бывает ещё проблема с отладкой, если сервер 1с перезапустил, а конфигуратор нет.. То есть конфигуратором просто переподключился, а не открыл, закрыл..
   TormozIT
 
15 - 10.02.21 - 00:10
Ну сколько можно распространять это заблуждение про косую черту?
Неважно косая черта или дефис написана перед debug. Играет роль только полный перезапуск сервера, который обычно следует за этим изменением в любую сторону.
   Вафель
 
16 - 10.02.21 - 07:46
а еще отладка частотне работает из-за клиентского файрвола
   Вафель
 
17 - 10.02.21 - 07:46
в (0) как раз оно
   Ненавижу 1С
 
18 - 10.02.21 - 07:48
Бывает отпадает отладка, если конфигуратор сутки открытый.
Посмотрите ещё открытость нужных портов
   Вафель
 
19 - 10.02.21 - 07:48
это когда при запуске 1с вылезает окошко "разрешить подключатья к сетям" и кто-то нажал Нет.
теперь нужно лезть в настройки и в ручную сбрасывать правило
   Айрат_116
 
20 - 10.02.21 - 15:07
Похоже проблема в том что платформа стоит 8.3.18.1208
Если включаем отладку через http всё глючить начинает
А через tcp на сервер не попадает
   Kassern
 
21 - 10.02.21 - 15:10
(20) у нас эта платформа, отладка работает по tcp
   Айрат_116
 
22 - 10.02.21 - 15:13
(21) У нас на одном сервере тоже работает tcp
А на другом нет, платформы одинаковые
   Garykom
 
23 - 10.02.21 - 15:17
(22) сервер 1С и rdp сервера разные? проверить порты открыты ли


Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.