Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УПП 1.3.152.3 (предпоследний релиз). Макет новай справки 2-НДФЛ есть в конфигурации, но

УПП 1.3.152.3 (предпоследний релиз). Макет новай справки 2-НДФЛ есть в конфигурации, но
Я
   altaykniga
 
09.02.21 - 13:30
Доброго времени суток, уважаемые специалисты.
УПП 1.3.152.3. В описании к релизу указано:
"В соответствии с Приказом ФНС России от 15.10.2020 № ЕД-7-11/753@ обновлена форма справки 2-НДФЛ для сотрудников."

порылся в конфигуарции, макет новый есть, но вот в коде модулей не нашел ни одной процедуры печати данного макета... И в зарегистрированных ошибках такой нет

    Если СтруктураДанныхНА.НалоговыйПериод = 2010 Или (СтруктураДанныхНА.НалоговыйПериод = 2011 И ДанныеДокумента.СпециальныйДокумент2011года) Тогда
        ТабДокумент = Печать2010(Отказ, СтруктураДанныхНА, ТаблицаДанныхСотрудников, ТаблицаДанныхОДоходах, ТаблицаДанныхОВычетах, ТаблицаИтоговыхДанных, СоответствиеКодовСтран, СоответствиеИменСтран, СоответствиеДокументовУдостоверяющиеЛичность, СоответствиеКодовРегионов, СоответствиеКодовДоходов, СоответствиеКодовВычетов)
    ИначеЕсли СтруктураДанныхНА.НалоговыйПериод + ?(ДанныеДокумента.СпециальныйДокумент2013года, 0, 1) < ГодПереходаНаОКТМО Тогда
        ТабДокумент = ПечатьС2011года(Отказ, СтруктураДанныхНА.НалоговыйПериод, "Форма2НДФЛс2011", СтруктураДанныхНА, ТаблицаДанныхСотрудников, ТаблицаДанныхОДоходах, ТаблицаДанныхОВычетах, ТаблицаИтоговыхДанных, СоответствиеКодовСтран, СоответствиеИменСтран, СоответствиеДокументовУдостоверяющиеЛичность, СоответствиеКодовРегионов, СоответствиеКодовДоходов, СоответствиеКодовВычетов, СоответствиеСтавокДоходов)
    ИначеЕсли СтруктураДанныхНА.НалоговыйПериод < 2015 Тогда
        ТабДокумент = ПечатьС2011года(Отказ, СтруктураДанныхНА.НалоговыйПериод, "Форма2НДФЛс2014", СтруктураДанныхНА, ТаблицаДанныхСотрудников, ТаблицаДанныхОДоходах, ТаблицаДанныхОВычетах, ТаблицаИтоговыхДанных, СоответствиеКодовСтран, СоответствиеИменСтран, СоответствиеДокументовУдостоверяющиеЛичность, СоответствиеКодовРегионов, СоответствиеКодовДоходов, СоответствиеКодовВычетов, СоответствиеСтавокДоходов)
    ИначеЕсли Не ВыводитьФорму2НДФЛ2018Года(СтруктураДанныхНА.НалоговыйПериод, СтруктураДанныхНА.Дата) Тогда
        НомерКорректировки = 0;
        Если РеквизитыДокумента.Найти("НомерКорректировки") <> Неопределено Тогда
            НомерКорректировки = ОбщегоНазначенияЗК.ПолучитьЗначениеРеквизита(Ссылка,"НомерКорректировки")
        КонецЕсли;
        ТабДокумент = ПечатьС2015года(Отказ, СтруктураДанныхНА.НалоговыйПериод, НомерКорректировки, "Форма2НДФЛс2015", СтруктураДанныхНА, ТаблицаДанныхСотрудников, ТаблицаДанныхОДоходах, ТаблицаДанныхОВычетах, ТаблицаИтоговыхДанных, СоответствиеКодовСтран, СоответствиеИменСтран, СоответствиеДокументовУдостоверяющиеЛичность, СоответствиеКодовРегионов, СоответствиеКодовДоходов, СоответствиеКодовВычетов, СоответствиеСтавокДоходов)
    ИначеЕсли Не ВыводитьФорму2НДФЛ2019Года(СтруктураДанныхНА.НалоговыйПериод, СтруктураДанныхНА.Дата) Тогда
        НомерКорректировки = 0;
        Если РеквизитыДокумента.Найти("НомерКорректировки") <> Неопределено Тогда
            НомерКорректировки = ОбщегоНазначенияЗК.ПолучитьЗначениеРеквизита(Ссылка,"НомерКорректировки")
        КонецЕсли;
        ТабДокумент = ПечатьС2018года(Отказ, СтруктураДанныхНА.НалоговыйПериод, НомерКорректировки, "Форма2НДФЛс2018", СтруктураДанныхНА, ТаблицаДанныхСотрудников, ТаблицаДанныхОДоходах, ТаблицаДанныхОВычетах, ТаблицаИтоговыхДанных, СоответствиеКодовСтран, СоответствиеИменСтран, СоответствиеДокументовУдостоверяющиеЛичность, СоответствиеКодовРегионов, СоответствиеКодовДоходов, СоответствиеКодовВычетов, СоответствиеСтавокДоходов)
    Иначе
        ТабДокумент = ПечатьС2019года(Отказ, СтруктураДанныхНА.НалоговыйПериод, "Форма2НДФЛс2019", СтруктураДанныхНА, ТаблицаДанныхСотрудников, ТаблицаДанныхОДоходах, ТаблицаДанныхОВычетах, ТаблицаИтоговыхДанных, СоответствиеКодовСтран, СоответствиеИменСтран, СоответствиеДокументовУдостоверяющиеЛичность, СоответствиеКодовРегионов, СоответствиеКодовДоходов, СоответствиеКодовВычетов, СоответствиеСтавокДоходов)
    КонецЕсли;


Никто не сталкивался с такой проблемой? Каким образом распечатать сотруднику справку 2-НДФЛ нового образца, если, например, сотрудник просит справку за январь 2021года?
   altaykniga
 
1 - 09.02.21 - 13:33
    Если СтруктураДанныхНА.НалоговыйПериод = 2010 Или (СтруктураДанныхНА.НалоговыйПериод = 2011 И ДанныеДокумента.СпециальныйДокумент2011года) Тогда
        ТабДокумент = Печать2010(Отказ, СтруктураДанныхНА, ТаблицаДанныхСотрудников, ТаблицаДанныхОДоходах, ТаблицаДанныхОВычетах, ТаблицаИтоговыхДанных, СоответствиеКодовСтран, СоответствиеИменСтран, СоответствиеДокументовУдостоверяющиеЛичность, СоответствиеКодовРегионов, СоответствиеКодовДоходов, СоответствиеКодовВычетов)
    ИначеЕсли СтруктураДанныхНА.НалоговыйПериод + ?(ДанныеДокумента.СпециальныйДокумент2013года, 0, 1) < ГодПереходаНаОКТМО Тогда
        ТабДокумент = ПечатьС2011года(Отказ, СтруктураДанныхНА.НалоговыйПериод, "Форма2НДФЛс2011", СтруктураДанныхНА, ТаблицаДанныхСотрудников, ТаблицаДанныхОДоходах, ТаблицаДанныхОВычетах, ТаблицаИтоговыхДанных, СоответствиеКодовСтран, СоответствиеИменСтран, СоответствиеДокументовУдостоверяющиеЛичность, СоответствиеКодовРегионов, СоответствиеКодовДоходов, СоответствиеКодовВычетов, СоответствиеСтавокДоходов)
    ИначеЕсли СтруктураДанныхНА.НалоговыйПериод < 2015 Тогда
        ТабДокумент = ПечатьС2011года(Отказ, СтруктураДанныхНА.НалоговыйПериод, "Форма2НДФЛс2014", СтруктураДанныхНА, ТаблицаДанныхСотрудников, ТаблицаДанныхОДоходах, ТаблицаДанныхОВычетах, ТаблицаИтоговыхДанных, СоответствиеКодовСтран, СоответствиеИменСтран, СоответствиеДокументовУдостоверяющиеЛичность, СоответствиеКодовРегионов, СоответствиеКодовДоходов, СоответствиеКодовВычетов, СоответствиеСтавокДоходов)
    ИначеЕсли Не ВыводитьФорму2НДФЛ2018Года(СтруктураДанныхНА.НалоговыйПериод, СтруктураДанныхНА.Дата) Тогда
        НомерКорректировки = 0;
        Если РеквизитыДокумента.Найти("НомерКорректировки") <> Неопределено Тогда
            НомерКорректировки = ОбщегоНазначенияЗК.ПолучитьЗначениеРеквизита(Ссылка,"НомерКорректировки")
        КонецЕсли;
        ТабДокумент = ПечатьС2015года(Отказ, СтруктураДанныхНА.НалоговыйПериод, НомерКорректировки, "Форма2НДФЛс2015", СтруктураДанныхНА, ТаблицаДанныхСотрудников, ТаблицаДанныхОДоходах, ТаблицаДанныхОВычетах, ТаблицаИтоговыхДанных, СоответствиеКодовСтран, СоответствиеИменСтран, СоответствиеДокументовУдостоверяющиеЛичность, СоответствиеКодовРегионов, СоответствиеКодовДоходов, СоответствиеКодовВычетов, СоответствиеСтавокДоходов)
    ИначеЕсли Не ВыводитьФорму2НДФЛ2019Года(СтруктураДанныхНА.НалоговыйПериод, СтруктураДанныхНА.Дата) Тогда
        НомерКорректировки = 0;
        Если РеквизитыДокумента.Найти("НомерКорректировки") <> Неопределено Тогда
            НомерКорректировки = ОбщегоНазначенияЗК.ПолучитьЗначениеРеквизита(Ссылка,"НомерКорректировки")
        КонецЕсли;
        ТабДокумент = ПечатьС2018года(Отказ, СтруктураДанныхНА.НалоговыйПериод, НомерКорректировки, "Форма2НДФЛс2018", СтруктураДанныхНА, ТаблицаДанныхСотрудников, ТаблицаДанныхОДоходах, ТаблицаДанныхОВычетах, ТаблицаИтоговыхДанных, СоответствиеКодовСтран, СоответствиеИменСтран, СоответствиеДокументовУдостоверяющиеЛичность, СоответствиеКодовРегионов, СоответствиеКодовДоходов, СоответствиеКодовВычетов, СоответствиеСтавокДоходов)
    Иначе
        ТабДокумент = ПечатьС2019года(Отказ, СтруктураДанныхНА.НалоговыйПериод, "Форма2НДФЛс2019", СтруктураДанныхНА, ТаблицаДанныхСотрудников, ТаблицаДанныхОДоходах, ТаблицаДанныхОВычетах, ТаблицаИтоговыхДанных, СоответствиеКодовСтран, СоответствиеИменСтран, СоответствиеДокументовУдостоверяющиеЛичность, СоответствиеКодовРегионов, СоответствиеКодовДоходов, СоответствиеКодовВычетов, СоответствиеСтавокДоходов)
    КонецЕсли;

   altaykniga
 
2 - 09.02.21 - 13:35
(1) в коде модулей не нашел ни одной процедуры печати данного макета
   CHerypga
 
3 - 09.02.21 - 13:35
в 1.3.153.1 появляется 
    ИначеЕсли Не ВыводитьФорму2НДФЛ2021Года(СтруктураДанныхНА.НалоговыйПериод, СтруктураДанныхНА.Дата) Тогда
        ТабДокумент = ПечатьС2019года(Отказ, СтруктураДанныхНА.НалоговыйПериод, "Форма2НДФЛс2019", СтруктураДанныхНА, ТаблицаДанныхСотрудников, ТаблицаДанныхОДоходах, ТаблицаДанныхОВычетах, ТаблицаИтоговыхДанных, СоответствиеКодовСтран, СоответствиеИменСтран, СоответствиеДокументовУдостоверяющиеЛичность, СоответствиеКодовРегионов, СоответствиеКодовДоходов, СоответствиеКодовВычетов, СоответствиеСтавокДоходов)
    Иначе
        ТабДокумент = ПечатьС2019года(Отказ, СтруктураДанныхНА.НалоговыйПериод, "Форма2НДФЛс2021", СтруктураДанныхНА, ТаблицаДанныхСотрудников, ТаблицаДанныхОДоходах, ТаблицаДанныхОВычетах, ТаблицаИтоговыхДанных, СоответствиеКодовСтран, СоответствиеИменСтран, СоответствиеДокументовУдостоверяющиеЛичность, СоответствиеКодовРегионов, СоответствиеКодовДоходов, СоответствиеКодовВычетов, СоответствиеСтавокДоходов)
    КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.