Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

что я делаю не так

↓ [Волшебник, 06.02.21 - 23:02]
что я делаю не так
Я
   The_ka6a4ok
 
06.02.21 - 18:24
в запросе получаю всю номенклатуру, пытаюсь получить объект, но не понимаю почему. уф, унф 1.6

https://postimg.cc/Cdmyrn8G
   tixis
 
1 - 06.02.21 - 18:26
что за запрос то? к чему запрос?
   The_ka6a4ok
 
2 - 06.02.21 - 18:27
ой, извиняюсь


&НаКлиенте
Процедура Кнопка(Команда)
    Единицы();
КонецПроцедуры

&НаСервере
Процедура Единицы()
    Запрос = Новый Запрос();
    Запрос.Текст = "ВЫБРАТЬ
    |    Номен.Наименование,
    |    Номен.ТипНоменклатуры,
    |    Номен.Ссылка
    |    ИЗ Справочник.Номенклатура КАК Номен";
    Выборка = Запрос.Выполнить().Выбрать();
    ОбъектЕдиниц = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду("2009");
    Пока Выборка.Следующий() Цикл
        Объект = Проверка(Выборка.Ссылка);
        Объект.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Услуга;
        Объект.ЕдиницаИзмерения = ОбъектЕдиниц;
        Объект.Записать();
    КонецЦикла;
КонецПроцедуры (1)
   The_ka6a4ok
 
3 - 06.02.21 - 18:29
(2) в цикле, первая строка : Объект = Выборка.Ссылка.ПолучитьОбъект();
   tixis
 
4 - 06.02.21 - 18:30
Измени синоним Объект на ОбъектНоменклатура например
   The_ka6a4ok
 
5 - 06.02.21 - 18:32
(4) ясно
   The_ka6a4ok
 
6 - 06.02.21 - 18:32
(5) уф топ за свои деньги
   sitex
 
7 - 06.02.21 - 18:34
(6) Да и сразу заучи это https://its.1c.ru/db/v837doc#bookmark:dev:TI000000138

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.