Вход | Регистрация
 

1С УТ 10.3 Печать чека из ПКО Почему могут не печататься товары в чеке?

1С УТ 10.3 Печать чека из ПКО Почему могут не печататься товары в чеке?
Я
   evorle145
 
05.02.21 - 10:55
Отладчиком смотрю, в ПараметрыФискализацииЧека.ПозицииЧека массив заполнен. Указаны конкретные номенклатуры, количество, цена, сумма, но в чеке просто написано "Принято от частное лицо Основание и сумма" и все.. а детализации нет...
   ColonelAp4u
 
1 - 05.02.21 - 11:05
(0) потому что нет реализации.
   ColonelAp4u
 
2 - 05.02.21 - 11:06
и у Вас заполняется фиктивная строка с признаком расчета аванс или предоплата.
   evorle145
 
3 - 05.02.21 - 11:13
(1) реализация есть. Указана как документ расчета. Ну вот тут заполняется:

    РезультатЗапроса = Запрос.ВыполнитьПакет();
    
    Выборка = РезультатЗапроса[РезультатЗапроса.ВГраница()].Выбрать();
    Пока Выборка.Следующий() Цикл
        
        СтрокаПозицииЧека = МенеджерОборудованияКлиентСервер.ПараметрыФискальнойСтрокиЧека();
        СтрокаПозицииЧека.ПризнакПредметаРасчета = Перечисления.ПризнакиПредметаРасчета.ПлатежВыплата;
        
        ЗаполнитьЗначенияСвойств(СтрокаПозицииЧека, Выборка);
        
        СтрокаПозицииЧека.Сумма = Окр(СтрокаПозицииЧека.Сумма, 2);
        
        СтрокаПозицииЧека.Наименование = НоменклатураКлиентСервер.ПредставлениеНоменклатурыДляПечати(
            Выборка.НоменклатураНаименование,
            Выборка.ХарактеристикаНаименование,
            Выборка.УпаковкаНаименование);
        
        СтрокаПозицииЧека.СтавкаНДС = РозничныеПродажиКлиентСервер.СтавкаНДСФискальнойОперации(Выборка.СтавкаНДС);
        СтрокаПозицииЧека.НомерСекции = 1;
        
        Если СтрокаПозицииЧека.Количество <> 0 Тогда
            СтрокаПозицииЧека.ЦенаСоСкидками = Окр(СтрокаПозицииЧека.Сумма / СтрокаПозицииЧека.Количество, 2);
        КонецЕсли;
        
        ПозицииЧека.Добавить(СтрокаПозицииЧека);
        ИтогоСуммаЧека = ИтогоСуммаЧека + СтрокаПозицииЧека.Сумма;
        
    КонецЦикла;
    
    ПараметрыФискализацииЧека.ПозицииЧека = ПозицииЧека;



Признак предмета расчета: СтрокаПозицииЧека.ПризнакПредметаРасчета = Перечисления.ПризнакиПредметаРасчета.ПлатежВыплата;
   evorle145
 
4 - 05.02.21 - 11:37
ЭтоТоварныйДокумент = ТипЗнч(Ссылка) = Тип("ДокументСсылка.РеализацияТоваровУслуг") ИЛИ 
        ТипЗнч(Ссылка) = Тип("ДокументСсылка.ВозвратТоваровОтПокупателя");
        
    Если ЭтоТоварныйДокумент Тогда
        
        Если Ссылка.ВалютаДокумента = глЗначениеПеременной("ВалютаРегламентированногоУчета") Тогда
            КурсОплаты = 1;
        Иначе
            КурсОплаты = Ссылка.КурсВзаиморасчетов / Ссылка.КратностьВзаиморасчетов;
        КонецЕсли;
        
        ЗаполнитьОплатыДляТоварногоДокумента(Ссылка, ОбщиеПараметры, КурсОплаты);
        
        ЗаполнитьТоварныеПозицииДляТоварногоДокумента(Ссылка, ОбщиеПараметры, КурсОплаты);
        
    Иначе
        
        ЗаполнитьОплатыДляПлатежногоДокумента(Ссылка, ОбщиеПараметры);
        
        РасчетыСПокупателем = (ВидОперации = ПредопределенноеЗначение("Перечисление.ВидыОперацийПКО.ОплатаПокупателя"))
            ИЛИ (ВидОперации = ПредопределенноеЗначение("Перечисление.ВидыОперацийРКО.ВозвратДенежныхСредствПокупателю"))
            ИЛИ (ТипЗнч(Ссылка) = Тип("ДокументСсылка.ОплатаОтПокупателяПлатежнойКартой"))
            Или (ВидОперации = ПредопределенноеЗначение("Перечисление.ВидыОперацийПоступлениеБезналичныхДенежныхСредств.ОплатаПокупателя"));
        ЭтоВозврат = (ВидОперации = ПредопределенноеЗначение("Перечисление.ВидыОперацийОплатаОтПокупателяПлатежнойКартой.ВозвратДенежныхСредствПокупателю"))
            ИЛИ (ТипЗнч(Ссылка) = Тип("ДокументСсылка.РасходныйКассовыйОрдер")) ИЛИ (ТипЗнч(Ссылка) = Тип("ДокументСсылка.ПлатежноеПоручениеИсходящее"));
        
        ЗаполнитьТоварныеПозицииДляПлатежногоДокумента(Ссылка, ОбщиеПараметры, 
            РасчетыСПокупателем, ЭтоВозврат, КомуОтКого, Основание);
        
    КонецЕсли;
   evorle145
 
5 - 05.02.21 - 11:37
ЭтоТоварныйДокумент  у меня ложь... то есть ссылка у меня получается ПКО ... а надо видимо чтобы в этот кусок кода попадала РТУ
   Ненавижу 1С
 
6 - 05.02.21 - 11:39
Вид операции ПКО какой?
   evorle145
 
7 - 05.02.21 - 11:44
(6) оплата от покупателя
   ColonelAp4u
 
8 - 05.02.21 - 13:54
(4) посмотри в 11 ут если есть возможность, там когда бьется чек из пко 1С проверяет, если есть реализация то пко по товарный, иначе предоплата/аванс.
   evorle145
 
9 - 05.02.21 - 21:47
(8) в ут 10.3 развилка: или это товарный документ или нет. Если товарный то выводить детелизацию, если нет, то выводить общую строку..

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.