Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

как поправить измерение у регистра перед записью?

как поправить измерение у регистра перед записью?
Я
   tmk315
 
02.02.21 - 09:48
В модуле регистра перехватил перед записью ,
поправил измерение .
На отбор ругается  .
   Ёпрст
 
1 - 02.02.21 - 09:52
ну дык установи его правильно
   Фрэнки
 
2 - 02.02.21 - 09:53
даже боюсь код спросить... если спросишь, то как вывалит простыню метров на 10 :-)
   tmk315
 
3 - 02.02.21 - 09:53
Пробовал , недоступно для записи . Подскажи как ?
   Капитан Джек Воробей
 
4 - 02.02.21 - 09:53
(0) убери с отбора измерение которое меняешь, перебери в цикле с условием твоего измерения там и поменяй
   tmk315
 
5 - 02.02.21 - 09:54
СвТер=ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Код территории (Территории)");
    //НаборЗаписей = РегистрыСведений.грНачисленияСотрудников.СоздатьНаборЗаписей();

    //НаборЗаписей.Отбор.ID.Установить(УИД);

    //НаборЗаписей.Прочитать();

    
    НаборЗаписей=ЭтотОбъект;
    Для каждого Запись Из НаборЗаписей Цикл
        КПП=Запись.ПодразделениеОрганизации.РегистрацияВНалоговомОргане.КПП;
        Для каждого сДопРек Из Запись.ВидРабот.ДополнительныеРеквизиты Цикл
            Если сДопРек.Свойство=СвТер Тогда
                КодТер=сДопРек.Значение;
            Иначе
            КонецЕсли;    
        КонецЦикла;
        Если ЗначениеЗаполнено(КодТер) Тогда
            ТехТер=НайтиТериторию(КПП,КодТер,СвТер);
            НаборЗаписей.Отбор.ТехническаяТерритория=ТехТер;
            Запись.ТехническаяТерритория=ТехТер;
        Иначе
        КонецЕсли;
    КонецЦикла;
    //НаборЗаписей.Записать();
   Капитан Джек Воробей
 
6 - 02.02.21 - 09:59
(5)НаборЗаписей.Отбор.ТехническаяТерритория.Установить(ТехТер)
   tmk315
 
7 - 02.02.21 - 10:17
Спасибо . Работает.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.