Вход | Регистрация
 

Как программно составить список всех документов отсортированных по дате

Как программно составить список всех документов отсортированных по дате
Я
   gabd_marat
 
31.01.21 - 10:21
Добрый день! Как программно составить список абсолютно всех документов отсортированных по дате, за определенный период, только запросом?
   Mankubus
 
1 - 31.01.21 - 10:36
Сделать запрос в цикле по метаданным
   wertyu
 
2 - 31.01.21 - 10:38
(1) может не запрос, а текст запроса?
   gabd_marat
 
3 - 31.01.21 - 10:48
(1) (2) Может у вас пример есть?
   Ненавижу 1С
 
4 - 31.01.21 - 11:12
   gabd_marat
 
5 - 31.01.21 - 11:50
(4) (2) (1) Сделал так, теперь надо упорядочить по дате


    Запрос = Новый Запрос;
    Текст = "";
    Для Каждого Док Из Метаданные.Документы Цикл
        Текст = Текст + "ВЫБРАТЬ Ссылка, Дата ИЗ Документ." + Док.Имя + " ГДЕ (Документ." + Док.Имя + ".Дата >= &ДатаНачала И Документ." + Док.Имя + ".Дата <= &ДатаКонец)   ОБЪЕДИНИТЬ ";
    КонецЦикла;
    Запрос.Текст = Лев(Текст, СтрДлина(Текст) - СтрДлина(" ОБЪЕДИНИТЬ "));
    Запрос.УстановитьПараметр("ДатаНачала",ДатаНач);
    Запрос.УстановитьПараметр("ДатаКонец",ДатаКонец);
    Выборка = Запрос.Выполнить().Выбрать();
   ДенисЧ
 
6 - 31.01.21 - 12:08
Добавь
Запрос.Текст = Запрос.Текст + "
|УПОРЯДОЧИТЬ ПО Дата
|";
   gabd_marat
 
7 - 31.01.21 - 12:19
(6) Да,спасибо, разобрался

А как программно провести все эти документы? С сообщениями об ошибке если не проведется
   gabd_marat
 
8 - 31.01.21 - 12:22
Или есть уже готовые обработки . Конфигурация 1с упп сильно изменённая ,написанная под нужды предприятия
   gabd_marat
 
9 - 31.01.21 - 12:38
Такой вариант рабочий 

Процедура ПровестиДокументы()
    
    Для Каждого ДокументСсылка Из СпискДокументов Цикл
        
        Попытка 
             ДокументСсылка.Записать(РежимЗаписиДокумента.Проведение);
             Сообщить("Документ" + ДокументСсылка + "провелся удачно!");

         Исключение
             Сообщить("Документ" + ДокументСсылка + "не провелся!");
        КонецПопытки  ;
        
    КонецЦикла;    
    
КонецПроцедуры
   Chameleon1980
 
10 - 31.01.21 - 18:51
вы просмотрели ликбез по самообучению новых 1сников
   Ненавижу 1С
 
11 - 31.01.21 - 20:26
(9) а точно имеет смысл проводить дальше, если что-то не провелось?
   RomanYS
 
12 - 31.01.21 - 22:00
(8) да,в упп есть групповая обработка, которая подойдёт для этой задачи
   Ёпрст
 
13 - 31.01.21 - 22:52
(7) А оно точно надо ? А условие хоть воткнул, что выбрать хотя бы только проведенные доки ?
   Ёпрст
 
14 - 31.01.21 - 22:52
(9) хотя бы РежимПроведения.НеОперативный
   Вася Теркин
 
15 - 01.02.21 - 14:38
Как за 13 часов подготовить масштабную диверсию....
   Fragster
 
16 - 01.02.21 - 14:40
(14) вроде по дефолту там так и есть?
   ДенисЧ
 
17 - 01.02.21 - 14:46
(16) Ты веришь в аргументы по умолчанию?
   Fragster
 
18 - 01.02.21 - 15:55
(17) я вообще доверчивый

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.