Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Неправильно работает отправка письма

Неправильно работает отправка письма
Я
   remont16
 
28.01.21 - 15:59
При нажатии на кнопку открывается форма отправки письма. При нажатии на кнопку "отправить", все работает, письмо отправляется, но при закрытии этой формы, оно все равно отправляется. Почему так происходит и как это исправить?
   ДенисЧ
 
1 - 28.01.21 - 16:01
Нужно открыть код и посмотреть процедуру ПриЗакрытии
   remont16
 
2 - 28.01.21 - 16:04
(1) при закрытии ничего нет, есть только ПередЗакрытием
Процедура ПередЗакрытием(Отказ, ЗавершениеРаботы, ТекстПредупреждения, СтандартнаяОбработка)
    
    Если Не ЗавершениеРаботы
        И Модифицированность
        И Объект.СтатусПисьма = ПредопределенноеЗначение("Перечисление.СтатусыИсходящегоЭлектронногоПисьма.Черновик") Тогда
        
        ЕстьРедактируемыеФайлы = Ложь;
        МассивРедактируемыхФайлов = Новый Массив;
        
        Для Каждого Вложение Из Вложения Цикл
            
            Если Вложение.Редактируется Тогда
                ЕстьРедактируемыеФайлы = Истина;
                МассивРедактируемыхФайлов.Добавить(Вложение.Ссылка);
            КонецЕсли;
            
        КонецЦикла;
        
        Если ЕстьРедактируемыеФайлы Тогда
            
            Отказ                = Истина;
            СтандартнаяОбработка = Ложь;
            
            ТекстВопроса = НСтр("ru = 'Данные были изменены, Записать?'");
            ДополнительныеПараметры = Новый Структура;
            ДополнительныеПараметры.Вставить("МассивРедактируемыхФайлов", МассивРедактируемыхФайлов);
            ОповещениеПослеВопросаОЗакрытии = Новый ОписаниеОповещения("ПослеВопросаПриЗакрытии", ЭтотОбъект, ДополнительныеПараметры);
            
            ПоказатьВопрос(ОповещениеПослеВопросаОЗакрытии, ТекстВопроса, РежимДиалогаВопрос.ДаНетОтмена);
            
        КонецЕсли;
        
    КонецЕсли;
        
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.