Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Нужна помощь с ошибкой: Значение не является значением объектного типа (ВГраница)

Нужна помощь с ошибкой: Значение не является значением объектного типа (ВГраница)
Я
   coolgazz
 
27.01.21 - 12:56
Стоит 1С - УТП.
При создании возвратного ЭСФ показывает эту ошибку:
{Обработка.ОбменЭСФ.Форма.КлиентОбычная.Форма(2047)}: Ошибка при вызове метода контекста (ОткрытьФорму)
        ОткрытьФорму("Документ.ЭСФ.ФормаОбъекта", ПараметрыФормы);    
по причине:
Ошибка при выполнении обработчика - 'ОбработкаЗаполнения'
по причине:
{Обработка.ОбменЭСФ.МодульОбъекта(11432)}: Значение не является значением объектного типа (ВГраница)
        ОткрытьФорму("Документ.ЭСФ.ФормаОбъекта", ПараметрыФормы);
   Волшебник
 
1 - 27.01.21 - 12:57
ошибка в строке 11432...
удачи
   coolgazz
 
2 - 27.01.21 - 13:59
Не могу понять что тут не так, вроде все написано правильно.
Процедура СоздатьЭСФ(Знач Параметр) Экспорт
    
    МассивСчетовФактур = ЭСФКлиент.МассивСчетовФактур(Параметр);
    
    Если МассивСчетовФактур = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    Если МассивСчетовФактур.Количество() > 1 Тогда 
        
        ТекстВопроса = НСтр(
        "ru = 'Для выделенных счетов-фактур будут созданы и записаны документы ЭСФ.
        |Созданные документы ЭСФ будут указаны в качестве актуальных ЭСФ для счетов-фактур.
        |Продолжить?'");
        
        ДополнительныеПараметры = Новый Структура("МассивСчетовФактур", МассивСчетовФактур);
        ОписаниеОповещения = Новый ОписаниеОповещения("СоздатьСписокЭСФЗавершение", ЭтаФорма, ДополнительныеПараметры);
        ПоказатьВопрос(ОписаниеОповещения, ТекстВопроса, РежимДиалогаВопрос.ДаНет);
        
    ИначеЕсли МассивСчетовФактур.Количество() = 1 Тогда
        
        ПараметрыФормы = Новый Структура;
        ПараметрыФормы.Вставить("Основание", МассивСчетовФактур[0]);
        ОткрытьФорму("Документ.ЭСФ.ФормаОбъекта", ПараметрыФормы);    
        
    Иначе// МассивСчетовФактур.Количество() = 0 Тогда 

        
        ПоказатьПредупреждение(, НСтр("ru = 'Выберите хотя бы один счет-фактуру.'"));
        
    КонецЕсли;
    
КонецПроцедуры
   ДенисЧ
 
3 - 27.01.21 - 14:00
(2) Ну и где в твоём коде ВГраница?
   coolgazz
 
4 - 27.01.21 - 14:03
Честно, понятия не имею.
Ошибка ссылается именно на эту часть кода
   youalex
 
5 - 27.01.21 - 14:03
Отладка/Остановка по ошибке...

Скорее всего, падает в модуле документа ЭСФ, в Процедура ОбработкаЗаполнения()
   coolgazz
 
6 - 27.01.21 - 14:23
Меня немного напрягает то, что тут вызывается эта-же процедура:

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
    
    ОбработкаОбменЭСФ = ЭСФСерверПовтИсп.ОбработкаОбменЭСФ();
    ОбработкаОбменЭСФ.ДокументЭСФ_ОбработкаЗаполнения(ЭтотОбъект, ДанныеЗаполнения, СтандартнаяОбработка);
    
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.