Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как установить владельца справочника при выборе из списка

Как установить владельца справочника при выборе из списка
Я
   МимохожийОднако
 
26.01.21 - 10:07
В тестовой обработке добавил программно на форму реквизит типа Справочник, у которого есть владелец
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
ПолеВвода=Элементы.Вставить("Места_Ячейка",Тип("ПолеФормы"),Элементы.СтраницаКарточкаНоменклатуры);//,Элементы.КарточкаНоменклатуры);
    
    ПолеВвода.Заголовок = "Ячейка";
    ПолеВвода.Вид = ВидПоляФормы.ПолеВвода;
    
    //Установка связи элемента с данными
    ПолеВвода.ПутьКДанным = "Объект.Места_Ячейка";
    
    //Добавляем обработчики события
    ПолеВвода.УстановитьДействие(
    "ПриИзменении",             //Имя события
    "ПриИзмененииЯчейки"); //Имя процедуры обработчика
    
    ПолеВвода.УстановитьДействие(
    "НачалоВыбора",             //Имя события
    "ПриНачалеВыбора"); //Имя процедуры обработчика
    
КонецПроцедуры
Задал процедуру обработки события &НаКлиенте
Процедура ПриНачалеВыбора(Элемент)
    //Надо установить отбор по складу
    //СтандартнаяОбработка = Ложь;
    мПараметры = Новый Структура();
    мПараметры.Вставить("РежимВыбора", Истина);
    ВладелецЯчейки=ВернутьСкладВладелецЯчейки();
    мПараметры.Вставить("Отбор", Новый Структура("Владелец", ВладелецЯчейки));
    ФормаВыбора = ПолучитьФорму("Справочник.СкладскиеЯчейки.ФормаВыбора", мПараметры, Элемент);
    ФормаВыбора.Открыть();
КонецПроцедуры

&НаСервере
Функция ВернутьСсылкаНаЯчейку()
    Возврат Объект.Места_Ячейка;
КонецФункции
..
При выборе значения в добавленном справочнике дважды выскакивает форма выбора. Как избежать этого
   МимохожийОднако
 
1 - 26.01.21 - 10:08
СтандартнаяОбработка = Ложь; не помогло
   МимохожийОднако
 
2 - 26.01.21 - 10:16
Разобрался.
Добавил недостающие параметры в процедуру
Процедура ПриНачалеВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    //Надо установить отбор по складу 

    СтандартнаяОбработка = Ложь;
....

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.