Вход | Регистрация
 

Печать строки на ФР

Печать строки на ФР
Я
   Cyrix
 
24.01.21 - 13:16
Всем привет!
Как напечатать на ФР Атол или Штрих ОДНУ текстовую строку без всяких там ИНН-ов, РНМ-ов, ФН-ов и прочего ...?
МенеджерОборудованияКлиент.НачатьПечатьТекста(Неопределено, Новый УникальныйИдентификатор, "ля-ля-ля три рубля") - выводит все фискальные данные после моего текста.

8.3, УНФ 1.6
   vovastar
 
1 - 24.01.21 - 13:37
(0) стесняюсь спросить, а зачем?
   Cyrix
 
2 - 24.01.21 - 13:42
Хочется рекламный текст распечатать, но без лишней информации. Предзаказ например.
   Cyrix
 
3 - 24.01.21 - 13:50
Эта информация - подвал чека. Как его выключить при печати? Есть какой-то параметр, отвечающий за это?
   Cyrix
 
4 - 24.01.21 - 13:53
свойство PO.PrintFinalCliche, с помощью которого определяется необходимость печати клише. По умолчанию свойство имеет значение "true", что соответствует печати клише. - как его за false-тить?
   Ненавижу 1С
 
5 - 24.01.21 - 13:53
(3) в драйвере атола есть возможность редактирования клише
   Ненавижу 1С
 
6 - 24.01.21 - 13:54
   Cyrix
 
7 - 24.01.21 - 13:56
(6) :о) подвал всё равно вылезет
   Cyrix
 
8 - 24.01.21 - 13:57
(5) зачем? Клеше то тут причём? Речь об отключении подвала
   Исновая
 
9 - 24.01.21 - 13:58
0 печальную весть вам принес...
   Cyrix
 
10 - 24.01.21 - 14:21
Проще забить и оставить этот подвал в покое. Ужас какой-то.
   Исновая
 
11 - 24.01.21 - 14:23
Printstring..но 1с вас считает не пограммистами, ешьте чоо дали
   Cyrix
 
12 - 24.01.21 - 14:56
PrintString()
ПечатьСтроки()
Метод служит для печати строки символов на чековой ленте и/или контрольной
ленте. Печать строки возможна только внутри открытого чека. При открытии чека печатаются реквизиты.
   Йохохо
 
13 - 24.01.21 - 15:50
BeginDocument()Печать нефискального документа на принтере ПД. Метод переводит драйвер в состояние буферизации данных, добавляемых методами печати строки. Это  означает,  что  все  последующие  команды PrintString помещают  данные  во временный  буфер  драйвера  (в  памяти  ПК).  Данныебудут  переданы  и  напечатаны  на  ККМ только по команде EndDocument. Очистка буфера осуществляется командой ClearOutput.
оно?
   Cyrix
 
14 - 24.01.21 - 16:33
Что-то со мной не так. Теперь не могу создать объект драйвера. Или создаётся как то криво:
&НаСервере
Функция ПолучитьОбъектДрайвера(ДанныеДрайвера, ТекстОшибки = Неопределено)
    
        глПодключаемоеОборудование = Новый Структура();
        глПодключаемоеОборудование.Вставить("ДрайвераПодключаемогоОборудования", Новый Соответствие());
        глПодключаемоеОборудование.Вставить("ПараметрыПодключенияПО"           , Новый Массив());
        глПодключаемоеОборудование.Вставить("ПоследнийСлипЧек"                 , "");
        глПодключаемоеОборудование.Вставить("ЗавершениеРаботыСистемы"          , Ложь);
    
    ОбъектДрайвера = Неопределено;
    
    Для Каждого ДрайверПО Из глПодключаемоеОборудование.ДрайвераПодключаемогоОборудования Цикл
        Если ДрайверПО.Ключ = ДанныеДрайвера.ДрайверОборудования  Тогда
            ОбъектДрайвера = ДрайверПО.Значение;
            Прервать;
        КонецЕсли;
    КонецЦикла;   
    
    Если ОбъектДрайвера = Неопределено Тогда
        Попытка
            
            ProgID = ДанныеДрайвера.ИдентификаторОбъекта;
            Если ПустаяСтрока(ProgID) Тогда
                ОбъектДрайвера = "";// Драйвер не требуется

            Иначе
                ProgID1 = ?(Найти(ProgID, "|") > 0, Сред(ProgID, 1, Найти(ProgID, "|")-1), ProgID); 
                ProgID2 = ?(Найти(ProgID, "|") > 0, Сред(ProgID, Найти(ProgID, "|")+1), ProgID); 
                Если ДанныеДрайвера.ПоставляетсяДистрибутивом Тогда
                    ПодключитьВнешнююКомпоненту(ProgID1);
                Иначе
                    ИмяОбъекта = Сред(ProgID1, Найти(ProgID1, ".") + 1); 
                    Префикс = Сред(ProgID1, 1, Найти(ProgID1, ".")); 
                    ProgID2 = Префикс + СтрЗаменить(ИмяОбъекта, ".", "_") + "." + ИмяОбъекта;
                    Если ДанныеДрайвера.ВСоставеКонфигурации Тогда
                        Результат = ПодключитьВнешнююКомпоненту("ОбщийМакет." + ДанныеДрайвера.ИмяМакетаДрайвера, СтрЗаменить(ИмяОбъекта, ".", "_"));
                    Иначе
                        СсылкаНаДрайвер = ПолучитьНавигационнуюСсылку(ДанныеДрайвера.ДрайверОборудования, "ЗагруженныйДрайвер");
                        Результат = ПодключитьВнешнююКомпоненту(СсылкаНаДрайвер, СтрЗаменить(ИмяОбъекта, ".", "_"));
                    КонецЕсли;
                КонецЕсли;
                ОбъектДрайвера = Новый (ProgID2);
            КонецЕсли;
                
        Исключение
            Инфо = ИнформацияОбОшибке();
            ТекстОшибки = Инфо.Описание;
        КонецПопытки;
        
        Если ОбъектДрайвера <> Неопределено Тогда
            глПодключаемоеОборудование.ДрайвераПодключаемогоОборудования.Вставить(ДанныеДрайвера.ДрайверОборудования, ОбъектДрайвера);
            ОбъектДрайвера = глПодключаемоеОборудование.ДрайвераПодключаемогоОборудования[ДанныеДрайвера.ДрайверОборудования];
        КонецЕсли;
        
    КонецЕсли;   
        
    Возврат ОбъектДрайвера;
    
КонецФункции

//-----------------------------------------

&НаСервере
Процедура ТестПечатиНаСервере()
//Перем Идентификатор;    

ТипыПО = Неопределено;
Идентификатор = Неопределено;
РабочееМесто = Неопределено;
ТолькоАвтоматическаяФискализация = Ложь;
мсф = Справочники.ПодключаемоеОборудование.ОборудованиеПоПараметрам(ТипыПО, Идентификатор, РабочееМесто, ТолькоАвтоматическаяФискализация);    
дрв = Справочники.ДрайверыОборудования.НайтиПоНаименованию(мсф[0].ссылка.ДрайверОборудования).Ссылка;
ДанныеДрайвера = МенеджерОборудованияВызовСервера.ПолучитьДанныеДрайвера(дрв);    
ФР = ПолучитьОбъектДрайвера(ДанныеДрайвера);
ФР.BeginDocument(); <---- говорит, что нет такого метода
КонецПроцедуры
   Йохохо
 
15 - 24.01.21 - 18:37
   Исновая
 
16 - 24.01.21 - 19:38
(14) я жте сказал..жуй что дали ...у интеграционной копмоненты нет такой метода
   Йохохо
 
17 - 24.01.21 - 19:52
(16) "у интеграционной копмоненты" "ах, бритва оккама, бессердечная ты сука" (!sic)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.