Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Что я не так делаю? Набор записей РН не выгружается в ТЗ.

Что я не так делаю? Набор записей РН не выгружается в ТЗ.
Я
   Обработка
 
21.01.21 - 07:34
Вот  код:

    ИС_Пятерка =  НомераГТДСервер.ПолучитьИсточникПроисхожденияПоУмолчанию();
  //  РегистрыНакопления.ТоварыОрганизацийБУ.УстановитьИспользованиеИтогов(Ложь);
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
            |    ТоварыОрганизацийБУ.Регистратор
            |ИЗ
            |    РегистрНакопления.ТоварыОрганизацийБУ КАК ТоварыОрганизацийБУ
            |ГДЕ
            |    ТоварыОрганизацийБУ.Период > &НачалоПериода
            |    И ТоварыОрганизацийБУ.ИсточникПроисхождения = ЗНАЧЕНИЕ(Справочник.ИсточникиПроисхождения.ПустаяСсылка)

            |СГРУППИРОВАТЬ ПО
            |    ТоварыОрганизацийБУ.Регистратор";
    
    Запрос.УстановитьПараметр("НачалоПериода", НачалоПериода);
    Рег = РегистрыНакопления.ТоварыОрганизацийБУ;
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        ОбработкаПрерыванияПользователя();
        Сообщить(Выборка.Регистратор);
        
        Рег = РегистрыНакопления.ТоварыОрганизацийБУ;
        НаборЗаписей = Рег.СоздатьНаборЗаписей();
        НаборЗаписей.Отбор.Регистратор.Значение = Выборка.Регистратор;
        ТЗ = НаборЗаписей.Выгрузить();
        Для Каждого стр из ТЗ Цикл
            Если Стр.ИсточникПроисхождения = Справочники.ИсточникиПроисхождения.ПустаяСсылка() Тогда
                Стр.ИсточникПроисхождения = ИС_Пятерка;
            КонецЕсли;    
        КонецЦикла;    
        НаборЗаписей.Очистить();
        НаборЗаписей.Загрузить(ТЗ);
        НаборЗаписей.Записать();
        прервать;
    КонецЦикла;
   // РегистрыНакопления.ТоварыОрганизацийБУ.УстановитьИспользованиеИтогов(Истина);
   ДенисЧ
 
1 - 21.01.21 - 07:35
.Прочитать()
   Обработка
 
2 - 21.01.21 - 07:42
(1) Спасибо!
Черт чужой код копируешь и не думаешь.  v8: Как заполнить или подключить обработку к документу "Корректировка записей регистров"?

Потом ищешь ошибки.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.