Вход | Регистрация
 

1С Asterisk как принять звонок?

1С Asterisk как принять звонок?
Я
   andryscha1c
 
20.01.21 - 16:08
Есть внешняя компонента которая отлавливает события из Asterisk. Когда выловили входяший звонок, то показываем пользователи оповещение о звонке, с кнопкой "принять" и "отклонить". Так вот как можно принять звонок, что бы он принялся и связь перешла на пример на программный телефон Simple-Phone. Логически нужно команду запулить в Астериск на соединение, но не знаю пока что какую. Подглядел в бесплатной панели телефонии 1С там используют следующее:
&НаКлиенте
Процедура ПринятьЗвонок(НомерЛинии)
    
    КомандаСтруктура = Новый Структура;
    КомандаСтруктура.Вставить("name", "answer");
    КомандаСтруктура.Вставить("line", НомерЛинии);        
    ОтправитьКоманду(КомандаСтруктура);
        
КонецПроцедуры

&НаКлиенте
Процедура ОтправитьКоманду(КомандаСтруктура) Экспорт
    
    Если ТелефонПодключен Тогда
        КомандаСтрока = "type=command;";
        Для Каждого Элемент Из КомандаСтруктура Цикл
            КомандаСтрока = КомандаСтрока + Элемент.Ключ+"="+Элемент.Значение+";";
        КонецЦикла;
        
        ВК.Команда(КомандаСтрока);
        
        Если Объект.Отладка Тогда
            ВывестиСообщениеПользователю("====>====>====>====>");
            ВывестиСообщениеПользователю("ТекЛиния " + ТекЛиния + "  Команда: " + КомандаСтрока);
        КонецЕсли;
    Иначе
        ВывестиСообщениеПользователю("Сфотфон не подключен. Каманда не выполнена");
    КонецЕсли;
    
КонецПроцедуры

Параметр answer отвечает как раз за принятие звонка.
тут я так понимаю либо нужна другая компонента, которая используется в панелях телефонии 1с либо правильно дать команду.

Кто сталкивался подскажите в чем дело?
   andryscha1c
 
1 - 20.01.21 - 16:55
Сложно все похоже =)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.