Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Поиск документа по штрихкоду - ERP 2.4

Поиск документа по штрихкоду - ERP 2.4
Я
   serg999
 
19.01.21 - 11:58
Добрый день. Подтолкните малость ...

Включил ШК в документах (в форме печати ШК выводит), добавил сканер. Не могу понять, как работает поиск по ШК в списке документа?

Есть обработка "ПоискОбъектовПоШтрихкоду" .. попробовал в нее подсунуть номер из ШК. Тут все робит, ссылку на документ возвращает.

Пробую поиск из списка документов, фокус переходит в поисковую строку, результат нулевой. Куда ему этот код внести ???

Посмотрел код, в списке документов, есть событие "ОбработкаОповещения" по нему далее "ОбработатьШтрихкоды" и поиск объекта по ШК, но я не могу понять, что должно произойти чтобы событие отработало :((

Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)

    // ПодключаемоеОборудование
    Если Источник = "ПодключаемоеОборудование" И ВводДоступен() Тогда
        Если ИмяСобытия = "ScanData" И МенеджерОборудованияУТКлиент.ЕстьНеобработанноеСобытие() Тогда
            ОбработатьШтрихкоды(МенеджерОборудованияУТКлиент.ПреобразоватьДанныеСоСканераВСтруктуру(Параметр));
        КонецЕсли;
    КонецЕсли;
    // Конец ПодключаемоеОборудование

КонецПроцедуры
   polosov
 
1 - 19.01.21 - 12:18
(0) Возьми сканер и сканируй.
   serg999
 
2 - 19.01.21 - 12:26
(1) Взял сканер, отсканировал .. результат балалайка ..

Может какой префикс ему нужен в начале ?
   ДенисЧ
 
3 - 19.01.21 - 12:39
"обработка "ПоискОбъектовПоШтрихкоду" .. попробовал в нее подсунуть номер из ШК. Тут все робит"

Так что тебе ещё, хороняка, надобно?
Возьми эту обработку и посмотри, как там сделано...
   serg999
 
4 - 19.01.21 - 12:52
(3) Тык написал все выше ..
Сканер должен отправит оповещение, а процедура в форма перехватить .. так вот этого не происходит!
   ДенисЧ
 
5 - 19.01.21 - 12:52
(4) Ну обработка-то перехватывает? вот и смотри, в чём разница
   serg999
 
6 - 19.01.21 - 13:02
(5) Да там все норм ..  код преобразуется в уид, далее возвращает ссылку ..
Вопрос почему событие не отрабатывает ..
   neomarat
 
7 - 19.01.21 - 13:20
Отсканируй для начала в Блокнот - шрихкод появляется?
Как сканер подключен - com или разрыв клавы?
   neomarat
 
8 - 19.01.21 - 13:21
Смотри ОбработкаВнешнегоСобытия в форме - туда попадает при пике со сканера?
   serg999
 
9 - 19.01.21 - 14:21
(7) Через блокнот код проходит.
Сканер Honeywell 1450g (USB) .. подключен в 1С как "1С:Сканеры штрихкода (NativeApi)", порт "Клавиатура", но пробовал и на COM вешать
(8) Такой нет "ОбработкаВнешнегоСобытия", в форме есть ОбработкаОповещения .. но при пике туда не попадает ..
   serg999
 
10 - 19.01.21 - 14:32
Я кажется разобрался .. в 1С, где настройка сканера, есть кнопка "Тест подключению", форма открывается и в ней можно ШК пикнуть, и сразу строка с кодом, так в конце строки стоит "TAB", а в 1С выставлен "CR" .. поменял на "TAB" все взлетело, но блин не явно так.

Спасибо, вопрос закрыт.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.