Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Комплексная автоматизация, ввод начальных остатков и акт сверки

Комплексная автоматизация, ввод начальных остатков и акт сверки
Я
   DJ Anthon
 
19.01.21 - 11:03
Сверка взаиморасчетов (документ там такой есть) производится по регистру РасчетыСКлиентамиПоДокументам.
Документ Ввод начальных остатков по взаиморасчетам вводит движения по регистру РасчетыСКлиентами.
Проведение этого документа ни в какие задания по распределению расчетов не попадает.
Каким, собственно говоря, образом они должны увязываться?
   ДенисЧ
 
1 - 19.01.21 - 11:08
А зачем его проводить ещё раз? Сделал один раз движения и всё. Это же неизменяемая информация...
   DJ Anthon
 
2 - 19.01.21 - 11:16
(1) а затем, что так сейчас там все устроено, чтобы получить движения по документу, надо его провести, чтобы он попал в распределения, а созданные обработкой туда могут и не попасть.
вопрос-то в том, почему он пишет в один регистр, а в отчетах используется другой?
   ДенисЧ
 
3 - 19.01.21 - 11:19
(2) А что, сам документ не делает движения в тот регистр?
   Bigbro
 
4 - 19.01.21 - 11:21
видимо акт сверки - для сверки текущих расчетов за период по документам, а не для сверки начального загруженного сальдо взаиморасчетов.
   DJ Anthon
 
5 - 19.01.21 - 11:21
(3) не делает. в коде такого нет.
   DJ Anthon
 
6 - 19.01.21 - 11:22
(4) а для чего оно тогда нужно? как внести правильное сальдо по взаиморасчетам?
   yzimin
 
7 - 19.01.21 - 11:25
Если только начинаете работать в КА2, включайте сразу он-лайн расчёты
   DJ Anthon
 
8 - 19.01.21 - 11:26
(7) работаем три года, я сделал свертку. что дают онлайн расчеты? мне надо остатки сверить и убедиться, что данные правильно свернуты. а остатков по взаиморасчетам в актах сверки нет
   Bigbro
 
9 - 19.01.21 - 11:27
так вы же его внесли сальдо?
введете потом документ, который задолженность закроет и все будет хорошо.
ну а если интересует акт сверки за период вне учетной системы - сформируйте этот акт там где данные по документам есть до этого периода.
   DJ Anthon
 
10 - 19.01.21 - 11:27
они есть только в ведомости по взаиморасчетам. но клиентам нужны акты, а не ведомости
   DJ Anthon
 
11 - 19.01.21 - 11:28
(9) не понял. я внес сальдо на 31.12. в ведомости за январь оно есть, в акте сверки нет. какой еще период вне учетной системы?
   Bigbro
 
12 - 19.01.21 - 11:29
"мне надо остатки сверить" и "клиентам нужны акты" - не сходится.
   DJ Anthon
 
13 - 19.01.21 - 11:31
(12) в актах сверки сальдо выходит нулевым! что не сходится? остатки сверяю по актам.
   DJ Anthon
 
14 - 19.01.21 - 11:32
до свертки все суммы были. значит, свертка кривая и уничтожает сальдо? как тогда ее делать?
   Михаил Козлов
 
15 - 19.01.21 - 11:38
(11) У меня в акте сумма совпадает с введенной во вводе начальных остатков.
Проверьте Объект расчетов и Расчетный документ во вводе остатков. В сверке (и вводе остатков) объект расчетов - договор.
Он-лайн расчеты: ввод двигает не РН Расчеты по документам, а РН Расчеты с клиентами по срокам (и Плановые оплаты клиентов).
   DJ Anthon
 
16 - 19.01.21 - 11:47
так, задания к расчету появились. надо было отменить документы перед проведением.
   ДенисЧ
 
17 - 19.01.21 - 11:48
(16) Это штатная фича, я в своё время наткнулся ))
   DJ Anthon
 
18 - 19.01.21 - 11:49
значит, эта чертова свертка при проведении документов ввода остатков не заполняет регистр ЗаданияКРаспределениюРасчетовСКлиентами.
опять все за них доделывать. удаление помеченных тоже не работает. надо перед удалением пометить все документы вида РегистраторРасчета с помеченным на удалением объектом расчета.
   DJ Anthon
 
19 - 19.01.21 - 11:49
(17) свертка тоже штатная
   DJ Anthon
 
20 - 19.01.21 - 12:18
итак, распределять заново все взаиморасчеты мне не вперлось, потому что это закрытые периоды, и два года перезакрывать после них тоже неохота, поэтому
в расширении в модуле ВзаиморасчетыСервер добавил

&После("ОтразитьРасчетыСКлиентами")
Процедура А_ОтразитьРасчетыСКлиентами(ДополнительныеСвойства, Движения, Отказ)
    Если ДополнительныеСвойства.ДляПроведения.МетаданныеДокумента.Имя = "ВводОстатков" Тогда
        ТаблицаРасчеты = ДополнительныеСвойства.ТаблицыДляДвижений.ТаблицаРасчетыСКлиентами;
        ДвиженияРасчеты = Движения.РасчетыСКлиентамиПоДокументам;
        ДвиженияРасчеты.Записывать = Истина;
        ДвиженияРасчеты.Загрузить(ТаблицаРасчеты);
    КонецЕсли;
КонецПроцедуры

&После("ОтразитьРасчетыСПоставщиками")
Процедура А_ОтразитьРасчетыСПоставщиками(ДополнительныеСвойства, Движения, Отказ)
    Если ДополнительныеСвойства.ДляПроведения.МетаданныеДокумента.Имя = "ВводОстатков" Тогда
        ТаблицаРасчеты = ДополнительныеСвойства.ТаблицыДляДвижений.ТаблицаРасчетыСПоставщиками;
        ДвиженияРасчеты = Движения.РасчетыСПоставщикамиПоДокументам;
        ДвиженияРасчеты.Записывать = Истина;
        ДвиженияРасчеты.Загрузить(ТаблицаРасчеты);
    КонецЕсли;
КонецПроцедуры
   DJ Anthon
 
21 - 19.01.21 - 12:23
(15) перейдем, когда свертку закончим, на это еще месяца два уйдет. сначала надо избавиться от миллионов лишних записей в регистрах. зря наделали подразделений, а как оказалось, нужды в них нет, а они умножают количество движений во много раз.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.