Вход | Регистрация
    1  2

OFF: О важности указания тарифов при общении с суб-подрядчиками

OFF: О важности указания тарифов при общении с суб-подрядчиками
Я
   Гений 1С
 
18.01.21 - 12:47
Пытаюсь взять натурой с одного фрилансера, который должен мне 12.500 рублей.

Поручил ему простую задачку, написал: "есть задача на 15 минут * 1000 рублей".
Так вот он воспринял это как 1000 рублей за 15 минут, т.е. по тарифу 4000 рублей в час.
Хотя мы с ним всегда работаем по 1000.

Я понимаю, если бы я написал "15 минут = 1000 рублей".

В общем, в итоге сошлись на 500, но вот эти непонятки, они откуда вообще?

Я туплю или фрилансер?
   dangerouscoder
 
101 - 19.01.21 - 23:25
(92) цикл зачем нужен? СтрЗаменить для всей строки работает.
   acht
 
102 - 19.01.21 - 23:31
(101) Чтобы посдовательно превращать тройные/четверные и т.п. пробелы в двойные/тройные и т.д. до полного подавления.
   dangerouscoder
 
103 - 19.01.21 - 23:36
(102) читай сразу строку посимвольно и их вообще удалять не надо
   acht
 
104 - 19.01.21 - 23:43
(103) Медленно. Это тебе не си, а неторопливая виртуалка. А так меняем память на скорость.

Вообще это конечно, через СтрСоединить(СтрРазделить(Строка, " ", Ложь), " ") делается.
   dangerouscoder
 
105 - 20.01.21 - 00:30
(104) Да быстрее работает даже с учетом очистки от мусора
Функция СтрокуВМассив(Стр,Разд= " ",Разд2= " ")
    МассОбр = Новый Массив;
    МассВых = СтрРазделить(Стр,Разд,Ложь);
    Если НЕ Разд=" " Тогда
        Для Сч = 0  По МассВых.ВГраница() Цикл
            МассВых.Установить(Сч,  СокрЛП(МассВых.Получить(Сч) ) ) ;
        КонецЦикла;
    КонецЕсли;
    Стр  = СтрСоединить(МассВых,Разд2);
    Возврат МассВых;
КонецФункции
   mgreat
 
106 - 20.01.21 - 05:30
Интересно, а тарифы 5 и 1 минута у Гения бывают? Клиентам выгодна такая тарификация.
А еще лучше так - первые 30 минут бесплатно. Вообще супер тариф, отбоя от заказчиков не будет, которым "просто спросить" ))
   Гений 1С
 
107 - 20.01.21 - 06:07
(106) у меня все округляется до 6 минут (одна десятая часа)
   Гений 1С
 
108 - 20.01.21 - 06:08
(100) ну вот фрил не сбрасывал и попал:
1. Использовал рекурсию
2. Не изолировал функции
3. Слава богу, не опустился до стрразделить
   mgreat
 
109 - 20.01.21 - 06:26
(107) нужно до 1 минуты. 1 минута это круто!
Говоришь заказчику: тарификация поминутная, 1 минута 26 рублей 67 копеек (например). На вашу задачу у меня ушло 20 часов и 37 минут, к оплате столько-то. Вот заказчик охренеет от такой точности!
   Гений 1С
 
110 - 20.01.21 - 06:39
(109) я веду учет работ в экселе, там округляется до 0.1 часа. Я крут в другом, поэтому ко мне без рекламы по сарафану идут
   Bigbro
 
111 - 20.01.21 - 08:31
вспомнил, что мне напомнило

"Просто оцени правильно время заранее

- Слушай, ты разработчик. Ответь, почему разработчики всегда неправильно оценивают время на создание программ?

- Представь что тебе надо разгрузить машину, сколько времени это займет?

- Пару часов

- Это камаз

- 8 часов

- Камаз, груженый песком

- 12 часов

- У тебя нет лопаты и инструментов, только твои руки

- 2 дня

- На улице -40

- 4 дня

- Камаз вообще под водой

- Так же нечестно, ты постоянно придумываешь новые условия! К чему ты мне вообще все это рассказываешь? Вы, разработчики, вечно всякую фигню рассказываете! Вместо этого могли бы просто оценить правильное время на разработку."

(с) https://pikabu.ru/story/prosto_otseni_pravilno_vremya_zaranee_5719042
   dka80
 
112 - 20.01.21 - 09:07
Что-то вся эта ветка напоминает мне старый анекдот:
— Алло, дорогая, только что по радио передали, что один псих едет по встречке. Будь осторожнее!
— Один? Да их тут , млядь, тысячи!
   dangerouscoder
 
113 - 20.01.21 - 09:26
(112) да все стандартно - очередной "очень умный!" товарищ думает нашел "батрака"
но все закончиться проще - "походом в пешее эротическое"
   RetardedToBoot
 
114 - 20.01.21 - 09:38
Качество соответствует оплате. Не то что бы оплата слишком низкая, но в пятнадцати минутных задачах постановка и вникание в задачу может быть дольше. Один не дообъяснил, другой не до спросил.

Как вообще можно отдавать на фриланс задачи в 15 минут? Ведь их проще и быстрее самому сделать, а главное при этом не возникнет недопонимания между постановщиком и исполнителем...

СтрЗаменить
СтрПолучитьСтроку
СтрКоличествоСтрок
решают весь вопрос, в том числе и множественные пробелы.
   DexterMorgan
 
115 - 20.01.21 - 09:41
- Сколько стоит капелька сока?
- Нисколько
- Накапайте стаканчик, плз

А так вопрос не очень понятен, ты рассчитывал ему заплатить 250 руб за задачу?
Я считаю, тарификация всегда часовая, если у тебя нет задач на час - копи задачи и еби мне мозг. Если задача на 15 мин - плати за час
   Гений 1С
 
116 - 20.01.21 - 09:53
(114) еще один "излишне умный". Использовать в строковых функциях функции, которые есть не во всех релизах - это вообще забавно.
   Гений 1С
 
117 - 20.01.21 - 09:53
(115) считай что я у него на поддержке. Мне когда клиент обращается с вопросом мелким, я выставляю 6-12 минут, а не час.
   vovastar
 
118 - 20.01.21 - 09:55
(117) да ты монстр))))
   RetardedToBoot
 
119 - 20.01.21 - 09:59
(116) указанные мной функции есть даже в клюшках.
   dka80
 
120 - 20.01.21 - 10:01
(116) Есть такое понятие, как инженерная точность. Оно говорит нам, что что-то нужно выполнять с необходимой и достаточной точностью. Даже если ты не используешь функции, которые есть только в определенных релизах, то какова вероятность, что тебе не пришлют строку в формате base64 и тогда пойдет весь твой алгоритм по одном мохнатому месту. Всегда нужно ограничивать функциональность, а не заявлять, что она работает на всех и вся.
   vovastar
 
121 - 20.01.21 - 10:01
(117) быть программистом и быть на поддержке у программиста, это сильно)
Водители нанимают водителей, уборщицы нанимают уборщиц)
   ДенисЧ
 
122 - 20.01.21 - 10:02
" быть программистом^Wгением и быть на поддержке у программиста"

Извини, немного поправил...
   RetardedToBoot
 
123 - 20.01.21 - 10:20
(117) Поддержка выставляется фиксированной оплатой за период. Вроде у всех так. Я конечно могу ошибаться, и есть исключения..
   Гений 1С
 
124 - 20.01.21 - 13:20
(120) я использую эти функции в универсальной обработке. Не хочу лишних проблем на пустом месте, поэтому и заказал эти 2-3 функции за 15 минут
   Гений 1С
 
125 - 20.01.21 - 13:20
(121) это называется "подаван"
  1  2

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.