Вход | Регистрация
    1  2   

OFF: О важности указания тарифов при общении с суб-подрядчиками

OFF: О важности указания тарифов при общении с суб-подрядчиками
Я
   Гений 1С
 
18.01.21 - 12:47
Пытаюсь взять натурой с одного фрилансера, который должен мне 12.500 рублей.

Поручил ему простую задачку, написал: "есть задача на 15 минут * 1000 рублей".
Так вот он воспринял это как 1000 рублей за 15 минут, т.е. по тарифу 4000 рублей в час.
Хотя мы с ним всегда работаем по 1000.

Я понимаю, если бы я написал "15 минут = 1000 рублей".

В общем, в итоге сошлись на 500, но вот эти непонятки, они откуда вообще?

Я туплю или фрилансер?
   ДенисЧ
 
1 - 18.01.21 - 12:50
Ты
   DrShad
 
2 - 18.01.21 - 12:51
первый час неделим
   Rovan
 
3 - 18.01.21 - 12:52
"Пытаюсь взять натурой" - интрига... дальше каике-то цифры, конфликт... в итоге компромисс в 500 рублей, но все злы друг на друга
   Холст
 
4 - 18.01.21 - 12:54
Какой-то бедняга под анальным рабством у Гения 1С ...
   1СникКривыеРуки
 
5 - 18.01.21 - 12:54
Я с Гения фигею!

Всю жизнь было - первый час считаем полным независимо от времени решения.
Возможно иное, но четко оговаривается.
Я бы в (0)воспринял бы как 15 мин за 1000 руб.
   Вафель
 
6 - 18.01.21 - 12:54
если так нечетко ставить задачу, то конечно каждый будет в свою сторону тянуть
   Гений 1С
 
7 - 18.01.21 - 12:54
(3) не, мы не злы. но я реально удивлен, что чувак рассчитывал на 1к за 15 минут. Задача то не важная и не срочная и вообще не прикладная даже, так из курса информатики.
   Гений 1С
 
8 - 18.01.21 - 12:55
(5) ну мы то с ним не впервые работаем. я бы не стал платить 1к за 15 минут
   1СникКривыеРуки
 
9 - 18.01.21 - 12:55
Хотя да, за 500 руб. за задачу... Это тока если добавить реквизит.
Рабство какое то... Гений наверно нашел золотую жилу рабов и с нее кормится
   acht
 
10 - 18.01.21 - 12:56
(4) Дык вот так вот у них у фрилансеров принято. Ты думаешь, что Геня так радуется, что фрилансером стал?
   Холст
 
11 - 18.01.21 - 12:57
Особохитрозадые заказчики как раз стремятся сначала бесплатно "обсуждать и спрашивать" задачу, а потом заплатить за финальные 5 минут кодинга разделив ставку часа на эти минуты
   Гений 1С
 
12 - 18.01.21 - 13:01
(9) там задача была написать строковую функцию простую
   Стаканов
 
13 - 18.01.21 - 13:01
(0) Оба красавцы, один хрень неоднозначную пишет, другой начинает работать, не обговорив условия полностью.
   1СникКривыеРуки
 
14 - 18.01.21 - 13:01
Хотя все эти часы очень условны.

Как пример - есть задача примерно на стандартные 4 дня. Т.е.32 часа.
В теории я должен запросить мин 32 тр.
Но заказчика денег стока нет и он готов заплатить 15-16тр.
Договариваемся и делаем. Ибо 15 тр за 4 дня лучше чем совсем ничего. Особенно + к ЗП.
ибо можно и ночью поработать
   Rovan
 
15 - 18.01.21 - 13:02
(7) 1000 руб в час и 15 мин работы...  - там наверное только задачу прочитать \ обсудить занимает 15 минут
+ сделать+ проверить + передать + показать....  Так что (2) - прав !
   Вафель
 
16 - 18.01.21 - 13:05
(14) часы - это у.е, а не реально потраченные часы.
   Вафель
 
17 - 18.01.21 - 13:06
у них только на один спор о сумме потрачено куда больше 15 мин
   1СникКривыеРуки
 
18 - 18.01.21 - 13:07
(16)и я о том же. Ты считаешь, что можешь сделать задачу и меньше сумм N делать не готов. А подрядчик не готов платить больше суммы M.
Все остальное в этих рамках
   d4rkmesa
 
19 - 18.01.21 - 13:38
(0) Сережа, не позорьтесь. Зажал 500 руб коллеге. Если работал на франче, должен же знать, что там округляют частенько до часов, причем в большую сторону.
   Guk
 
20 - 18.01.21 - 13:39
я смотрю тяжело у автора стартап развивается ;)...
   dka80
 
21 - 18.01.21 - 13:46
Удивляют эти задачи на 15 минут. Можешь расписать из чего у тебя 15 минут складываются? Например для себя укрупненно так оцениваю стоимость работы в часах:
1. Обсудить задачу
2. Написать ФТ/ТЗ или еще что. Даже на простую функцию должны быть формализованы требования
3. Реализовать задачу
4. Внутреннее тестирование
5. Сдать задачу заказчику
6. Написать инструкцию
Далее это время умножается на 1,3 чтобы учесть возможные риски

Также не забываем, что одно дело для БП что-то сделать, другое для ERP, когда одна конфигурация будет фиг знает сколько загружаться
   ДенисЧ
 
22 - 18.01.21 - 13:47
(21) "Подвинь картинку на 10 пикселей и увеличь шрифт заголовка на 2 пункта"
   Гений 1С
 
23 - 18.01.21 - 13:47
(15) нет, не прав. Если дешево, не стоит браться.
   Гений 1С
 
24 - 18.01.21 - 13:47
(17) Трендеть - не работать.
   Гений 1С
 
25 - 18.01.21 - 13:48
(19) начнем с того, что коллега торчит мне 12.500, т.к. не смог справиться с проектом. Просто даже не взялся за него недельку после получения аванса, в итоге чего мне потом пришлось в мыле нагонять.
   Гений 1С
 
26 - 18.01.21 - 13:49
(21) ну это была мелкая задака, которую лень самому было делать.
   vovastar
 
27 - 18.01.21 - 13:50
(20) Финита ля комедия)
   zak555
 
28 - 18.01.21 - 13:51
(0) брось учитывать деньги по времени
   vovastar
 
29 - 18.01.21 - 13:52
а почему задача на 15 минут, а не на 16 или 14? Сметную оценку времени кто разрабатывал?
   dka80
 
30 - 18.01.21 - 13:53
(22) Согласен, что задача на первый взгляд плевая, но по факту может выйти, что надо было не на 10, а на 9 и не влево, а вверх и шрифтом поиграться. А потом выяснится, одно поле начинает наезжать на другое... Так что все эти задачи на 15 минут... Либо собирай в кучу все задачи и давай на целый час
 
 Рекламное место пустует
   Стаканов
 
31 - 18.01.21 - 13:53
(25) Какой ужас...
   vovastar
 
32 - 18.01.21 - 13:55
(31) после этого, Серго впоймал цейнот..
   Стаканов
 
33 - 18.01.21 - 13:56
(32) И слава богу, хоть на немного на Мисте тупых тем чутка поменьше стало.
   hhhh
 
34 - 18.01.21 - 14:43
(25) ну это ведь обычно так. Это только вы, как Гений, получив задание, тут же садитесь за комп и начинаете строчить строчки кода, с бешеной скоростью, как пулемет. Обычные люди по другому работают, нужно сначала всё обдумать, освоиться на незнакомом проекте, ну хотя бы первую недельку. А потом уже не спеша приступать к выполнению.
   БаксПо90
 
35 - 18.01.21 - 14:49
(34) ничего ты не понимаешь, он уже в 12500 сделал человека себе обязанным. Видишь, теперь планирует его часы и тарифы обсуждает с нами , а не с ним.
А в обычной жизни , его бы за такие деньги уже бы послали бы
   Обработка
 
36 - 18.01.21 - 14:55
(0) Когда же ты работаешь то?
   fisher
 
37 - 18.01.21 - 15:02
(7) Чувак, наверное, тоже удивился. Но ситуации разные бывают. Мало ли. Суперсрочность, например. С деньгами не шутят. И небрежности они тоже не любят.
   Малыш Джон
 
38 - 18.01.21 - 15:36
(0) 4к в час??? а чего так мало то?)
   Джинн
 
39 - 18.01.21 - 15:41
(7) Вы предложили - он согласился. Платите.
   vovastar
 
40 - 18.01.21 - 15:41
(38) за Имя надо платить.
Платят же за огрызок столько, сколько он не стоит...
   Hans
 
41 - 18.01.21 - 15:44
DrShad разбанили что ли?
   Гений 1С
 
42 - 18.01.21 - 16:15
(2) Прям право "первой брачной ночи", неоспоримое напомнило, ггг.
(28) с хера ли?
(29) я предложил - он согласился.
(30) тут есть два варианта - предложить клиенту овербюджет или отказаться от задачи. Я никогда не требую у клиента платить больше если договаривались на меньше, можно просто отказаться делать за эти деньги.
(34) там задача не по проекту была, чистая математика. (39) 500 и заплатил. вычел из его долга 4% получается "отработал".
   Гений 1С
 
43 - 18.01.21 - 16:16
(41) если он был забанен, то поздравляю его с разбаном. Хороший чувак, хоть и с Украины
   Вафель
 
44 - 18.01.21 - 17:14
те проще (быстрее) отдать такую маленькую задачу непонятному чуваку чем написать самому?
   Trimax
 
45 - 18.01.21 - 17:18
(44) Ну хоть кто-то внес здравую мысль в феерию бреда серожи. Ну не верю я что 1000 рублей и серожи менее важно написания очередной фантазии в ЖЖ....
   Вафель
 
46 - 18.01.21 - 17:20
хотя может потому что долг и чтобы хоть что-то закрыть он портатил 2-3 часа своего времени
   Itmaint
 
47 - 18.01.21 - 17:21
взять натурой// ты что, из этих, радужных?
   Aleksey
 
48 - 18.01.21 - 17:25
(47) Не обязательно. Он может вызвать проституток и заставит его за себя "отрабатывает" вызов
   vovastar
 
49 - 18.01.21 - 17:33
(48) а может троячок?
   dka80
 
50 - 18.01.21 - 17:36
Мне друг говорил, что они больше чем 1000 руб за час берут
   Быдло замкадное
 
51 - 18.01.21 - 17:39
за 250 рублей даже текст задачи читать не буду. Какую ерундой вы занимаетесь.......
   dmt
 
52 - 18.01.21 - 17:48
(51) никто бы не стал, поэтому ТС сыграл в маркетолога при обозначении цены
   dmpl
 
53 - 18.01.21 - 18:01
(0) Я бы 15 тыр. попросил - по 1000 рэ за минуту.
   dmpl
 
54 - 18.01.21 - 18:05
(22) А потом выясняется, что это генерится программно, получая описание формы от удаленного сервера, который на каждый запрос меняет данные в рабочей базе :)
   Гений 1С
 
55 - 18.01.21 - 18:07
(44) ага, лень. уже сто раз писал.
   dmpl
 
56 - 18.01.21 - 18:08
(42) Минимальное количество часов - это обычай делового оборота в данном случае. Т.е. по умолчанию так. Если не так - это обговаривается отдельно.
   Гений 1С
 
57 - 18.01.21 - 18:33
(56) у нас оговорено отдельно
   Ненавижу 1С
 
58 - 18.01.21 - 19:03
Пиши уже условие задачи, а то у тебя то строковая функция, то чистая математика
   dangerouscoder
 
59 - 18.01.21 - 19:16
А что же за основное задание завалил твой суб-подрядчик. Может там специально ценник был занижен в разы?
   Гений 1С
 
60 - 18.01.21 - 19:56
(58) выделить слово под номером N из строки
 
 Рекламное место пустует
   acht
 
61 - 18.01.21 - 20:08
(60) 4000 рублей. Специально для тебя.
   timurhv
 
62 - 18.01.21 - 20:12
(51) Я бы взялся если там работа из разряда передвинуть элемент формы, поправить процедуру и в пуле >30 задач в одной базе.
   dka80
 
63 - 18.01.21 - 22:21
(60) а предлог является словом? а если есть знаки препинания их надо отсекать, а разделитель между словами точно пробел?
   dka80
 
64 - 18.01.21 - 22:23
(60)
функция словоизстроки(твоястрока, номерслова)
Возврат стрразделить(твоястрока)[номерслова-1]
конецфункции

где мои 250 рублей?
   Ненавижу 1С
 
65 - 18.01.21 - 23:39
(64) это у вас мало опыта общения с гением. Сейчас выяснится, что имелось ввиду другое. А кто не согласен - буквоед!
   МихаилМ
 
66 - 19.01.21 - 01:45
(64)
если пробелов больше 1 , может быть ошибка
   Гений 1С
 
67 - 19.01.21 - 07:28
(64) стрразделить есть не во всех 1С, переписывай.
   Гений 1С
 
68 - 19.01.21 - 07:29
(66) молодец, надо тыкать самоуверенных подаванов в их промахи
   dka80
 
69 - 19.01.21 - 07:54
(68) вот об этом я и писал: сейчас всплывут нюансики: не во всех платформах есть стрразделить, может быть два пробела и т.д. и т.п. Так уж ли задача на 15 минут?
   Ненавижу 1С
 
70 - 19.01.21 - 08:10
(68) твоя проблема что в своей самоуверенности ты даже не понимаешь что не умеешь ставить корректно задачи. В терминологии у тебя тоже всё плохо
   dmpl
 
71 - 19.01.21 - 08:13
(67) Платформа не была указана. Обновляйте.
   Гений 1С
 
72 - 19.01.21 - 15:52
(71) клиент всегда прав. Хочешь быть успешным фрилансером - все оговаривай заранее, иначе за твой щот.
Кстати, задача была поставлена так (т.е. две функции):
Есть задача на 15 минут * 1000 рублей, чисто на написание строковой функции выделения последнего слова из строки и слова с номером N.

И кстати, фрилансер мне эту функцию написал так:

Процедура РазложитьСтроку(Стр,Раздел,НомерКрайнегоСлова)
    Если НомерКрайнегоСлова > 0 И ТП.Количество() = НомерКрайнегоСлова Тогда
        Возврат;
    КонецЕсли;
    ДлинаРазделителя = СтрДлина(Раздел);
    НовСтрТП = ТП.Добавить();
    НовСтрТП.НС = ТП.Количество();
    Поз = Найти(Стр,Раздел);
    Если Поз = 0 Тогда
        НовСтрТП.Слово = Стр;
    Иначе
        НовСтрТП.Слово = Сред(Стр,1,Поз-1);
        Стр = Сред(Стр,Поз+ДлинаРазделителя);
        РазложитьСтроку(Стр,Раздел,НомерКрайнегоСлова);
    КонецЕсли;
КонецПроцедуры


Процедура ОсновныеДействияФормыКонечное(Кнопка)
    Если СтрДлина(СокрЛП(Разделитель))= 0 Тогда
        Раздел = " ";
    Иначе
        Раздел = Разделитель;
    КонецЕсли;
    ДлинаРазделителя = СтрДлина(Раздел);
    Стр = УдалитьЛишниеПробелы(Предложение);
    Для Сч = -(СтрДлина(Предложение)-ДлинаРазделителя) По -1 Цикл
        Если Сред(Стр,-Сч,ДлинаРазделителя) = Раздел Тогда
            Сообщить("Крайнее слово: '"+Сред(Стр,-Сч+ДлинаРазделителя)+"'");
            Возврат;
        КонецЕсли;
    КонецЦикла;
    Сообщить("Не найден разделитель!");
КонецПроцедуры


Вас ничего не смущает в его решении?
по мне так тотальный игнор постановки задачи...
   Гений 1С
 
73 - 19.01.21 - 15:53
(70) это не проблема, а особенность всех заказчиков. Вроде фрил не новичок и общался с реальными заказчиками. Меня удивляет, что все сомнения он решил по-своему а не спросил "как надо". Спрашивать "чего изволите" - это простите, просто MUST HAVE у фрилансера.
   Гений 1С
 
74 - 19.01.21 - 15:54
(69) тут видишь какое дело - я предложил, он согласился. Никто его не заставлял соглашаться без "нюансиков".
Если я в процессе вижу, что не укладываюсь во время, или прошу повышения бюджета или отказываюсь от задачи (если нет согласия по бюджету)
   dka80
 
75 - 19.01.21 - 16:34
(72) "клиент всегда прав" - именно поэтому в (21) такие пункты и 30% риска, а с некоторыми заказчиками и того больше надо закладывать))
"Спрашивать "чего изволите"" - за чей счет беседа по душам? Как уже писали ранее, написание кода может и занять 15 минут, а вот выявление "чего изволите" порой часами длится и заканчивается как в той байке "все нормально, но поиграйтесь с формой квадрата"
Кстати, клиент не всегда прав, иногда он может очень не двусмысленно пойти на йух, потому что нервы одни, а клиент и другой будет.
   Конструктор1С
 
76 - 19.01.21 - 16:55
(72) какой уродливый код
   Гений 1С
 
77 - 19.01.21 - 17:29
(76) А в чем именно? Хотя меня смущают два момента:
1. НовСтрТП - странный идентификатор.
2. Отсутствие пробела после запятых - это подчерк "семерочника"
   Гений 1С
 
78 - 19.01.21 - 17:30
(75) так все верно. Если клиент начинает выделываться, проще уйти от такого клиента. Но махать после драки кулаками тоже не стоит.
Выходы я уже описал:
1. Делать в рамках бюджета.
2. Попросить увеличения бюджета.
3. Отказаться от задачи и (возможно) клиента.
   BeerHelpsMeWin
 
79 - 19.01.21 - 17:53
(76) Рекурсия - это современно!
   dangerouscoder
 
80 - 19.01.21 - 18:00
(76) Гений нашел достойного последователя ))
про первоначальную задачу мы так и не узнаем
   Конструктор1С
 
81 - 19.01.21 - 18:02
(77) во всём. Это не код, а уродство. 30 строк кода, а хватит на целую лекцию, как НЕнадо писать код
   Конструктор1С
 
82 - 19.01.21 - 18:04
(79) рекурсия это способ сделать логику [обычно и без того хромого] кода ещё более запутанной
   Стаканов
 
83 - 19.01.21 - 18:52
(81) Раз фиксину нравится, значит он сам примерно так и пишет. Что вполне ожидаемо, впрочем.
   Garykom
 
84 - 19.01.21 - 18:56
Я правильно понял что суть "фриланса" гения это микрободишоп?
   acht
 
85 - 19.01.21 - 19:04
(80) Не. Геня внезапно увидел фрилансера со стороны заказчика.
   Вася Теркин
 
86 - 19.01.21 - 19:17
Это нужно перенести в ветку про кино: гений 2 притворяюсь дурачком попадает в кабалу к ма приму одинэснику, отчаянно пытающегося организовать собственный фриланс бизнес. Внедрившееся диверсант за 8 лет и 3 руб окончательно уничтожает все надежды упертого предшественника. За происходящим следит общественность и Волшебник.... Как бы вы назвали такое кино?
   Николай Жирнов
 
87 - 19.01.21 - 19:32
у меня как-то был похожитй случай - не поняли друг друга на берегу с заказчиком.. правда в итоге он мне все оплатил но больше не общаемся))
   BeerHelpsMeWin
 
88 - 19.01.21 - 19:44
(82) Извините за непонимание, просто я больше не пишу слово "сарказм" в ветках Гения :)
   BeerHelpsMeWin
 
89 - 19.01.21 - 19:46
Хотя так-то ему надо завидовать.
Кто еще сможет выложить 500 рублей за РазложитьСтрокуВМассивПодстрок? То-то же!
   Гений 1С
 
90 - 19.01.21 - 19:57
(82) а, ну да, я ему высказал за рекурсию, он переделал потом без рекурсии. Могу дать финальный код в студию, если хотите
   Гений 1С
 
91 - 19.01.21 - 20:03
Одну функцию пришлось написать самому:
   Гений 1С
 
92 - 19.01.21 - 20:03
Функция ОдинРазделитель(Знач Строка, Разделитель = " ")  
    Пока Истина Цикл
        ТекСтрока = СтрЗаменить(Строка, Разделитель + Разделитель, Разделитель);
        Если ТекСтрока = Строка Тогда
            Возврат Строка;
        КонецЕсли;
        Строка = ТекСтрока;
    КонецЦикла;
КонецФункции
   Вафель
 
93 - 19.01.21 - 20:52
так в типовой же есть такая функция
   dka80
 
94 - 19.01.21 - 21:06
(93) сейчас выяснится, что бсп использовать нельзя
   acht
 
95 - 19.01.21 - 21:06
(93) У настоящего самурая нет цели
   Глупый ответ
 
96 - 19.01.21 - 21:16
(0) "В общем, в итоге сошлись на 500, но вот эти непонятки, они откуда вообще? " я думаю он тебя на .!. послал и телефон твой забанил. Сирожа в 1С нет поминутной тарификации. Там шлюхам тоже поминутно платишь? Сомневаюсь.
   Гений 1С
 
97 - 19.01.21 - 21:22
(93) это не важно.
(96) не, он мне торчит 12к. так просто не может забанить. или не пацан.
   acht
 
98 - 19.01.21 - 21:25
(97) > или не пацан
Чой-та ржу
   DimG
 
99 - 19.01.21 - 22:05
(72) Клевый велосипед. Есть СтрРазделить.
   whitedi
 
100 - 19.01.21 - 22:05
(74) т.е. нужно было целую анкету на эту задачу фрилу сбросить?
1) какая версия платформы 1с
2) тип операционной системы клиента
3) тип клиента 1с (тонкий/веб/мобильный)
4) нужна ли поддержка в будущем при изменении версии платформы?
5) что будет в случае попадания заказчика под трамвай?
6) наличие судимостей? По сбису пробить? Договор у нотариуса?
....
так что ли?)
  1  2   

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.