Вход | Регистрация
 

Подскажите пример передачи файла на сервер через ВЕБ без компоненты

Подскажите пример передачи файла на сервер через  ВЕБ без компоненты
Я
   DES
 
16.01.21 - 21:51
Для 8.3.17 пример
передачи/считывания файла через WEB
чтобы без установки  расширений для браузера
   xXeNoNx
 
1 - 16.01.21 - 22:33
Двоичные данные отлично сериализуются в json/xml
   acht
 
2 - 16.01.21 - 23:31
(0) Ну, например, СП / Глобальный контекст / НачатьПомещениеФайлаНаСервер, вариант синтаксиса: по ссылке на файл или с диалогом выбора файла.
   DES
 
3 - 17.01.21 - 00:39
что такое СП ?
   acht
 
4 - 17.01.21 - 00:50
(3)
самолётное производство
саморазгружающаяся платформа
самостоятельное подразделение
самостоятельное предприятие
санаторий-профилакторий
санитарные потери
санитарные правила
санитарный паспорт
санитарный пост
санитарный пропускник
сантипуаз
Саратовская панорама
сборный пункт
сварочное производство
сверхпластичность
световой прибор
светосигнальный прибор
свободный порт
Своды правил
Северная пивоварня
Северное побережье
северное полушарие
Северный полюс
северный прорыв
сейсмическая партия
сейсмическое просвечивание
секретариат президента
секстант перископический
секторный прицел
секционный переключатель
селенопиран
сельсин-приёмник
сельское поселение
семейное положение
семейное пособие
Сервис плюс
сервисное предприятие
сервис-провайдер
сервопривод
сертификат происхождения
сеть Петри
Сибирский посад
сигнальный процессор
силовой пункт
синегнойная палочка
синтакс-помощник
синхронизирующая последовательность
синхронный перевод
система пожаротушения
система посадки
системное программирование
скиповый подъёмник
скорый поезд
скрытое повреждение
Славянская партия
следящий привод
слёзная плёнка
слойный пласт
служба персонала
служба поддержки
случайный процесс
смачивающийся порошок
смерть погонам
смесь перцев
сметная прибыль
снайперский патрон
собрание постановлений
собственной поляризации
совет прессы
Советская педагогика
Советский писатель
совместная покупка
совместное предприятие
совместное производство
Современный писатель
солнечная панель
Солнечный поток
сортировочный пост
социалистическая партия
социальное партнёрство
социология и политология
Союз писателей
союзная программа
спальное место
спаренный пулемёт
спасательная станция
спектр, спектральный
специализированный полк
специальная подготовка
специальная проверка
специальная психология
специальность
специальный патрон
специальный пионер
специальный препарат
спецификация
спецпоселенец
спонтанный пневмоторакс
справочное пособие
средний план
средство поражения
срочная переводная
срыв потока
Ставропольская правда
стажёрская площадка
стакан пластмассовый
сталеплавильное производство
стандартная программа
станция подслушивания
стартовая платформа
стартовая позиция
стеклопакет
стеклянный предохранитель
стол производственный
стоп-пуск
стоячие покои
стратегическое предприятие
страховое покрытие
стрелковый полк
стрелочный прибор
стрелочный привод
стрессовый перелом
строительная площадка
строительная продукция
Строительная промышленность
струйный принтер
структурное подразделение
Студенческая правда
судостроительная промышленность
супружеская пара
схема подключения
Счётная палата
счётчик простоев
сырой протеин

https://forum.mista.ru/rules.php#dict
   ДедМорроз
 
5 - 17.01.21 - 01:00
Самое простое просто браузер и http сервис.
   DES
 
6 - 17.01.21 - 01:39
(3) мазохисткое детектед.
не постить то что спрашивают и катать то что не просят.
   Сергиус
 
7 - 17.01.21 - 03:06
(0)А подробней описать задачу? Что куда и зачем?
   DES
 
8 - 17.01.21 - 10:50
в СП есть описание . конечно читал, но нет примера как в других пунктах.
   acht
 
9 - 17.01.21 - 11:42
(8) > конечно читал
После вопроса о том, что такое СП?. Тебе еще многое предстоит детектед.
   DES
 
10 - 17.01.21 - 12:02
(9) тебя это бесит?
   DES
 
11 - 17.01.21 - 12:05
(7) задача такая загнать pdf файлы (1-10), вытащить из них текст, загнать его в xls книгу и вернуть обратно.
все работает на обычных формах, а нужно через web.
   acht
 
12 - 17.01.21 - 12:05
(10) Не. Скорее, гм, развлекает.
   acht
 
13 - 17.01.21 - 12:07
(7) Ну вот, в (11) тебе все разъяснили. Давай, пиши сюда код, да пострайся уж, чтобы он правильный был.
   acht
 
14 - 17.01.21 - 12:11
(11) Вот, кстати, что такое "ИТС" знаешь?
   oslokot
 
15 - 17.01.21 - 12:11
ЯННП! что значит "передать файл через веб"?
   DES
 
16 - 17.01.21 - 12:38
(14) Нет, но ты же сейчас простыню накатаешь?
   acht
 
17 - 17.01.21 - 12:39
(16) Не, я тебе другую ссылку дам: https://v8.1c.ru/metod/books/108481.htm
   DES
 
18 - 17.01.21 - 12:39
(15) ну смотри, ветка 1с8 , у которой есть режим web.
   DES
 
19 - 17.01.21 - 12:40
(17) за ради литра молока не стоит покупать корову.
   Юрий Лазаренко
 
20 - 17.01.21 - 12:41
(11) А вернуть обратно, и что потом с ними сделать? Сохранить на диск?
   acht
 
21 - 17.01.21 - 12:42
(19) На халяву и уксус - уксус
   Cyberhawk
 
22 - 17.01.21 - 12:42
   Сергиус
 
23 - 17.01.21 - 12:43
(11)Вытаскивать инфу из pdf еще то удовольствие..
   DES
 
24 - 17.01.21 - 12:45
(23) ноу проблем, все сделал.
(20) ну как , на пример, работает online форматер текста JS.
   oslokot
 
25 - 17.01.21 - 13:01
(18) задам вопрос по другому. Ты подключен тонким клиентом к серверу через web-соединение или работаешь напрямую в браузере?
   ДедМорроз
 
26 - 17.01.21 - 13:06
У меня после отправить pdf,разобрать и сохранить в excel только один вопрос,а зачем тут 1с?
Apache с php решат эту проблему гораздо эффективнее.
   DES
 
27 - 17.01.21 - 13:56
(26) Потому что уже сделано на ОФ
   DES
 
28 - 17.01.21 - 13:57
(18) Нужно в браузере сделать
   DES
 
29 - 17.01.21 - 13:57
(25) см (28)
   МимохожийОднако
 
30 - 17.01.21 - 13:59
Мне тоже интересно, как получить файл на сервер через тонкого клиента через web-соединение.
 
 Рекламное место пустует
   RomanYS
 
31 - 17.01.21 - 14:00
(0) (30) а в чём проблема? Открываешь типовую/БСП - там это есть
   DES
 
32 - 17.01.21 - 14:02
(25)
в браузере сделал выбор файла и передачу, но в тонком клиенте.
А в браузере не получается . ни с установкой расширения. ни как.
Потому что не нахожу ни одного живого примера для 8.3.16 и выше
   DES
 
33 - 17.01.21 - 14:03
нет у меня ни типовой и БСП
   acht
 
34 - 17.01.21 - 14:05
(33) Вот здесь скачать можно: https://releases.1c.ru/project/SSL31
   DES
 
35 - 17.01.21 - 14:06
У Вас нет доступа к данной странице.
   RomanYS
 
36 - 17.01.21 - 14:16
&НаКлиенте
Процедура ИмяФайлаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    
    Оповещение = Новый ОписаниеОповещения("ПрикрепитьФайлЗавершение", ЭтаФорма, Новый Структура(""));
    НачатьПомещениеФайла(Оповещение, , Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие), Истина, УникальныйИдентификатор,);  
    
КонецПроцедуры

&НаКлиенте
Процедура ПрикрепитьФайлЗавершение(Результат, Адрес, ПомещаемыйФайл,ДополнительныеПараметры) Экспорт
    
    Если Результат = Ложь Тогда
        Возврат;    
    КонецЕсли; 
    
    Ф = Новый Файл(ПомещаемыйФайл);
    Объект.ИмяФайла =  Ф.Имя;
    ПрикрепитьСканНаСервере(Адрес, Ф.Расширение);

КонецПроцедуры    

&НаСервере
Процедура ПрикрепитьСканНаСервере(Адрес, Расширение)
...
    
    ДвоичныеДанные = ПолучитьИзВременногоХранилища(Адрес);
    ИмяВременногоФайла = ПолучитьИмяВременногоФайла(Расширение);
...
КонецПроцедуры
   DES
 
37 - 17.01.21 - 14:19
(36) СПС, но это устаревший метод
мне нужен НачатьПомещениеФайлаНаСервер()
   acht
 
38 - 17.01.21 - 14:24
(35) А что у тебя вообще есть?
   DES
 
39 - 17.01.21 - 14:31
(38) лицензионный конфигуратор
   RomanYS
 
40 - 17.01.21 - 14:33
(37) К ДенисЧ обратись, он вроде СП приторговывал
   acht
 
41 - 17.01.21 - 14:36
(39) Ну, ты ж его не на помойке нашел, верно? Обратись туда, где взял - у них 100% есть и БСП и типовые и примеры.
   DES
 
42 - 17.01.21 - 14:40
(41) они на 8.5.15 - у них нету НачатьПомещениеФайлаНаСервер
   DES
 
43 - 17.01.21 - 14:42
(41) ну чтоб тебе было понятно, мне нужен пример , а не адрес.
По адресам я уже везде был
   acht
 
44 - 17.01.21 - 14:44
(42) Ну 8.3.17 ты же откуда-то взял, это же явно не их 8.5.15
   acht
 
45 - 17.01.21 - 14:44
(43) Еще не по всем адресам, уж поверь.
   RomanYS
 
46 - 17.01.21 - 14:46
(37) (42) ты уж определись как-нибудь
   DES
 
47 - 17.01.21 - 15:37
(46) что еще нужно определить?
Есть пример с НачатьПомещениеФайлаНаСервер()
*(Прим. авт. Пример с  НачатьПомещениеФайла() не нужен ,он есть )
   DES
 
48 - 17.01.21 - 15:38
(44) ну ты блин даешь, кто-ж его с сайта скачать может ?
   RomanYS
 
49 - 17.01.21 - 15:40
(47) так в (42) пишешь , что нет НачатьПомещениеФайлаНаСервер. Или ты из-за этой фигни режим совместимости готов поднять?
   Salimbek
 
50 - 17.01.21 - 15:46
   DES
 
51 - 17.01.21 - 16:04
(50) это первое с чем начал заниматься, идет затык с параметром АдресФайла
Где и как заполняется понять не могу
   acht
 
52 - 17.01.21 - 17:49
А, ну то есть не в примере дело. Понятно.
Корову таки купи, пригодится.
   DES
 
53 - 17.01.21 - 21:27
Нет не купил.
Пример набирал от руки, и почему то не срабатывал модуль ПриЗаписиНаСервере()
Пришлось убить и создать его из меню и заполнить по новой, тогда и пошло.
   Salimbek
 
54 - 17.01.21 - 22:28
(53) Дык, дело же не в имени процедуры, а в Событии. Т.е. в свойствах формы в самом низу находишь Событие "При записи на сервере" и там указываешь процедуру, которая будет обрабатывать это событие. Так что проверьте, может еще какое событие не подвязано.
   DES
 
55 - 17.01.21 - 23:37
Было все кописпащено.
Все было.
Только не срабатывало при событии записи, соответственно ничего и не считывалось.
Пока не перебил процедуру события по-новой.
   Salimbek
 
56 - 18.01.21 - 01:08
(55) Да я то понял, это ты не понял.
Вот скопипастил ты процедуру "ПриЗаписиНаСервере()" и что дальше? А ничего, просто есть у тебя код в модуле, который никогда не выполнится.
Потому что к Событию эта процедура никак не привязана. Вот зайдешь в События, выберешь для События "При записи на сервере" эту процедуру, вот тогда она и начнет работать.

А то, что ты ее создал "из меню" - так как раз там это и происходит, Создается шаблон Процедуры в модуле и Событию назначается эта Процедура.
Вот тут вот: https://i.imgur.com/tRip1YM.png
   Salimbek
 
57 - 18.01.21 - 01:10
+(56) Я просто недавно с ВнешнееСобытие так попал, так что свежи еще шишки от граблей :-)))
   DES
 
58 - 18.01.21 - 07:42
а разве эти предопределенные процедуры срабатывают не по имени?
   ДенисЧ
 
59 - 18.01.21 - 07:43
(58) Нет. Это только в клюшках такое непотребство было.
   acht
 
60 - 18.01.21 - 08:24
(58) Нет. Причем в толстом клиенте, в котором у тебя "все работало" - ровно то же самое.
 
 Рекламное место пустует
   DES
 
61 - 18.01.21 - 10:25
(56) ок. спс. буду знать.
   sikuda
 
62 - 18.01.21 - 11:19
(61) Как там у Земфиры поется... ;)
А программист с Мисточки
Ты конфигуратор запусти
Да ты не такой как все, и не любишь читать доки.
Я не буду тебя спасать,
Код писать, отлаживать, тестировать.
Меньше всего нужны мне твои callback'и...
   DES
 
63 - 18.01.21 - 19:15
(62) Да, не у всех песняров консерваторское образование.

Кто подскажет, при ВЕБ доступе процедура долго выполняется и браузер спрашивает что хочет зависнуть. Как победить?
   acht
 
64 - 18.01.21 - 19:40
   Ёпрст
 
65 - 18.01.21 - 20:50
(59) в снеговике тоже оставили.. в модуле документа кучка предопределенных процедур
:)
А в форме да, сделали по-человечьи
   DES
 
66 - 19.01.21 - 13:10
Может кто скинуть  ОбщегоНазначения.ВыполнитьМетодКонфигурации()?
Что-то в конфе нет такой.
   ДенисЧ
 
67 - 19.01.21 - 13:13
(66)// Выполнить экспортную процедуру по имени с уровнем привилегий конфигурации.

// При включении профилей безопасности для вызова оператора Выполнить() используется
// переход в безопасный режим с профилем безопасности, используемым для информационной базы

// (если выше по стеку не был установлен другой безопасный режим).
//

// Параметры:
//  ИмяМетода  - Строка - имя экспортной процедуры в формате

//                       <имя объекта>.<имя процедуры>, где <имя объекта> - это
//                       общий модуль или модуль менеджера объекта.

//  Параметры  - Массив - параметры передаются в процедуру <ИмяЭкспортнойПроцедуры>
//                        в порядке расположения элементов массива.

// 
// Пример:

//  Параметры = Новый Массив();
//  Параметры.Добавить("1");

//  ОбщегоНазначения.ВыполнитьМетодКонфигурации("МойОбщийМодуль.МояПроцедура", Параметры);
//

Процедура ВыполнитьМетодКонфигурации(Знач ИмяМетода, Знач Параметры = Неопределено) Экспорт
    
    ПроверитьИмяПроцедурыКонфигурации(ИмяМетода);
    
    Если ПодсистемаСуществует("СтандартныеПодсистемы.ПрофилиБезопасности") Тогда
        МодульРаботаВБезопасномРежиме = ОбщийМодуль("РаботаВБезопасномРежиме");
        Если МодульРаботаВБезопасномРежиме.ИспользуютсяПрофилиБезопасности()
            И Не МодульРаботаВБезопасномРежиме.УстановленБезопасныйРежим() Тогда
            
            ПрофильИнформационнойБазы = МодульРаботаВБезопасномРежиме.ПрофильБезопасностиИнформационнойБазы();
            Если ЗначениеЗаполнено(ПрофильИнформационнойБазы) Тогда
                
                УстановитьБезопасныйРежим(ПрофильИнформационнойБазы);
                Если БезопасныйРежим() = Истина Тогда
                    УстановитьБезопасныйРежим(Ложь);
                КонецЕсли;
                
            КонецЕсли;
            
        КонецЕсли;
    КонецЕсли;
    
    ПараметрыСтрока = "";
    Если Параметры <> Неопределено И Параметры.Количество() > 0 Тогда
        Для Индекс = 0 По Параметры.ВГраница() Цикл 
            ПараметрыСтрока = ПараметрыСтрока + "Параметры[" + Индекс + "],";
        КонецЦикла;
        ПараметрыСтрока = Сред(ПараметрыСтрока, 1, СтрДлина(ПараметрыСтрока) - 1);
    КонецЕсли;
    
    Выполнить ИмяМетода + "(" + ПараметрыСтрока + ")";
    
КонецПроцедуры
   DES
 
68 - 19.01.21 - 13:16
СПС
   sikuda
 
69 - 19.01.21 - 17:31
(63)В некоторых браузерах нельзя прокручивать страницу, пока идёт синхронный запрос. Ну а если же синхронный запрос по какой-то причине выполняется слишком долго, браузер предложит закрыть «зависшую» страницу https://learn.javascript.ru/xmlhttprequest
В 1С один путь - переделывать через фоновые задания...
   DES
 
70 - 19.01.21 - 17:34
(69) это понятно, а в чем выход фонового задания?
что браузер не ждёт , а он узнает что все готово?
ДА, еще вопрос, например как обновить форму?
   sikuda
 
71 - 19.01.21 - 17:55
(70) При нормальном асинхроне он действительно не ждет, а прилетают данные и обновляется
В 1С на сервере в оповешении на форме
ФЗ = ФоновыеЗадания.НайтиПоУникальномуИдентификатору(АдресФоновогоЗадания);
ФЗ.ПолучитьСообщенияПользователю(Истина)...



Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.