Вход | Регистрация
 

Почему в УТ11 куценький выбор статусов заказов? Как включить все?

Почему в УТ11 куценький выбор статусов заказов? Как включить все?
Я
   Гений 1С
 
13.01.21 - 18:36
У заказа 4 статуса:

НеСогласован
КОбеспечению
КОтгрузке
Закрыт

Судя по коду, КОтгрузке будет ставиться, только если включен режим "ИспользоватьПострочнуюОтгрузкуВЗаказеКлиента".

Делаю выгрузку в Битрикс, хотелось бы использовать статус КОтгрузке (для сайта).

Расширением добавил, чем грозит?

Код расширения:


&После("ЗаполнитьСписокВыбора")
Процедура дор_ЗаполнитьСписокВыбора(ДанныеВыбора, УстановленныйСтатус) Экспорт
    //Осипов 2021-01-13 +++
    //
    Иск = Перечисления.СтатусыЗаказовКлиентов.КОтгрузке;
    Если ДанныеВыбора.НайтиПоЗначению(Иск) = Неопределено Тогда
        ДанныеВыбора.Добавить(Иск, Иск);
    КонецЕсли;

КонецПроцедуры




Исходный код:
Процедура ЗаполнитьСписокВыбора(ДанныеВыбора, УстановленныйСтатус) Экспорт
    Если НЕ ПолучитьФункциональнуюОпцию("ИспользоватьРасширенныеВозможностиЗаказаКлиента") Тогда
        Возврат
    КонецЕсли;
    
    ДанныеВыбора.Очистить();
    
    ДанныеВыбора.Добавить(Перечисления.СтатусыЗаказовКлиентов.НеСогласован);
    
    Если НЕ ПолучитьФункциональнуюОпцию("ИспользоватьПострочнуюОтгрузкуВЗаказеКлиента") Тогда
        ДанныеВыбора.Добавить(Перечисления.СтатусыЗаказовКлиентов.КОбеспечению, НСтр("ru='В резерве'"));
        ДанныеВыбора.Добавить(Перечисления.СтатусыЗаказовКлиентов.КОтгрузке);
    Иначе
        ДанныеВыбора.Добавить(Перечисления.СтатусыЗаказовКлиентов.КОбеспечению, НСтр("ru='К выполнению'"));
    КонецЕсли;
    
    Если ПолучитьФункциональнуюОпцию("НеЗакрыватьЗаказыКлиентовБезПолнойОплаты")
        ИЛИ ПолучитьФункциональнуюОпцию("НеЗакрыватьЗаказыКлиентовБезПолнойОтгрузки") Тогда
        ДанныеВыбора.Добавить(Перечисления.СтатусыЗаказовКлиентов.Закрыт);
    КонецЕсли;
    
    Если ДанныеВыбора.НайтиПоЗначению(УстановленныйСтатус) = Неопределено Тогда
        
        ДанныеВыбора.Добавить(УстановленныйСтатус, УстановленныйСтатус);
        
    КонецЕсли;
    
КонецПроцедуры
 
 Партнерская программа EFSOL Oblako
   Гений 1С
 
1 - 13.01.21 - 19:26
Вообще вопрос в другом - можно ли свои статусы туда напихать?
   Злопчинский
 
2 - 14.01.21 - 03:16
ну так по коду - обработка идет по "идентифицированным" значениям. если свои понапихаешь - то как ониобрабатыватьяс будут? посмотреть имхо лучше в сторону "состояний" заказов, отдельно от "статусов".
   Сергиус
 
3 - 14.01.21 - 03:43
(1)пихай и проверяй на тестовой.
   МимохожийОднако
 
4 - 14.01.21 - 07:15
(2) Поддерживаю.Лучше отдельные статусы для Битрикса.
   Гений 1С
 
5 - 14.01.21 - 07:25
(4) статусы в документе или регистре хранятся?
По идее посмотрел, там в Битрикс можно гнать даже значение доп. реквизита заказа, а его устанавливать программно в расширении, так что довольно гибко
   Гений 1С
 
6 - 14.01.21 - 07:32
(2) состояния же тоже идентифицированы. Лучше свой доп.реквизит с перечнем состояний имхо.
   Гений 1С
 
7 - 14.01.21 - 07:35
а на что влияет статус заказа в УТ11? Но хотя, т.к. не знаю, лучше свои статусы не добавлять.
   FIXXXL
 
8 - 14.01.21 - 08:21
(7) на движения

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.