Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Нет свободных кодов в доступных диапазонах штучных штрихкодов. Штрихкод не сформирован.

Нет свободных кодов в доступных диапазонах штучных штрихкодов. Штрихкод не сформирован.
Я
   remont16
 
13.01.21 - 17:15
При нажатии на кнопку новый штрихкод появляется вот такая ошибка:

"Нет свободных кодов в доступных диапазонах штучных штрихкодов.
Штрихкод не сформирован."

До этого ни одного штрихкода не формировали и не добавляли, в чем причина?
   vicof
 
1 - 13.01.21 - 17:32
Отладку надо запускать и смотреть
   remont16
 
2 - 13.01.21 - 17:40
(1) отладка показала вот что
Для Каждого СтрокаТЧ Из Диапазоны Цикл
    Код = СтрокаТЧ.Код + 1;
    Диапазон = СтрокаТЧ.Диапазон;
    Прервать;
КонецЦикла;
    
Если Код = Неопределено Тогда
    ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщенияНетСвободныхКодовШтучныхШтрихкодов());
    Возврат Неопределено;
КонецЕсли;

массив диапазонов пустой и поэтому код = Неопределено, но как это поправить все равно не знаю
   vicof
 
3 - 13.01.21 - 18:10
Не нажимать кнопку
Убрать проверку
Спросить разработчиков
Вариантов много
   Злопчинский
 
4 - 14.01.21 - 03:12
Проверить какие коды у позиций, на которые проводитяс формирование ШК
   remont16
 
5 - 14.01.21 - 14:43
(3) и все которые вы предложили абсолютно не подходят
   remont16
 
6 - 14.01.21 - 14:44
Решил проблему, нужно было сначала добавить в ручную первый код 2000000000000, и после этого все стало нормально работать.
   Gbpltw
 
7 - 14.01.21 - 16:51
(6) не решил. нужно искать неправильно заведенный ШК
   Voronve
 
8 - 14.01.21 - 16:55
(7) Решил.
Баг тут
Для Каждого СтрокаТЧ Из Диапазоны Цикл
    Код = СтрокаТЧ.Код + 1;
    Диапазон = СтрокаТЧ.Диапазон;
    Прервать;
КонецЦикла;

Если нет ни одного шк то переменная Код не заполняется.

И вот тут падает в ошибку
Если Код = Неопределено Тогда
    ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщенияНетСвободныхКодовШтучныхШтрихкодов());
    Возврат Неопределено;
КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.