Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как найти строку и заменить значение в дереве значений?

Как найти строку и заменить значение в дереве значений?
Я
   Daemons
 
13.01.21 - 14:30
Доброго времени суток господа!
Помогите с одним практическим вопросом, совсем запутался с этими деревьями.
Вопрос такой. Есть построенное дерево значений, нужно найти нужную строчку по ключу и в ней изменить значение.
Код прилагаю, в комментарии обозначил место затыка

&НаСервере
Процедура НайтиСтрокуДЗ_НаСервере(СтрПоиска,КолВо)

    ДеревоЗначений = РеквизитФормыВЗначение("ТоварыДерево");

    // Поиск строки по колонке Код
    НайденнаяСтрока = ДеревоЗначений.Строки.Найти(СтрПоиска,"Код", Истина);

    Если НайденнаяСтрока <> Неопределено Тогда
        Если НайденнаяСтрока.Родитель = Неопределено Тогда    
            ИндексТекСтроки = ДеревоЗначений.Строки.Индекс(НайденнаяСтрока);
            ЭтаФорма.РаботыДерево.ТекущаяСтрока=НайденнаяСтрока;
        Иначе        
            ИндексТекСтроки = НайденнаяСтрока.Родитель.Строки.Индекс(НайденнаяСтрока)
        КонецЕсли;
        Сообщить(Строка(ИндексТекСтроки)+""+НайденнаяСтрока.Номенклатура);
        // Выводит индексы относительно родителей, не знаю как их использовать
        //????
        //И вот как теперь в этой НайденнаяСтрока изменить значение 2 полей ????
        ///
    КонецЕсли;      
КонецПроцедуры

Буду очень благодарен за любую помощь или подсказку!
   DrShad
 
1 - 13.01.21 - 14:31
НайтиСтроки()
   Daemons
 
2 - 13.01.21 - 14:39
(1) это чтобы найти строку, или чтобы уже изменить значение?
   DrShad
 
3 - 13.01.21 - 15:15
а СП что говорит? конечно чтобы найти, потом в цикле по массиву найденных строк делай с ними что хочешь
   Малыш Джон
 
4 - 13.01.21 - 15:22
(0) >>Как найти строку и заменить значение в дереве значений?

Так же как в таблице значений, только искать в коллекции строк, а не в таблице
   Малыш Джон
 
5 - 13.01.21 - 15:24

Список тем форума
Рекламное место пустует  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.