Вход | Регистрация
 

ЧЕСТНЫЙ ЗНАК. Получение по API информации о контрагенте.

ЧЕСТНЫЙ ЗНАК. Получение по API информации о контрагенте.
Я
   torgm
 
13.01.21 - 12:03
Делал ли кто из форумчан,  обращение к честному знаку по API c целью получить информацию является ли контрагент участником честного знака?
   timurhv
 
1 - 13.01.21 - 12:20
(0) Там ошибки? Мы не делали, но другие методы реализованы.
   trad
 
2 - 13.01.21 - 12:23
я делал
   AlexandrV
 
3 - 13.01.21 - 13:26
Подскажите как после отгрузки товара с этикетками (прием знаков прошел) выполнить заполнение отгрузки Им МП и отправить в чз ???
Подскажите кто знает
   AlexandrV
 
4 - 13.01.21 - 13:45
Подскажите кто знает как передать инфу в честный знак
   trad
 
5 - 14.01.21 - 11:48
(0) пример кода на 77
// Метод проверки регистрации УОТ по ИНН в системе ГИС МТ

//*******************************************
Процедура ПроверкаРегистрацииУОТпоИНН(Токен, ИНН)
    
    // Запрос авторизации при единой аутентификации

    Адрес = мБазовыйАдресТочкиПодключения + "/participants/" + СокрЛП(ИНН);
    
    Запрос = СоздатьОбъект("Msxml2.ServerXMLHTTP");
    Запрос.open("GET", Адрес);
    Запрос.setRequestHeader("cache-control", "no-cache");
    Запрос.setRequestHeader("authorization", "Bearer " + Токен);
    Запрос.send();
    
    JSON = СоздатьОбъект("JSON");
    Если Запрос.status = 200 Тогда
        Данные = JSON.ЧтениеJSON(Запрос.responseText);
        Сообщить(JSON.ЗаписьJSON(Данные, 1));
    Иначе
        ТекстОшибки = "Ошибка: " + Запрос.status + " : " + Запрос.statusText;
        Сообщить(ТекстОшибки, "err");
    КонецЕсли;

КонецПроцедуры


мБазовыйАдресТочкиПодключения = = "https://markirovka.crpt.ru/api/v3/true-api";;
   trad
 
6 - 14.01.21 - 11:49
ПроверкаРегистрацииУОТпоИНН(Токен, "123456789012");
ПроверкаРегистрацииУОТпоИНН(Токен, "?inns=123456789012&inns=123456789013");
   trad
 
7 - 14.01.21 - 11:51
//*******************************************

Функция ПолучитьТокен()
    
    Криптография = СоздатьОбъект("Криптография");
    Сертификат = Криптография.НайтиСертификатПоОтпечатку("xxxxxxxxxxxxxxxxxxxxxxxxxxx");
    Если ПустоеЗначение(Сертификат) = 1 Тогда
        Сообщить("Сертификат не найден");
        Возврат "";
    КонецЕсли;
    
    
    // Авторизация

    
    // Запрос авторизации при единой аутентификации

    Адрес = мБазовыйАдресТочкиПодключения + "/auth/key";
    
    Запрос = СоздатьОбъект("Msxml2.ServerXMLHTTP");
    Запрос.open("GET", Адрес);
    Запрос.setRequestHeader("cache-control", "no-cache");
    Запрос.setRequestHeader("Accept", "application/json");
    Запрос.send();
    
    JSON = СоздатьОбъект("JSON");
    Если Запрос.status = 200 Тогда
        Данные = JSON.ЧтениеJSON(Запрос.responseText);
    Иначе
        ТекстОшибки = "Ошибка: " + Запрос.status + " : " + Запрос.statusText;
        Сообщить(ТекстОшибки, "err");
        Возврат "";
    КонецЕсли;
    
    ПодписанныеДанные = Криптография.Подписать(Данные.data, Сертификат, 0);
    Данные.data = ПодписанныеДанные;

    СтрJSON = JSON.ЗаписьJSON(Данные);
    
    
    // Получение ключа сессии при единой аутентификации

    Адрес = мБазовыйАдресТочкиПодключения + "/auth/simpleSignIn";
    
    Запрос = СоздатьОбъект("Msxml2.ServerXMLHTTP");
    Запрос.open("POST", Адрес);
    Запрос.setRequestHeader("cache-control", "no-cache");
    Запрос.setRequestHeader("Content-Type", "application/json");
    Запрос.setRequestHeader("Accept", "application/json");
    Запрос.send(СтрJSON);
    
    Если Запрос.status = 200 Тогда
        Данные = JSON.ЧтениеJSON(Запрос.responseText);
        Возврат Данные.token;
    Иначе
        ТекстОшибки = "Ошибка: " + Запрос.status + " : " + Запрос.statusText;
        Сообщить(ТекстОшибки);
        Данные = JSON.ЧтениеJSON(Запрос.responseText);
        Сообщить(Данные .error_message);
        Возврат "";
    КонецЕсли;
    
КонецФункции
   trad
 
8 - 14.01.21 - 11:52
Токен = ПолучитьТокен();
   timurhv
 
9 - 14.01.21 - 11:59
>Подскажите как после отгрузки товара с этикетками (прием знаков прошел) выполнить заполнение отгрузки Им МП и отправить в чз ???
У вас какие-то собственные аббревиатуры. 99% людей не понимают, поэтому не смогут помочь.

>прием знаков прошел
Каких знаков, где прошел?

>Им МП
Что такое МП? Маркируемая продукция?
   torgm
 
10 - 14.01.21 - 12:00
(5)  спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.