Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не получается записать внешнюю обработку из хранилища

Не получается записать внешнюю обработку из хранилища
Я
   slafor
 
12.01.21 - 16:54
Полностью самописная конфигурация.
В меню есть пункт Сервис - Дополнительные возможности, где открывается список дополнительных отчетов и обработок.
Когда открываю обработку из дополнительных возможностей, все работает нормально. Хочу выгрузить ее во внешний файл - получаю пустую обработку без реквизитов, без формы и вообще без кода. Что я могу делать не так?

При сохранении обработки во внешний файл выполняется следующий код:

&НаКлиенте
Процедура СохранитьФайлИзХранилища(хранилище) Экспорт
    
    ДиалогФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
    
    ДиалогФайла.Фильтр = "Внешняя обработка(*.epf)|*.epf|Внешний отчет(*.erf)|*.erf";    
    ДиалогФайла.ПроверятьСуществованиеФайла = Истина;
    
    ДвоичныеДанные = хранилище.Получить();
    
    Если ДвоичныеДанные = Неопределено Тогда
        Предупреждение("Внешний файл отсутствует в хранилище");
        Возврат;
    КонецЕсли;
    
    Если ДиалогФайла.Выбрать() Тогда
        ИмяФайла = ДиалогФайла.ПолноеИмяФайла;
        Попытка
            ДвоичныеДанные.Записать(ИмяФайла);
        Исключение
            Предупреждение("Внешний файл не сохранен
            |"+ОписаниеОшибки());
        КонецПопытки;
    КонецЕсли;
    
КонецПроцедуры
   ДенисЧ
 
1 - 12.01.21 - 16:57
А где сохранение, собственно? Кроме названия процедуры?
   youalex
 
2 - 12.01.21 - 17:06
(0) >>пустую обработку без реквизитов
Расширение проверь. У обработок epf, у отчетов - erf (вроде)
   slafor
 
3 - 12.01.21 - 17:06
Да вот же:
ДвоичныеДанные.Записать(ИмяФайла); )
   slafor
 
4 - 12.01.21 - 17:08
(2) Спасибо, точно.
Там почему-то автоматически предлагали записать в epf, а это erf, оказывается.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.