Вход | Регистрация
 

Получить форму дока "ОперацияБух"

Получить форму дока "ОперацияБух"
Я
   lirt82
 
12.01.21 - 09:20
Необходимо сделать внешнюю печатную форму к документу "ОперацияБух" конфа Бух 3.0, столкнулся с проблемой получения данных из таб части дока Операция. Таб часть документа это реквизит формы, получаю форму дока программно в обработке но ФормаОперации = Неопределено, полез в синтаксис.
Возвращаемое значение:
Тип: Форма, Неопределено.
Неопределено - если в обработчике ПриСозданииНаСервере установлен признак отказа от создания формы.
вот код из модуля формы документа ОперацияБух
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
        
    ВерсионированиеОбъектов.ПриСозданииНаСервере(ЭтаФорма);
        
    Если Параметры.Ключ.Пустая() Тогда        
        ПодготовитьФормуНаСервере(?(ЗначениеЗаполнено(Параметры.Основание), Параметры.Основание,Параметры.ЗначениеКопирования));        
    КонецЕсли;

    //При открытии из журнала проводок активизируем выбранную строку
    Если ЗначениеЗаполнено(Параметры.ПараметрТекущаяСтрока) Тогда
        Элементы.Типовой.ТекущаяСтрока = Параметры.ПараметрТекущаяСтрока-1;
    КонецЕсли;
    
    ЗапретРедактированияРеквизитовОбъектовПереопределяемый.ЗаблокироватьРеквизиты(ЭтотОбъект, НЕ Параметры.Ключ.Пустая());
        
КонецПроцедуры

/////////////
вот код моей внеш печ формы
ТабличныйДокумент.Вывести(ЗаголовокТаблицы2);
    ТабличныйДокумент.Вывести(ЗаголовокТаблицыДляПереноса);
    
    //заполняем строки ТЧ
    ОбластьСтроки = МакетОбработки.ПолучитьОбласть("СтрокаТаблицы2");
        
    _Ключ = Новый Структура("Ключ", СсылкаНаДокумент);
    ФормаОперации = ПолучитьФорму("Документ.ОперацияБух.Форма.ФормаДокумента", _Ключ);
    //ФормаОперации.Открыть();
            
    //Для Каждого ТекущаяСтрока Из СсылкаНаДокумент.ХХХХХ Цикл
    //    ЗаполнитьЗначенияСвойств(ОбластьСтроки.Параметры, ТекущаяСтрока);
    //    ТабличныйДокумент.Вывести(ОбластьСтроки);
    //КонецЦикла;
///////////
как обратиться к таб части дока ОперацияБух?, чтоб выгрузить в ТЗ ее таб часть и далее в цикле ее обрабатывать заполняя свой макет.
   ДенисЧ
 
1 - 12.01.21 - 09:21
У операции нет ТЧ. Она заполняется из проводок
   lirt82
 
2 - 12.01.21 - 09:24
(1) да, и все же как?:)
   ДенисЧ
 
3 - 12.01.21 - 09:26
Медленно.
"как обратиться к таб части дока ОперацияБух?, чтоб выгрузить в ТЗ ее таб часть"
Ответ простой - никак. Ибо табчасти у операции нет
   lirt82
 
4 - 12.01.21 - 09:26
(1) для пользователя на форме отображается. Вот это "отображение" мне и нужно "поймать".
   ДенисЧ
 
5 - 12.01.21 - 09:28
   lirt82
 
6 - 12.01.21 - 09:30
   Масянька
 
7 - 12.01.21 - 09:31
(4) В гугле забанили?
С таким-то размером...
   hhhh
 
8 - 12.01.21 - 09:40
(3) есть же у нее табчасть.
   lirt82
 
9 - 12.01.21 - 09:40
(3) (1)  т.е. обходить запросом журнал операции с фильтром по ссылке на Операцию, получить таким образом данные по проводкам?
   ДенисЧ
 
10 - 12.01.21 - 09:42
   lirt82
 
11 - 12.01.21 - 09:43
(8) да есть но это реквизит формы а не объекта
https://ibb.co/8sHj9Tb
   Масянька
 
12 - 12.01.21 - 09:44
(8) ОперацияБух - это не документ (в типовом понимании).
   ДенисЧ
 
13 - 12.01.21 - 09:44
(8) Нет.
   ДенисЧ
 
14 - 12.01.21 - 09:45
   lirt82
 
15 - 12.01.21 - 09:46

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.