Вход | Регистрация
 

Передача ТЗ на клиент

Передача ТЗ на клиент
Я
   Pepeega
 
10.01.21 - 11:16
Здравствуйте коллеги, бегал по форуму, не нашел нужной темы, есть кнопка, по нажатию которой отрабатывает код(на сервере), появилась надобность при выполнении опр. условия, дать возможность пользователю выбрать нужные ему действия из ТЗ, но столкнулся с проблемой, что заполняю ТЗ, а не пойму как мне её передать на клиент, чтобы открыть ТЗ через ВыбратьСтроку и заполнить нужные реквизиты, а после дать отработать остальному коду на сервере?
   H A D G E H O G s
 
1 - 10.01.21 - 11:50
Тз не передается на клиент.
Создай свою форму, размести на ней реквизит, сделай его типом [таблицазначений] и показывай его пользователю.
   Pepeega
 
2 - 10.01.21 - 11:55
(1) Проблема в том, что форма уже и так набита, не хочется на форму тыкать еще какие-то новые реквизиты
   H A D G E H O G s
 
3 - 10.01.21 - 11:57
(2) выбрось что нибудь ненужное.
   Ненавижу 1С
 
4 - 10.01.21 - 11:57
(2) речь про форму выбора строки?
Потому что метода ВыбратьСтроку больше нет в тонком клиенте
   Pepeega
 
5 - 10.01.21 - 12:00
(4) Да, я знаю, поэтому и нужно передать заполненную ТЗ на клиент(с сервера), показать клиенту ТЗ, он выбирает нужный вариант, и после отрабатывает код дальше на сервере
   Pepeega
 
6 - 10.01.21 - 12:00
(3) если бы было так легко всё, то я бы уже давно просто на форму закинул новый реквизит
   Гений 1С
 
7 - 10.01.21 - 12:01
(0) РеквизитФОрмыВЗНачение, выгрузка ТЗ в структуры, значениеВСтрокуВнутр, вот это все варианты.
   Гений 1С
 
8 - 10.01.21 - 12:01
(5) выбор строки из ТЗ не работает в уф, потому что там нет ТЗ на клиенте, например.
   Pepeega
 
9 - 10.01.21 - 12:05
(8) ох, совсем из головы вылетело, что ТЗ то у нас нет на клиенте .-.
Спасибо, попробую что-нибудь другое придумать
   Pepeega
 
10 - 10.01.21 - 12:08
Такой вопрос интересный, а каким еще путём я могу показать пользователю предложенные товары? не используя доп реквизитов(если возможно)
   Ненавижу 1С
 
11 - 10.01.21 - 12:13
(10) передавая через хранилище
   Pepeega
 
12 - 10.01.21 - 12:15
(11) Как я понял, показать в виде ТЗ я не смогу, а куда мне передать через хранилище?
   Ненавижу 1С
 
13 - 10.01.21 - 12:27
(12) из типовой пример
//Помещаем:

&НаСервере
Процедура ПередПодборомТоваровИзЗаказаСервер(МассивКодовСтрок, АдресТоваров)
    
    Для Каждого СтрокаТЧ Из Объект.Товары Цикл
        
        Если СтрокаТЧ.КодСтроки <> 0 И ЗначениеЗаполнено(СтрокаТЧ.ЗаказПоставщику) Тогда
            МассивКодовСтрок.Добавить(Новый Структура("КодСтроки,ЗаказПоставщику", СтрокаТЧ.КодСтроки, СтрокаТЧ.ЗаказПоставщику));
        КонецЕсли;
        
    КонецЦикла;
    
    АдресТоваров = ПоместитьВоВременноеХранилище(Объект.Товары.Выгрузить());
    
КонецПроцедуры

//Далее в форме выбора:


ТоварыНакладной = ПолучитьИзВременногоХранилища(АдресТоварыНакладнойВоВременномХранилище);
   Pepeega
 
14 - 10.01.21 - 12:35
(13) Спасибо за вариант, но проблема в том, что у меня изначально Поле Товары, куда должен добавлять товар, оно не активно, чтобы у пользователя не было возможности что-то поменять, и хочется сделать так, что если товара по отбору будет несколько, пользователю просто предоставляется возможность выбора из появившегося окна
   Pepeega
 
15 - 10.01.21 - 12:38
(13) Хотя нет, ваш пример был полезен, спасибо за помощь))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.