Вход | Регистрация
 

Выбранная строка в таблице значений УФ

Выбранная строка в таблице значений УФ
Я
   Peshalkin
 
09.01.21 - 21:48
Здравствуйте, помогите пожалуйста, уже час голову ломаю, есть таблица значений, если кликнуть по строке таблицы значений, то вся строка должна будет добавиться в другую ТЗ и удалиться из той ТЗ в которой была запись, но я решила попробовать пойти через событие Выбор, но оказалось, что выбраннаяСтрока (параметр изначальный) возвращает число, а не все данные строки, подскажите, как мне можно все данные получить при нажатии? код ниже


&НаСервере
Процедура ТоварВБракеВыборНаСервере(ВыбраннаяСтрока)
    
    Если Элементы.ТоварВБраке.ТекущаяСтрока <> Неопределено тогда
        Добавление = ТоварПодСписание.Добавить();
        ЗаполнитьЗначенияСвойств(Добавление, Элементы.ТоварВБраке.ТекущаяСтрока);
        ТоварВБраке.Удалить(Элементы.ТоварВБраке.ТекущаяСтрока);
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура ТоварВБракеВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    ТоварВБракеВыборНаСервере(ВыбраннаяСтрока);
КонецПроцедуры
   Ёпрст
 
1 - 09.01.21 - 21:50
(0) найтипоидентификатору в помощь
   Peshalkin
 
2 - 09.01.21 - 21:53
(1) а можно как-то не используя УИД?
   Ёпрст
 
3 - 09.01.21 - 21:54
(2) это не уид, почитай описание метода
   Ненавижу 1С
 
4 - 09.01.21 - 21:57
(2)
Стр = ТоварыВБраке.НайтиПоИдентификатору(ВыбраннаяСтрока);
   Peshalkin
 
5 - 09.01.21 - 22:00
(4) Спасибо за пример, но уже решила задачку)
(3) Спасибо за помощь, не знала о таком методе!
   ДедМорроз
 
6 - 09.01.21 - 23:28
Читаем СП,что содержит ТекущаяСтрока для таблицы формы,связанной с таблицей значений.
Вопрос одного поиска в СП.

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.