Вход | Регистрация
 

Вопрос про PostgreSQL (1С)

Вопрос про PostgreSQL (1С)
Я
   Ritter
 
30.12.20 - 18:47
Добрый день!

Возник вопрос насчет СУБД PostgreSQL.

Можно ли работать в старой версии PostgreSQL (10.11_5.1C от 18.02.2020) на более новых версиях 1С Платформы (8.3.17.1851 от 11.19.2020) и 1С Бухгалтерии (3.0.87.22 от 24.12.2020)?

И вообще в дальнейшем при обновлении 1С Платформ и 1С Бухгалтерии обязательно обновлять PostgreSQL? Или же можно спокойно работать на старой версии, если только в самом обновлении платформы/бухгалтерии не будет написано, что нужна более новая версия PostgreSQL?
 
 Партнерская программа EFSOL Oblako
   ansh15
 
1 - 30.12.20 - 21:46
Обычно пишут, что "Текущая версия PostgreSQL предназначена для использования с версией технологической платформы 1С:Предприятие 8 не ниже 8.3.14.1565", например. Это для PostgreSQL редакций 10 и 11. Для 12.5 - не ниже 8.3.18.
Ошибки, которые возникают при работе конкретных конфигураций с определенными версиями этой СУБД, исправляются по мере поступления обращений граждан в техподдержку. Иногда и в патче для PostgreSQL что-нибудь поправят, были такие случаи.
   ansh15
 
2 - 30.12.20 - 21:56
10.15-2.1C или 11.10-2.1C будут вполне приемлемы для вашего случая. Не стоит "сидеть" на старых версиях слишком долго, в случае PostgreSQL регулярные обновления не помешают.
   Фрэнки
 
3 - 30.12.20 - 22:30
но вопрос в другую сторону - от платформы 1С к версии постгри, а не наоборот, что слишком новая версия постгри не будет корректно работать со старой версией платформы.
   Фрэнки
 
4 - 30.12.20 - 22:51
обычно, если сама установленная версия не вызывает претензий, то он она держится долго - много релизов платформы можно не менять. Т.е. даже не припомню, чтоб после перехода на новый релиз платформы начинались какие-то жесткие глюки из-за того что субд не поменяли.

Но когда новая версия выходит, то там так всего хорошего обещают, что рано или поздно, но на них зачастую переходили. Потому может просто на практике и не заметно есть глюки новых платформ на старых субд или нет.
   Ritter
 
5 - 31.12.20 - 00:46
(1) Не подскажите где можно почитать про "Текущая версия PostgreSQL предназначена для использования с версией технологической платформы 1С:Предприятие 8 не ниже 8.3.14.1565"?
Это написано при установки самого PostrgeSQL или где-то в другом месте?
   ansh15
 
6 - 31.12.20 - 01:02

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.