Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Открыть форму с передачей параметров

Открыть форму с передачей параметров
Я
   NewerNow
 
29.12.20 - 06:27
Всем Доброго времени суток.
Суть вопроса:
Есть форма в справочнике, на ней кнопка, которая открывает форму документа по нажатию команды.
В команде написан следующий код:

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    ПараметрыФормы = Новый Структура ("МассивКниг", ПараметрКоманды);
    ОткрытьФорму("Документ.ПоступлениеКниг.ФормаОбъекта", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, ПараметрыВыполненияКоманды.Уникальность, ПараметрыВыполненияКоманды.Окно);
КонецПроцедуры


В документе ПоступлениеКниг, на форме, которую открываю, создал параметр с названием "МассивКниг".
В модуле открываемой формы такой код:


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если ЗначениеЗаполнено(ЭтаФорма.Параметры.МассивКниг)
        И Объект.Книги.Количество() = 0 Тогда
        Для Каждого Книга из ЭтаФорма.Параметры.МассивКниг Цикл
            НоваяСтрока = Объект.Книги.Добавить();
            НоваяСтрока.Книга = Книга;
        КонецЦикла;
    КонецЕсли;
КонецПроцедуры


В общем данные не передаются в открываемую форму. При отладке посмотрел, ПараметрКоманды, который в коде команды, просто не заполняется, он пустой. В чем может быть проблема?
   Галахад
 
1 - 29.12.20 - 09:31
При чем тут открытие формы, если еще до открытия параметр пустой?
   Жан Пердежон
 
2 - 29.12.20 - 13:31
ну и где его заполнение?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.