Вход | Регистрация
 

Как связать кастомный справочник Пользователи с пользователями информационной базы?

Как связать кастомный справочник Пользователи с пользователями информационной базы?
Я
   tabarigen
 
26.12.20 - 16:23
Устал бодаться с БСП. Возник вопрос по САБЖу.
Подскажите пож-та может у кого есть какие мысли?
 
 Партнерская программа EFSOL Oblako
   Волшебник
 
1 - 26.12.20 - 16:27
по логину Windows или по имени пользователя
   tabarigen
 
2 - 26.12.20 - 16:50
При помощи МенеджераПользователейИнформационной базы я получасю списик пользователей, пытаюсь вывести их на форму.

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    СписокПользователей = ПользователиИнформационнойБазы.ПолучитьПользователей();
    
    Для Каждого польз из СписокПользователей Цикл
        стр = Список.Добавить();
        стр.Пользователь = польз;
    КонецЦикла;    
КонецПроцедуры

Получаю ошибку.
{Справочник.Пользователи.Форма.ФормаСписка.Форма(8)}: Ошибка при установке значения атрибута контекста (Пользователь)
        стр.Пользователь = польз;
по причине:
Тип "ПользовательИнформационнойБазы" не может использоваться в данных формы
Тип "ПользовательИнформационнойБазы" не может использоваться в данных формы
   tabarigen
 
3 - 26.12.20 - 16:51
Где Список это ТаблицаЗначений а Пользователь ее реквизит с типом "ПроизвольныйТип".
Что со мной не так?
   Конструктор1С
 
4 - 26.12.20 - 16:58
У пользователя ИБ есть методы ИмяПользователя() и другие. Дёргай их и будет тебе щасте
   alkorolev
 
5 - 26.12.20 - 18:13
(0) так же, как и в БСП - по свойству "УникальныйИдентификатор" (в справочнике обычно называется "ИдентификаторПользователяИБ")
   alkorolev
 
6 - 26.12.20 - 18:14
(4) у пользователя ИБ есть только 2 метода: записать и удалить
   alkorolev
 
7 - 26.12.20 - 18:16
(2) ...
    СписокПользователей = ПользователиИнформационнойБазы.ПолучитьПользователей();
    
    Для Каждого польз из СписокПользователей Цикл
        стр = Список.Добавить();
        стр.Пользователь = польз.Имя;
        стр.ИдентификаторПользователяИБ = польз.УникальныйИдентификатор;
    КонецЦикла;    
КонецПроцедуры
   Конструктор1С
 
8 - 26.12.20 - 18:23
(6) тогда свойства дёргать...

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.