Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Создание регламентного задания

Создание регламентного задания
Я
   HelpMePlz
 
26.12.20 - 14:44
Добрый день. У меня такая проблема. Я сделать так что бы у у меня работало регламентное задание.
Что я сделал?
Первое я создал общий модуль во вкладке "Общее" модуль назвал его "РегЗаданиеОбменССайтомЗапчастей" в свойствах установил галочки "Сервер" и "Клиент".
Создал в модуле процедуру
код {
Процедура ОбменССайтомЗапчастей() Экспорт
    Выгрузка = Обработки.ОбменССайтомПоПродажеЗапчастей.Создать();
    Выгрузка.ИмяПроцедуры("РегЗадВыгрузка");    
КонецПроцедуры
} код
Второе я создал регламентное задание. Назвал его "ОбменССайтомЗапчастей", Имя метода назвал "РегЗаданиеОбменССайтомЗапчастей.ОбменССайтомЗапчастей".
Установил галочки "Предопределенное" и "Использование".
Третье Я создал обработку навал ее "ОбменССайтомПоПродажеЗапчастей". Добавил туда 1 реквизит. и форму
Код формы
Код {
Процедура ВыгрузкаНажатие()
    
    ПутьХранения = Строка("D:\Путь\Запчасти.xml");
    ФайлXML      = Новый ТекстовыйДокумент;
    ФайлXML.Записать(ПутьХранения);

КонецПроцедуры

Процедура РегЗадВыгрузка() Экспорт
    ВыгрузкаНажатие();
КонецПроцедуры

Процедура ОсновныеДействияФормыОсновныеДействияФормыВыполнить(Кнопка)
    
КонецПроцедуры
} код
А регламентное задание все равно не выполняется. Подскажите если что не так сделал.
   ДедМорроз
 
1 - 26.12.20 - 14:51
Выгрузка.ИмяПроцедуры это что за зверь?
Экспортную процедуру можно вызывать через точку,если она в модуле обработки,а не модуле формы.
На сервере,где будет выполняться задание,у обработки формы нет.
   HelpMePlz
 
2 - 26.12.20 - 15:03
(1) А можно как то с помощью отладки пройтись когда регламентное задание запускается? Что бы проверить вообще работает ли оно ?
   МимохожийОднако
 
3 - 26.12.20 - 19:12
(2) Да.
   DJ Anthon
 
4 - 26.12.20 - 20:22
(2) для этого в отладке - подключение включи галочку автоматически подключать фоновые задания
   Cthulhu
 
5 - 27.12.20 - 00:11
а расписание-то онастроил?
   HelpMePlz
 
6 - 27.12.20 - 13:52
(5) да настроил
   HelpMePlz
 
7 - 27.12.20 - 14:08
(4) Я вроде сделала так, но меня все равно даже не выкидывает в отладку. Я же правильно понимаю меня должно выбрасывать в общий модуль к которому привязано Регламентное задание. Это значит что Регламентное задание не выполняется ?
   Cthulhu
 
8 - 27.12.20 - 14:12
Консоль
   MihailShesternev
 
9 - 27.12.20 - 14:14
Посмотри журнал сообщений, обычно там показана ошибка если порвалась задача
   Cthulhu
 
10 - 27.12.20 - 14:19
   HelpMePlz
 
11 - 29.12.20 - 19:06
Спасибо большое

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.