Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вывод внешней печатной формы

Вывод внешней печатной формы
Я
   maestro-72
 
23.12.20 - 10:46
Вопрос в следующем. ут11.4 подключаемая печатная форма. Но существует условие по которому эта печатная форма не должна появляться. К примеру мы готовим форму по определенному виду товара а его может не оказаться в накладной ну это как вариант для понимания. Вопрос. Возможно ли на этапе обработки отказаться от вывода табличного документа? (вопрос зачем не рассматривается пока, оценивается возможность). поискал по форумам, ничего не нашел
   SadrArt
 
1 - 23.12.20 - 10:57
(0) не ясно излагаете, где не должна появляться?
   SadrArt
 
2 - 23.12.20 - 10:58
пустой табличный документ покажите (или верните)
   maestro-72
 
3 - 23.12.20 - 10:59
(2) пустой табличный документ вызывает исключение
   maestro-72
 
4 - 23.12.20 - 11:01
Нужно просто - оценка - нечего выводить - отказ от вывода табличного документа (операторы шлепают на автомате, им некогда следить есть там в накладной нужная номенклатура, нет ее... просто если нет, печататься ничего не должно, есть должно)
   SadrArt
 
5 - 23.12.20 - 11:04
(3) должно быть что то типа штатное "Печатная форма не сформирована", вот это называете исключением?
   SadrArt
 
6 - 23.12.20 - 11:05
Вообще, без кода сложно сказать, что у там

Например есть ли такая строка

УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, ИмяМакета, "Заголовок табличного документа", СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати));



?
   mikecool
 
7 - 23.12.20 - 11:12
на ОФ при подключении ВПФ можно было отборы задавать, в УФ кажется тоже - тогда форма не должна вообще в доступных светиться
   Фрэнки
 
8 - 23.12.20 - 11:14
(0) если не затруднит, то выложи нужную ВПФ - посмотрю, оставили там возможность для вставки кода или нет.
   SadrArt
 
9 - 23.12.20 - 11:16
(7) вряд ли в УФ есть такое.
   Фрэнки
 
10 - 23.12.20 - 11:16
(9) ну вот и я помню, что для ОФ такое было, а для УФ уже нет.
   maestro-72
 
11 - 23.12.20 - 11:38
(10) Ну скорее всего да, нет, видимо это связано с особенностью платформы. Я пока не понял почему нельзя было к примеру какой нибудь признак типа "отказ" поставить в истину, чтобы было понятно что табличный документ не нужен. А по поводу того что кнопка появляется или не появляется. представте в печатной форме запрос на три листа для оценки, тоже самое, ну или почти придется для условия прописывать. (6) Да, именно. Я не вижу смысла выкладывать код, он стандартный, просто в процедуре печать() по идее должно быть условие печатать не печатать и все.
   maestro-72
 
12 - 23.12.20 - 11:39
Видимо придется как то по другому изворачиваться.
   SadrArt
 
13 - 23.12.20 - 11:45
Если вот так:

Печатать = Истина;
СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати, Печатать);
Если Печатать Тогда
УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, ИмяМакета, "Заголовок табличного документа", ТабДок);
КонецЕсли;

Вызывается исключение?
   Aleksey
 
14 - 23.12.20 - 11:45
(10) Да и для УФ есть. По крайне мере я в УНФ пару лет назад такое делал (лоступность в зависимости от реквизитов шапки)
   SadrArt
 
15 - 23.12.20 - 11:46
(13) ТабДок = СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати, Печатать); *
   SadrArt
 
16 - 23.12.20 - 11:46
(14) в списке при выделении строк с противоречивым условием доступность какая?
   ДенисЧ
 
17 - 23.12.20 - 11:47
(14) Расскажи, как. Если подменю печати (в БСП) формируется в менеджере документа, где информации о составе конкретного документа нет
   Aleksey
 
18 - 23.12.20 - 11:48
(17) Разве это не функционал БСП?
   maestro-72
 
19 - 23.12.20 - 11:49
(13) Да, так пробовал, в ошибку вылетает
   ДенисЧ
 
20 - 23.12.20 - 11:50
(18) Нет. Ещё раз. В БСП вызывается 
Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт
    КомандаПечати = КомандыПечати.Добавить();
    КомандаПечати.МенеджерПечати = "Документ.МойДокумент";  
    КомандаПечати.Идентификатор = "МойДокумент";
    КомандаПечати.Представление = НСтр("ru = 'Мой документ'");
    КомандаПечати.ПроверкаПроведенияПередПечатью = Истина; 
КонецПроцедуры

Это в менеджере. Нет документа.
   Aleksey
 
21 - 23.12.20 - 11:52
(20) я про УправлениеПечатью.ДобавитьУсловиеВидимостиКоманды
   ДенисЧ
 
22 - 23.12.20 - 11:54
(21) Хм... Не знал... А сайт итса лёг что-то... Раньше не видел. Надо проверить...
Спасибо за инфу, если это сработает...
   maestro-72
 
23 - 23.12.20 - 11:55
//ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина;

    Для Каждого Док ИЗ МассивОбъектов Цикл
        
        Если Не НужноВыодитьПечатнуюФорму(Док) Тогда
            Продолжить;
        КонецЕсли;
        
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
        КоллекцияПечатныхФорм,
        "Маршрут",
        НСтр("ru = 'Маршрут'"),
        СформироватьПечатнуюФорму(Док));
    КонецЦикла;
Вот так пытался, ошибку дает
   ДенисЧ
 
24 - 23.12.20 - 11:57
(23) Какую?
   Aleksey
 
25 - 23.12.20 - 11:58
(22) Но там только на шапку, на ТЧ не поставишь.

Атак у команды печати есть еще один "реквизит" Обработчик. В него пробросятся ПараметрыПечати. В нем уже проверяешь реквизиты. Если условие выполнено — вызываете УправлениеПечатьюКлиент.ВыполнитьКомандуПечати(), если нет — исключение.

типа
КомандыПечати.Обработчик    = "УправлениеПечатьюБПКлиент.ВыполнитьКомандуПечати";
   Aleksey
 
26 - 23.12.20 - 12:02
О ИТС ожил
   Aleksey
 
27 - 23.12.20 - 12:03
Правда сервис авторизации лежит...
   maestro-72
 
28 - 23.12.20 - 12:18
(25) Я в 8 недавно (в смысле совсем) можно для чайника объяснить как это должно быть на простом примере. И - исключение нам не надо... Надо чтобы просто ничего не печаталось.
   maestro-72
 
29 - 23.12.20 - 12:19
(24) ТАм функция проверки стоит, определяет нужно ли выводить на печать, а вообще не понял о чем вопрос


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.