Вход | Регистрация
 

Заполнение таблицы значений на форме обработки

Заполнение таблицы значений на форме обработки
Я
   NIGHTHUNTER
 
23.12.20 - 03:17
УФ. На форме обработки таблица значений. Считываю данные с файла и добавляю в эту таблицу значений.
Как нужно добавлять строки в таблицу расположенную на форме обработки. Пробую имеющийся код, но везде идут ошибки.

        НоваяСтрока    = ТаблицаЗагрузки.Добавить();

            ТекущееЗначение          = МассивКолонок[НомерКолонки - 1];
            //
            ИмяКолонки               = ТаблицаЗагрузки.Колонки[НомерКолонки - 1].Имя;             
            НоваяСтрока[ИмяКолонки]  = ТекущееЗначение;            
            //
   NIGHTHUNTER
 
1 - 23.12.20 - 03:19
ТаблицаЗагрузки - ДанныеФормыКоллекция

и все.

ТаблицаЗагрузки.Колонки[НомерКолонки - 1].Имя

это уже не работает.
   NIGHTHUNTER
 
2 - 23.12.20 - 03:21
Нужно навреное у обработки создавать табличную часть и таблицу значений связывать с ней?
   hhhh
 
3 - 23.12.20 - 03:38
(1) выбрось всю эту хрень. Есть же нормальный способ

ТаблицаЗагрузки.Загрузить(Запрос.Выполнить().Выгрузить());
   H A D G E H O G s
 
4 - 23.12.20 - 03:40
(3) Это ЛивингСтар
   H A D G E H O G s
 
5 - 23.12.20 - 03:41
Сук, это все что я могу родить в этой ветке
https://youtu.be/2d9q4r54fco
   H A D G E H O G s
 
6 - 23.12.20 - 03:44
Еще можно покрасить это черным
https://youtu.be/niCG-LDrN9Q
   H A D G E H O G s
 
7 - 23.12.20 - 03:46
Давайте, ребят, ударим унынием по этому празднику жизни и феерии тупости!
https://youtu.be/ZeMlQEWEg2Q
   H A D G E H O G s
 
8 - 23.12.20 - 03:49
Единственное, хорошо, что мы это видим уже 10 год тут, на форуме 1С-ников.
А не ребята в энергетике или медицине.
   NIGHTHUNTER
 
9 - 23.12.20 - 05:07
(3) Совсем нет!!! Я гружу с файла!!! Фот что помогло, -
    ПреобразованнаяТЗ = РеквизитФормыВЗначение("ТаблицаЗагрузки");
    //

    ПрефиксУстановлен = 0;
    Для НомерСтроки = 2 по ЗагружаемыйФайл.КоличествоСтрок() Цикл
        Строка        = ЗагружаемыйФайл.ПолучитьСтроку(НомерСтроки);
        Если Не ЗначениеЗаполнено(Строка) Тогда
            Продолжить;
        КонецЕсли;
        МассивКолонок = РазложитьСтрокуВМассивПодстрок(Строка,Разделитель);
        //        

        НоваяСтрока    = ПреобразованнаяТЗ.Добавить();
        //

        НоваяСтрока2   = ТаблицаЗагрузки2.Добавить();
        //

        Для НомерКолонки = 1 по МассивКолонок.Количество() - 1 Цикл 
            //

            Если МассивКолонок[НомерКолонки - 1] = "XXX" Тогда
                Продолжить;
            КонецЕсли;
            ТекущееЗначение          = МассивКолонок[НомерКолонки - 1];
            //

            ИмяКолонки               = ПреобразованнаяТЗ.Колонки[НомерКолонки - 1].Имя;             
            НоваяСтрока[ИмяКолонки]  = ТекущееЗначение;            
            //

            ИмяКолонки               = ТаблицаЗагрузки2.Колонки[НомерКолонки - 1].Имя;             
            НоваяСтрока2[ИмяКолонки] = ТекущееЗначение;            
            //

        КонецЦикла;           
    КонецЦикла;   
    ЗначениеВРеквизитФормы(ПреобразованнаяТЗ, "ТаблицаЗагрузки");

Список тем форума
 
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.