Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Записать данные в программно созданную колонку формы

Записать данные в программно созданную колонку формы
Я
   Дождик_1
 
21.12.20 - 11:51
Добрый день.
Имеется табличная часть Фильтры элемента справочника.
При открытии в форму добавляется временная колонка, которую нужно заполнить справочными данными. Хранить их не нужно.
Приведенный код формирует колонку, но данные не пишет.
Подскажите, пожалуйста, где ошибка?

НоваяКолонка = ЭлементыФормы.Фильтры.Колонки.Вставить(2,"Код");
НоваяКолонка.Имя = "Код";

ТабличноеПоле = ЭлементыФормы.Фильтры;
    
Для Каждого ТекущаяСтрока Из ТабличноеПоле Цикл
       ТекущаяСтрока.Код = ТекущаяСтрока.НоменклатурнаяГруппа.Код;
КонецЦикла;
   ДенисЧ
 
1 - 21.12.20 - 11:56
Туды нельзя ничего записывать.
Туды можно только выводить.
Судя по ЭлементыФормы - у тебя обычные формы. Значит, рисуй в ПриПолученииДанных()
   Дождик_1
 
2 - 21.12.20 - 13:19
Спасибо за подсказку!

Результат:
[1c]
Процедура ПриПолученииДанных(Элемент, ОформленияСтрок)
    
    Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
    
        ОформлениеСтроки.Ячейки.Код.Значение = ОформлениеСтроки.Ячейки.НоменклатурнаяГруппа.Значение.Код;    
        
    КонецЦикла;
    
КонецПроцедуры
[1c]

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.