Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Может кто помнит как правильно запрос составить в таком случае (1c v7.7)

v7: Может кто помнит как правильно запрос составить в таком случае (1c v7.7)
Я
   Джордж1
 
12.12.20 - 17:47
Справочник С двумя Реквизитами Товар Аналог Количество
Товар и Аналог имеют один и тот же вид - Справочник Товар

Надо вывести итоги по товарам.

Но, если выбран Аналог - то в отчет включить именно аналог
   Джордж1
 
1 - 12.12.20 - 17:48
Пойдет даже самый кривой способ. Данных не много
   Chameleon1980
 
2 - 12.12.20 - 17:50
поле=и через запятую к ним пробовал?
   Джордж1
 
3 - 12.12.20 - 17:51
(2)не работает
   Chameleon1980
 
4 - 12.12.20 - 17:52
ну покажи как сделал и что значит не работает?
   ДенисЧ
 
5 - 12.12.20 - 17:54
ЯНХНП
Пример покажи
   Джордж1
 
6 - 12.12.20 - 17:57
|Обрабатывать НеПомеченныеНаУдаление;
    |КатегорияГодности = Справочник.Призыв.КатегорияГодности,Справочник.Призыв.КатегорияГодности2;
    |КатегорияГодности2 = Справочник.Призыв.КатегорияГодности2;
    |РВК = Справочник.Призыв.РВК;
    |Функция Количество=Счётчик() Когда (ПустоеЗначение(КатегорияГодности2)=1);
    |Функция Количество2=Счётчик() Когда (ПустоеЗначение(КатегорияГодности2)=0);
    |Группировка РВК все;
    |Группировка КатегорияГодности все;";
   Garykom
 
7 - 12.12.20 - 18:19
(6) гы
   hhhh
 
8 - 12.12.20 - 19:39
(6) и где тут товар?
   Джордж1
 
9 - 12.12.20 - 20:13
(8) какая разница товар или нет
Просто аналогию поивел ближе к 1с
   Cthulhu
 
10 - 12.12.20 - 21:48
(9) а накера аналогию-то?.. тут принято отвечать на вопросы, подобные твоему, в форме "я вот так делаю - получается не то что надо, а на самом деле надо чтоб получалось то-то..."
а в форме "сделайте за меня" - ответ один: "пригласите программиста" (с)
   Джордж1
 
11 - 12.12.20 - 22:00
(10) это где вы такое увидели - сделайте за меня.
у меня задача в общем виде - замена значения для группировки
   Lazy Stranger
 
12 - 12.12.20 - 22:37
(11) в запросе точно не получится значение заменить: выгружать в ТЗ и уже там извращаться
   Cthulhu
 
13 - 13.12.20 - 02:22
(11): да везде. потому что НЕ /тут принято отвечать на вопросы, подобные твоему, в форме "я вот так делаю - получается не то что надо, а на самом деле надо чтоб получалось то-то..."/.
   Cthulhu
 
14 - 13.12.20 - 02:23
* НЕ /в форме "я вот так делаю - получается не то что надо, а на самом деле надо чтоб получалось то-то..."/.
   youalex
 
15 - 13.12.20 - 02:32
(8) Справочник.Призыв же ))
https://www.youtube.com/watch?v=90lDX9jS-8o&feature=emb_logo
   Franchiser
 
16 - 13.12.20 - 02:55
(0) такая же проблема 7.7. не правильно компилирует запрос для sql. Делай прямой запрос
   Cthulhu
 
17 - 13.12.20 - 04:00
Пороцедура ДобавитьСуммуПоТовару(Сумма,Товар,ПриемникТЗ);
  ПриемникТЗ.НоваяСтрока(); ПриемникТЗ.Сумма=Сумма; ПриемникТЗ.Товар=Товар;
КонецПроцедуры//ДобавитьСуммуПоТовару


...
|Функция Сумма = Сумма(СуммируемыйРеквизит); Группировка Аналог; Группировка Товар;";
ПриемникТЗ=СоздатьОбъект("ТаблицаЗначений");
ПриемникТЗ.НоваяКолонка("ТоварИлиАналог","Справочник.Товары");
ПриемникТЗ.НоваяКолонка("Сумма","Число");
Пока Запрос.Группировка("Аналог")<>0 Цикл
  Если Запрос.Аналог.Выбран()<>0 Тогда
    ДобавитьСуммуПоТовару(Запрос.Сумма,Запрос.Аналог,ПриемникТЗ);
  Иначе
    Пока Запрос.Группировка("Товар")<>0
    Цикл ДобавитьСуммуПоТовару(Запрос.Сумма,Запрос.Аналог,ПриемникТЗ) КонецЦикла;
  КонецЕсли;
КонецЦикла;
ПриемникТЗ.Свернуть("ТоварИлиАналог","Сумма");
// как-то так...
   Джордж1
 
18 - 13.12.20 - 09:22
(12,17)Есть и еще способы. Но т.к. нужна кросс-таблица, самый простой вариант виделся через запрос
Через ТЗ сложнее - нужно несколько ТЗ, поиск нужен, отсев пустых значений и т.п.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.